•   
  • 1
  • 21
  • 22
  • 23(current)
  • 24
  • 25
  • 85
  •   
[RELEASE] Steam Launcher - Start Steam Big Picture Mode from within Kodi
(2014-06-06, 08:17)teeedubb Wrote: Sigh... I was hoping this one would be bug free Sad Can you post a xbmc.log file of this happening? There will be a update when I work out what the problem is, but for now you can downgrade via xbmc's gui.

Don't worry, maybe it is just because of my system, XBMC runs pretty unstable since the last few days. Maybe i've installed to many addons.

I am using 0.9.15 right now and everything is good. The "quit-dialog" isn't showing up and xbmc quits anyway when i start steam, but that is ok.
Reply
(2014-06-06, 16:01)morbo24 Wrote: Hey,

I have an XBMCbuntu config and the launcher does not work Sad.
When I start steam with the launcher I just get a black screen and the stuttering sound of the steam big picture intro.

When I start steam manually in an openbox session with 'DISPLAY=:0 steam -bigpicture' it works without any issue.

Any idea what I have wrongly configured? It looks like the launcher does not start a openbox session?

Sounds like you're running the addon with XBMC in its own session - this wont work. Whats the output of
Code:
DISPLAY=:0 wmctrl -l
when steam is launched via the addon and you get the black screen? The addon itself wont launch openbox, you need to configure xbmcbuntu to boot into openbox instead of a xbmc session, see the first post.

(2014-06-06, 16:33)gibxxi Wrote: I started the 1.0.0 version earlier on my HTPC and it started fine. As it was the first startup of the day, Steam did the usual "Checking for Updates" routine before launching the UI, but it did start properly. XBMC Seems to have closed, and it restarted fairly quickly upon exiting Steam as well.

You do have a typo in your "Updated Scripts" dialog box though, two words repeated in the the dialog. That's the only issue I could see. This is on W7-Pro SP1. Will try the same on my desktop at some point as I have a copy of XBMC installed there for testing purposes.

Cheers, will fix.
Reply
Hi teeedubb,

Back again, just been attempting to set up XBMC on my old HTPC I'm donating to a friend, and Although the changes in 1.0.0 work to successfully launch XBMC as per my previous posts in this thread, with XBMC using portable mode, and Steam in it's default location, XBMC is restarted incorrectly. Specifically, the "-p" switch is not being passed by the script, so when XBMC restarts, the configuration is bare (as there is none).

Here's the line from the log:

Code:
13:31:54 T:4708  NOTICE: script.steam.launcher: attempting to launch: "D:\XBMC Media Center\portable_data\userdata\addon_data\script.steam.launcher\scripts\LaunchHidden.vbs" "D:\XBMC Media Center\portable_data\userdata\addon_data\script.steam.launcher\scripts\SteamLauncher-AHK.exe" "C:\Program Files (x86)\Steam\steam.exe" "D:\XBMC Media Center\XBMC.exe" "0"

It works for me I guess, because I had previously symlinked the "%Appdata%\XBMC" folder on my new system to the "portable_data" folder anyway. This isn't a viable long-term option for my less XBMC-savvy friend.

I guess we need an option in the add-on configuration options to specify if XBMC is running in portable mode, and if so modify the output script based on that setting.
Image
Reply
Will look at adding something like that, but for now you can modify the entry in the settings.xml file in ...xbmc/userdata/addon_data/script.steam.launcher/ to look like

<setting id="XbmcWin" value="E:\a a a a a\XBMC\XBMC.exe -p" />

You need to disable file path checks in the addons settings.
Reply
I am also having problems relaunching xbmc with the -p option.

I've edited the settings file as specified and disabled path checking via the GUI, but I keep getting the default xbmc launch.

I am running under Win7. Any ideas?

Thanks!
-J
Reply
You can make a batch file for xbmc and point the addon to that:

xbmc.bat
Code:
e:
cd "E:\a a a a a\XBMC\"
xbmc.exe -p
Reply
hey updated steam a day ago and now the add-on isnt working.

any help please thanks?

it was working prefecrtly before. on 1.0.0
Major Props Poofy and Eskro! Check out their sigs for the best help/advice.
Reply
revert back to 1.0.0 for now, next version will remove the changes
Reply
Version 1.0.4 in OP
Quote:Scripts need to be updated for this version!
Reverted 'call' command in windows.
Added addon setting for pre/post steam scripts. The addon will wait for the script to finish before continuing.
Added portable mode option (osx doesnt have a portable mode, enabling this will cause xbmc not to restart)
Increased default busy dialog to 10 seconds.
Heap of small changes.

1.0.5
Quote:Small fix in steam-launch.sh for xbmc not restarting if steam exited quickly after opening.

v1.0.6
Quote:Fix unnecessary 'script not executable' dialog when deleting scripts.
Reply
Thanks teeedubb,

Will test later/tomorrow and report back. Smile
Image
Reply
I said it before and I'm saying it again now, I <3 this addon. It turned my XBMC onto a 'Game Console' and it's the best. Planning for a new living room HTPC, I got a used Radeon HD 6950 just so it was ready for Steam BPM like my first box. There's a Steam sale starting on the 19th and that is what turns the XBMC/Steam box into the BEST console. :3 (Though it's probably the only console that'll switch to desktop and be like 'Time to install updates! :3' at 3AM...)
Reply
Glad you like it Smile I've got a love/hate relationship with those sales... I don't need any more games but I can't say no to those prices. Yeah windows update suck and it took me a while to pinpoint it as the stealing focus culprit. From what I've read there is no way to prevent auto updates stealing focus so I've disabled them... Good one MS!
Reply
The add-on has given me some problems with the reliability of launching steam. Sometimes I will open steam and go right into big picture mode, but other times I will open steam, exit, then I am unable to re-open steam. The only way I am able to open steam is to stop steam in task manager, run a script to kill it, or restart the system completely. I tried pointing to a script that kills steam into the "run before/after" option in the advanced settings, but steam does not seem to close even then. Is there something I can do to make sure that the steam launcher is completely reliable?
Reply
Youre running windows right? So Steam does not open at all after running the addon? In BPM mode and desktop mode? Have you tried running steam from the command prompt when you have this problem?

If steam desktop mode is open: steam.exe steam://open/bigpicture
Or
If steam is not running at all: steam.exe -bigpicture

Also running the addon commands from a cmd prompt may shed some light on what's up. Have a look in the xbmc.log file to see the command that is passed on. And post your log file here too!
Reply
I tried to install the repo from both zip files on your github page and I get an "Add-on does not have the correct structure" error. Am I doing something wrong?
Reply
  •   
  • 1
  • 21
  • 22
  • 23(current)
  • 24
  • 25
  • 85
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Steam Launcher - Start Steam Big Picture Mode from within Kodi7
This forum uses Lukasz Tkacz MyBB addons.