•   
  • 1
  • 23
  • 24
  • 25(current)
  • 26
  • 27
  • 85
  •   
[RELEASE] Steam Launcher - Start Steam Big Picture Mode from within Kodi
Looks like it is possible to run Steam in OE, although it is 32bit only http://wiki.openelec.tv/index.php/Steam
I havent had much luck running OE in a VM and I dont have a 32bit install to test on, so if you can give me the commands used to start steam I should be able to intergrate OE support into the addon.

But since you have win8 have you considered dual booting, with windows only for gaming (or even linux/steamOS)? My Reboot2oOS addon makes dual booting easy http://openelec.tv/forum/128-addons/6235...another-os
Reply
(2014-07-02, 06:41)teeedubb Wrote: Hmmmm.. It may be possible to logout of the xbmc session so its not running, and running xbmc will autologin to the xbmc session. There is some info here regarding logging out of sessions from the command line: http://askubuntu.com/questions/180628/ho...-using-cli

Can you try some of the methods listed there and report back? I won't have a chance to try for at least a week.
Nothing seems to work :-(

(2014-07-02, 06:41)teeedubb Wrote: Also, does xbmc stay running if you exit the xvmc session via xbmc's GUI?
XBMC is restarting immediately
Reply
My Win 8.1 is 64 bit, I looked at the link you gave for your dual boot, looks a bit daunting for my limited knowledge but will have a in depth look later, cheers...
Reply
@buzzer, try this:

/usr/bin/xbmc-sl
Code:
#!/bin/bash

while [[ -f /tmp/xbmc.disabled ]] ; do
        sleep 1
done

xbmc $@

/usr/bin/xbmc-pre-steam (you need to point the addon to use this as the pre steam script)
Code:
#!/bin/bash

touch /tmp/xbmc.disabled

/usr/bin/xbmc-sl.sh (you should already have this file from my previous post, change the contents to the following)
Code:
#!/bin/bash

rm -rf /tmp/xbmc.disabled
dbus-send --system --print-reply --dest=org.freedesktop.DisplayManager  /org/freedesktop/DisplayManager/Seat0 org.freedesktop.DisplayManager.Seat.SwitchToUser string:'desktop' string:''

copy /usr/bin/xbmc-standalone to /usr/bin/xbmc-standalone-sl and edit it and make the XBMC= command look like
Code:
XBMC="${bindir}/xbmc-sl --standalone $@"

Now edit /usr/share/xsessions/gnome.dektop and change xbmc-standalone to xbmc-standalone-sl.
Make sure all file created are executable

That prevents xbmc from restarting when run via the addon on my VM.

EDIT: this breaks 'return to desktop' in steam bpm, so disable access to the linux desktop in steam's settings.
Reply
ohh wow it's working :-)
Thx for the help and your awesome addon.
Reply
I have the following problem

when i exit steam (after launching it from XBMC) i enter XBMC again , however the remote app i'm using which makes use of the HTTP WEB server of XBMC is unable to reconnect . it seems as if XBMC web server cannot rebind to the same port which was open prior opening Steam.
Reply
Yeah this is probably because the addon doesn't close xbmc cleanly - xbmc can take a long time to quit sometimes. From memory I've only seen this happen on Linux, where a error notification is displayed on xbmc startup as well. I did some testing and my remote app still worked after getting the error, though I didnt test all remote apps/web interface extensively.

What OS are you using? You could make a pre-steam script to kill xbmc cleanly and point the addon to use that.
Reply
using Ubuntu 12.04.4 LTS

how can i create that script ? don't have a clue really...
Reply
Try this one first, I dont get a error when reopening xbmc after this command, although the pc Im using doesnt have web access setup. If this one works well let me know and I will integrate it into the addon, it closes xbmc quickly:

xbmc-pre-steam.sh
Code:
#!/bin/bash
kill $(pidof xbmc.bin)

You can replace the 'kill' line above with a xbmc-send command (you need to install xbmc-eventclients-xbmc-send), which uses a inbuilt xbmc function to quit xbmc, although this takes along time to quit xbmc, atleast on my v14 install. Also this command doesnt wait for xbmc to quit. Note you may need to configure the command to suit your system:

Code:
xbmc-send --action=Quit

Make sure the script file is marked as executable.
Reply
yep i've tried the kill script which killed xbmc, restarted xbmc and web remote could connect back again , so i guess this is working fine (i wonder why you didn't do it like that in the first place Smile )

many thanks
Reply
New version of steam-launch.sh pushed to github, Ill make a new version of the addon in a few days after testing it at home, I cant replicate this problem with xbmc v14 and it hasnt been tested on OSX.

It will attempt to kill xbmc gracefully and then in the background waits 1sec and if xbmc is still running it forcefully closes xbmc.
Reply
replaced the script but still getting the same issue strange :/ do i need to wait for the add-on update ?
Reply
No, replacing the script contents should be enough. Did you try a few times with the pre-steam script and the previous steam-laumch.sh to be sure that using that command killed xbmc nicely? What about if you use the presteam script with the new steam-launch.sh? Also which file did you replace and your pre-steam script was the 'kill' command yeah?
Reply
i replaced the file in

/home/atomsk/.xbmc/userdata/addon_data/script.steam.launcher/scripts/steam-launch.sh
and
/home/atomsk/.xbmc/addons/script.steam.launcher/resources/scripts/steam-launch.sh

i restarted everything:

1.XBMC started with remote working
2.I fired the steam plugin, XBMC closed , steam launched
3.I exited steam, XBMC reopened (fairly quickly as if it was minized) and xbmc remote didn't work again Sad
Reply
What pre steam script did you previously use?
Reply
  •   
  • 1
  • 23
  • 24
  • 25(current)
  • 26
  • 27
  • 85
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Steam Launcher - Start Steam Big Picture Mode from within Kodi7
This forum uses Lukasz Tkacz MyBB addons.