•   
  • 1
  • 24
  • 25
  • 26(current)
  • 27
  • 28
  • 85
  •   
[RELEASE] Steam Launcher - Start Steam Big Picture Mode from within Kodi
the one that came with the addon i guess , i didn't modify anything
Reply
(2014-07-05, 04:41)teeedubb Wrote: Try this one first, I dont get a error when reopening xbmc after this command, although the pc Im using doesnt have web access setup. If this one works well let me know and I will integrate it into the addon, it closes xbmc quickly:

xbmc-pre-steam.sh
Code:
#!/bin/bash
kill $(pidof xbmc.bin)

You can replace the 'kill' line above with a xbmc-send command (you need to install xbmc-eventclients-xbmc-send), which uses a inbuilt xbmc function to quit xbmc, although this takes along time to quit xbmc, atleast on my v14 install. Also this command doesnt wait for xbmc to quit. Note you may need to configure the command to suit your system:

Code:
xbmc-send --action=Quit

Make sure the script file is marked as executable.

Which of these two did you use where it worked?
Reply
ah sorry , first one Smile

#!/bin/bash
kill $(pidof xbmc.bin)
Reply
Strange, that's what's the steam-launch.sh script . Does enabling that pre-steam script help with the new version of steam-launch.sh?
Reply
this is very strange ..i'm confused, the pre XBMC script is running fine (with the only difference that i'm running xbmc manually by clicking the icon after steam exits). I'm starting to believe that there's no problem when exiting XBMC but when rerunning it after steam exits , i've tried modifying your script (steam-launch.sh) using xbmc-send --action=Quit as well but i get the same issue.

If do
1. kill -9 $(pidof xbmc.bin) -> xbmc exits, connection to web server is lost
2. and start XBMC by clicking icon -> web server starts again with xbmc and remote reconnects

maybe there's some sort of bug with the previous version of xbmc (not using gotham)

i think i'll call it quits , thanks anyway
Reply
I'll have a closer look at it in the next few days when I'm at the machine where i ve seen the error... Maybe it isn't a issue with xbmc14...
Reply
Youre right it only occurs when launching xbmc via the addon - not sure why it causes this error, the commands are pretty much the same... But I think I have a workaround - if i have only 'Allow programs on this system to control XBMC' enabled in system > services > remote control I always get the error and changing to another port in xbmc's webserver settings doesnt help. If I enable 'Allow programs on other systems to control XBMC', so both options are enabled, I dont get the error. But in saying that, with only 'Allow programs on this system to control XBMC' enabled, a few seconds after I get the popup error message I am able to control xbmc via the web interface. Not sure why enabling that option gets rid of the error message.
Reply
Ok I have tested on 3 different linux machine and its the same on all of them: with only 'Allow programs on this system to control XBMC' enabled I get the error on restart, with both option enabled I get no error. While I get a few hits googling the error, I couldnt find much info on solutions. Launching steam-launch.sh via command line and the error does not occur, so this point to the cause being because it is launched by xbmc, but why I do not know. Using a pre-steam script to close xbmc using a inbuilt function and wait for xbmc to completely exit on its own before continuing does not help either...

Confusedhrugs:
Reply
Thanks for great work & support

Maybe you could help with one issue I've got. When I run steam first time after my htpc boot it works almost perfectly. Steam opens in big picture, windows task bar is visible (but I made it to autohide so not a big deal) and steam is focused, so can navigate to library, open games etc.

However, when I exit steam, return back to xbmc and try to run it again it will open steam but also windows start menu will pop up and steam loses focus. I need to press ESC on keyboard to bring back steam window. Not sure why this is happening, maybe there's a way to keep steam focused or disable start menu opening ?

I'm running Windows 8.1 with xbmc launcher to autorun xbmc on boot
Reply
Hmmm Ive never seen that before and the ahk script gives either xbmc/steam focus after they are detected. I think because there is a small overlap with them running, the xbmc launcher is causing this. Do you have 'force focus' or something like that enabled in the xbmc launcher?

You could also run a pre steam script to force focus on steam for x seconds. You need two file because you want it to run in the background.

pre-steam.bat (point the addon to this)
Code:
start c:\path\to\your\focus_steam_kodi.exe

focus_steam_kodi.exe
Code:
;Script to maximise and focus on either Steam BPM and Kodi for a defined period of time
#NoEnv
#SingleInstance force
SetWorkingDir %A_ScriptDir%

;Time to sleep (in milliseconds) between loops:
LoopFrequency = 500

;Time to run loop for (in milliseconds):
LoopTotalTime = 5000

;Uncomment below to force script to wait for Steam BPM before starting focus loop
;WinWait, Steam ahk_class CUIEngineWin32
;;;;;;;;;;

;Uncomment below to force script to wait for Kodi before starting focus loop
;WinWait, Kodi ahk_class Kodi
;;;;;;;;;;

;focus loop
start := A_TickCount
loop
{

;Uncomment below to maximise and force focus on Kodi;;;;;;;;;;;;;;;
;    IfWinExist,  Kodi ahk_class Kodi
;    {
;          WinMaximize, Kodi ahk_class Kodi
;        WinActivate, Kodi ahk_class Kodi
;    }
;;;;;;;;;;

;The following is to maximise and force focus on Steam BPM;;;;;;;;;
    IfWinExist, Steam ahk_class CUIEngineWin32
    {
        WinMaximize, Steam ahk_class CUIEngineWin32
        WinActivate, Steam ahk_class CUIEngineWin32
    }
;;;;;;;;;;

    sleep, %LoopFrequency%
    now := A_TickCount-start
    if now > %LoopTotalTime%
        break
}
return

ExitApp

It runs every 0.5 seconds for 25 seconds, you can adjust this by changing 500 + 50000 (milliseconds). It can also work for xbmc, just uncomment the code. Youll need autohotkey installed to compile it to a exe.
Reply
Running the following and need help:

Mac OS 10.9.4
XBMC 12.1
Steam (windows version through WINE)

XBMC runs fine
Steam runs fine - In order to launch (direct from applications folder), I double click a wineskin...

The Steam Launcher script executes, does *not* start steam, then returns to XBMC.

What is the correct path for the settings for steam location? I've basically used the OSX Steam Location for /wineskin/steam.app. Full location is in the Get Info screenshot here: http://imgur.com/u2wrfbo
Reply
Does normal osx steam work ok? You can find the command you need by using 'open' from a terminal, eg

open /Applications/Steam.app/

Note that the osx portion of the script launches programs using a directory.

EDIT: I don't think simply changing the path for steam will be enough - the addon looks for the running process 'steam.sh'. Since steam doesn't run but xbmc restarts you could make a pre-steam script (or rewrite steam-launch.sh to do what you want) to launch steam via wine and wait for it to exit, which will the run the rest of the script and restart xbmc.
Reply
New version:
Code:
1.2.2
Basic support for Android added. This simply launches the Steam app. Only options that work are 'busy dialog timeouts'. Closing XBMC requires root rights (at least using 'kill' via adb), and anyway, is there any point to closing XBMC on Android?
Script files attempt to close xbmc gracefully, then in the background wait 1 second and if xbmc still exists it will be closed forcefully.

1.9.4
New settings layout - only OS specific settings are shown.
Steam-launch.sh is made executable automatically when necessary and the option do so is removed.
Rewrote default.py - added extra logging and trimmed it down and cleaned it up a bit, should work better now.
New locking mechanism to try and prevent xbmc restarting multiple instances on linux if addon run multiple times
Changes to included scripts

1.9.6
fixed error notifications
cleaned up launching commands
addon check if checks if pre/post steam scripts exist, if not disables them.
small fixes
Reply
Hi first post here. Been using XBMC on a raspberry pi for over a year and upgraded to an Intel NUC this weekend.

teeedubb: Thanks a lot for your plugin and your guidance, thanks to you I was able to set up XBMCbuntu and steam together this weekend.

If you don't mind: I have a few remarks about your XBMCbuntu guide that could help new users. Some of it might be errors on my side, but this is all a result from following your guide to the letter and then trying to fix what went wrong:
  • Changing my user-session to Openbox didn't work, the config file appears to be ignored, maybe it uses a different one now? What I did instead was exit XBMC and at the login screen press 'F9' to open the windowmanager selection box (the button itself falls outside the screen on my TV) and select Openbox there. This time the change was permanent.
  • $HOME/.config/openbox/ doesn't appear to exist until you launched it at least once
  • Steam complains about missing 32-bit libraries the first time I try to run it. Was quickly solved with sudo ln -s /usr/lib/i386-linux-gnu/mesa/libGL.so.1 /usr/lib
  • wmctrl is not installed on XBMCbuntu by default, so installing it is an important step.

Final step is getting that Valve xpad driver to work in XBMC (works great in Steam though), but I am not the only one struggling with that and it has nothing to do with your addon Smile
*edit* I couldn't get your jsonrpc trick for my gamepad working at first. Then I released that the default port for jsonrpc in current XBMCbuntu builds is 8080, not 9191. I changed the portnumbers and now my gamepad works like a charm on bootup Big Grin
Using XBMCbuntu on Intel NUC DN2820FYKH
Reply
Cheers. I'll add that info to the guide in the next few days - I've been meaning to make a few other changes too.
Reply
  •   
  • 1
  • 24
  • 25
  • 26(current)
  • 27
  • 28
  • 85
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Steam Launcher - Start Steam Big Picture Mode from within Kodi7
This forum uses Lukasz Tkacz MyBB addons.