•   
  • 1
  • 22
  • 23
  • 24(current)
  • 25
  • 26
  • 82
  •   
[RELEASE] Steam Launcher - Start Steam Big Picture Mode from within Kodi
Github has changed the way downloads are handled and you need to download the raw version. Does it work with this link?

https://github.com/teeedubb/teeedubb-xbm...-1.0.1.zip
Reply
(2014-06-18, 01:00)teeedubb Wrote: Github has changed the way downloads are handled and you need to download the raw version. Does it work with this link?

https://github.com/teeedubb/teeedubb-xbm...-1.0.1.zip

Bingo! That got it installed. Thank you!
Reply
@guttermonk, I'm curious, how were you downloading the repo previously?
Reply
For other reasons I had to re-install windows on my system. With a fresh install everything seems to be working fine. Thanks for the help and the creation of the add-on. I'll be back if I need any more help. Thanks Smile
Reply
Trying this out before I create my ultimate media center box. Using Win 7 32 bit default XBMC location steam is installed on seperate drive. using 1.0.6. Just sits there "working" doesn't close or open steam here is the log file as well. http://xbmclogs.com/show.php?id=231698

Any help would be great.
Reply
I just want to say thanks, and that this is a great utility! I do have one question, how hard would it be to modify this launcher to start Skype (on Windows)... or any other app?
Reply
@TSX06 Does running the following give any output?

Code:
"C:\Users\BEDROOM\AppData\Roaming\XBMC\userdata\addon_data\script.steam.launcher\scripts\LaunchHidden.vbs" "C:\Users\BEDROOM\AppData\Roaming\XBMC\userdata\addon_data\script.steam.launcher\scripts\SteamLauncher-AHK.exe" "D:\Program Files\Steam\Steam.exe" "C:\Program Files\XBMC\XBMC.exe" "0" "false" "false" "false"
If that gives nothing try without the first quoted command.
Also because of a recent update, deleting the scripts via the addon settings is necessary, was it working with previous versions?

@djrocketboy not to hard I would think, probably easiest would be to use a early version as this addon simply killed xbmc and then waited for steam to completely exit before restarting xbmc.
Reply
(2014-06-17, 01:11)teeedubb Wrote: Glad you like it Smile I've got a love/hate relationship with those sales... I don't need any more games but I can't say no to those prices. Yeah windows update suck and it took me a while to pinpoint it as the stealing focus culprit. From what I've read there is no way to prevent auto updates stealing focus so I've disabled them... Good one MS!

How many games are we talking about here?

Smile
Image
DT: Intel Core-i7 - 4770K / Nvidia GTX-980 Ti | HTPC: Intel Core-i5 - 4670K / Nvidia GTX-950 | LT: Asus N550JK-CM531H
TV: Sony KDL-40EX524 | AVR: Onkyo TX-NR515 | SPK: 2x Pioneer CS-7070 / 3x Tannoy F1 Custom
Reply
Steam lists 99 games with the newest purchase being xcom enemy unknown (which is a great game and runs well on linux too), arkham origins and street fighter 4, all of which cost me about $25-30 Smile. Theres a few humble indie bundle packs and game bundles (I couldnt say no to a quake bundle for a couple of bucks) in there which bump the numbers up. I do play through the majority of the games, but with owning a ps3 and wii too I could probably go without buying a game for a few years Smile

So how many games are you guys sitting on?

And gibxxi, how is portable mode working for you?
Reply
v1.1.1

Quote:Added fix from 1.0.5 to OSX portion of steam-launch.sh
In linux section of steam-launch.sh the 3rd argument is passed to the pre-steam script. This is for my linux system.
Preliminary SteamOS support. The addon assumes you are running xbmc in the desktop session and when run switches to the steam session (same as the desktop icon). Only option available with SteamOS is 'Quit XBMC' (not quitting XBMC when using the gnome desktop causes problems with Steam on my test system).

For SteamOS users: You can install XBMC 13 from here. By simply adding XBMC to Steam it will run as the steam user and from what I've read it can cause problems, so to avoid this you can use two other methods to launch XBMC - Launch XBMC in its own session (replaces the Desktop session) or launching XBMC in the Gnome desktop session. If you want to launch external programs from XBMC (such as emulators, web browsers etc) it's probably best to run xbmc ontop of the Gnome desktop.

* XBMC ontop of Gnome desktop:
Firstly, you need the program wmctrl installed. Then create a new desktop entry to launch XBMC as the desktop user (there will be two entries for XBMC so you can still run XBMC as the steam user - if you use XBMC as both users you will probably want to symlink/bind mount the two ~/.xbmc directories so you can share user settings/addons/etc..). The new XBMC entry will be called just "XBMC":

/usr/share/applications/xbmc-sl.desktop
Code:
[Desktop Entry]
Version=1.0
Name=XBMC
GenericName=Media Center
Comment=Manage and view your media
Exec=/usr/bin/xbmc-sl.sh
Icon=xbmc
Terminal=false
Type=Application
Categories=AudioVideo;Video;Player;TV;

Steam doesnt like desktop entries using commands with prefixes (in this case sudo), so two script files are necessary - one for steam to launch, which in turn launches the second with sudo rights (this is needed as commands are being executed for different users)

/usr/bin/xbmc-sl.sh
Code:
sudo /usr/bin/xbmc-sl2.sh

/usr/bin/xbmc-sl2.sh
Code:
#!/bin/bash

dbus-send --system --print-reply --dest=org.freedesktop.DisplayManager  /org/freedesktop/DisplayManager/Seat0 org.freedesktop.DisplayManager.Seat.SwitchToUser string:'desktop' string:''

export DISPLAY=:1

until [[ $(sudo -u desktop wmctrl -l |grep "Desktop$") ]] ; do
        sleep 1
done

if [[ $(pidof xbmc.bin) ]] ; then
        sudo -u desktop wmctrl -r "XBMC Media Center" -b add,fullscreen &
else
        sudo -u desktop xbmc &
fi

Make both script files executable. Now to edit the sudoers file to allow the above to be executed without a password prompt. Run sudo visudo and add the following to the end:
Code:
%steam ALL = NOPASSWD: /usr/bin/xbmc-sl2.sh
%desktop ALL = NOPASSWD: /usr/bin/xbmc-sl2.sh

Also disable the password prompt when switching to desktop mode:
Code:
gsettings set org.gnome.desktop.lockdown disable-lock-screen 'true'

Now add the new XBMC entry to Steam as a external program.
Done!

* Running XBMC in its own session:
You can run XBMC in its own session by replacing the desktop session (note you will lose easy access to the desktop, and running other programs in the xbmc session, such as browsers or emulators, may have problems). In the /usr/share/xsessions directory rename gnome.desktop (i had to rename gnome-fallback.desktop due to using a VM) to have .bak extensions. Then copy XBMC.desktop to gnome.desktop (or gnome-fallback.desktop if necessary). Some extra steps are necessary to prevent XBMC from automatically restarting:

/usr/share/applications/xbmc-sl.desktop
Code:
[Desktop Entry]
Version=1.0
Name=XBMC
GenericName=Media Center
Comment=Manage and view your media
Exec=/usr/bin/xbmc-sl.sh
Icon=xbmc
Terminal=false
Type=Application
Categories=AudioVideo;Video;Player;TV;

/usr/bin/xbmc-sl.sh
Code:
#!/bin/bash

rm -rf /tmp/xbmc.disabled
dbus-send --system --print-reply --dest=org.freedesktop.DisplayManager  /org/freedesktop/DisplayManager/Seat0 org.freedesktop.DisplayManager.Seat.SwitchToUser string:'desktop' string:''

/usr/bin/xbmc-sl
Code:
#!/bin/bash

while [[ -f /tmp/xbmc.disabled ]] ; do
        sleep 1
done

xbmc $@

/usr/bin/xbmc-pre-steam (you need to point the Steam-Launcher addon to use this as the pre-steam script)
Code:
#!/bin/bash

touch /tmp/xbmc.disabled

copy /usr/bin/xbmc-standalone to /usr/bin/xbmc-standalone-sl and edit it and make the XBMC= command look like
Code:
XBMC="${bindir}/xbmc-sl --standalone $@"

Now edit /usr/share/xsessions/gnome.dektop and change xbmc-standalone to xbmc-standalone-sl
Make sure all files created are executable
NOTE: this breaks 'Return to desktop' in steam bpm, so disable 'Access to the linux desktop' in steam's settings.

That does it, enjoy!

I don't use SteamOS a great deal so suggestions are welcome.
Reply
I tried this with my steamos install, but it isn't working.

My steamos is booting directly into my xbmc xsession and when i start the addon to switch to steam, xbmc isn't completely killed.
I can see the xbmc process in "top" maxing 1 core.
Reply
If you have xbmc in its own session I'm pretty sure it restarts automatically. Do you have the same problem if you use the gnome desktop session instead of a xbmc session?
Reply
Yes it's restarting in xbmc xsession and working in gnome.
Is it possible to suppress the restart when steam is running?
Reply
Hmmmm.. It may be possible to logout of the xbmc session so its not running, and running xbmc will autologin to the xbmc session. There is some info here regarding logging out of sessions from the command line: http://askubuntu.com/questions/180628/ho...-using-cli

Can you try some of the methods listed there and report back? I won't have a chance to try for at least a week.

Also, does xbmc stay running if you exit the xvmc session via xbmc's GUI?
Reply
My system is based on Intel Celeron J1900 2GHz Quad-core, 4GB DDR3 SDRAM, Intel onboard graphics, the OS is Win8.1 but because I was getting stuttering & flickering playback issues on movies and TV shows, I have now installed openELEC 4.0.5 on to a USB drive with Gotham 13.1, I boot from the USB drive and the issues are gone, could I install this addon and play games with Steam.
Reply
  •   
  • 1
  • 22
  • 23
  • 24(current)
  • 25
  • 26
  • 82
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Steam Launcher - Start Steam Big Picture Mode from within Kodi7
This forum uses Lukasz Tkacz MyBB addons.