Bug XBMC touchscreen not working
#1
Bug 
So I think this is a bug. Today i tried ubuntu 12.10, Archlinux,xbmcbuntu. And in all of them is same situation. When I tap on screen cursor jumped to right down corner xbmc is no react on touchscreen. The case when it works when I run xbmc from console happened only on xbmcbuntu.
Other way there must be something wrong with fullscreen because when i run xbmc in window it's reacting normally on touches.

Touchscreen is iiyama and it's working out of box.

Old post:
/////////////////
Hi guys, I have problem with xbmcbuntu when it's started from gdm or menu in lxde or any other ways touchscreen is not working.

But when i run terminal and type xbmc touchscreen is working.

Any suggestion how to fix this, I really need to autostart xbmc.

Thanks

/edit: To be precise. Cursor is jumping to right down corner of screen.
Reply
#2
Updated. Same result in more distribution.
Reply
#3
I have the same problem on a Lenovo Thinkpad Twist. Here is my bug report: http://trac.xbmc.org/ticket/14300
Reply
#4
A workaround (fix?) is to add

export SDL_MOUSE_RELATIVE=0

to /usr/bin/xbmc, right before the call of xbmc.bin.

or install wmctrl, switch xbmc to windowed mode (System -> System -> Video Output -> Display Mode and change to "Windowed"), and run xbmc via the following wrapper script:

---------
#! /bin/bash
# Launch XBMC in windowed mode, then use wmctrl to remove the titlebar

# Select display 1
#DISPLAY=:0.0

# Start XBMC without blocking this script
/usr/bin/xbmc &

# Wait for the XBMC window to appear
status=0
while [ $status -eq 0 ]
do
sleep 1
status=`wmctrl -x -l | grep "XBMC Media Center" | wc -l | awk '{print $1}'`
done

# Force XBMC window to fullscreen
wmctrl -x -r XBMC Media Center.XBMC Media Center -b toggle,fullscreen
---------

http://www.madeo.co.uk/?page_id=676
http://forum.xbmc.org/showthread.php?tid=129299
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
XBMC touchscreen not working00