•   
  • 1
  • 32
  • 33
  • 34
  • 35
  • 36(current)
HOW-TO:Share libraries using MySQL: Wiki Edition
(2019-01-13, 04:46)Pajoe Wrote: I understand all the devices will need to be upgraded to v18 Leia to share the same database, but my big question is will the current database be converted to match the new version during the first upgrade or must I start from scratch, add and scan all the sources for content?

A new database will be created during the upgrade of your first client.

(2019-01-13, 04:46)Pajoe Wrote: Can someone point me to a simple how-to for upgrading v17- Krypton to v18- Leia when using a shared mysql database?

Upgrade one client, test it, and once you're happy it is working correctly you repeat the upgrade on your remaining clients and they will automatically start using the new database created by your first client.

You upgrade a LibreELEC client by copying the new tar file into the Update share on the device, and rebooting.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2019-01-13, 05:41)Milhouse Wrote: A  new database will be created during the upgrade of your first client.
(2019-01-13, 04:46)Pajoe Wrote: Can someone point me to a simple how-to for upgrading v17- Krypton to v18- Leia when using a shared mysql database?

Upgrade one client, test it, and once you're happy it is working correctly you repeat the upgrade on your remaining clients and they will automatically start using the new database created by your first client.

You upgrade a LibreELEC client by copying the new tar file into the Update share on the device, and rebooting.    

Thank you

I can see the light at the end of the tunnel. The biggest problem I had was LibreElec latest Leia beta release was using a different database version than Debian & CoreElec, I have downloaded one of your test builds and now the clients with Libreelec are also using RC5 and same database version as Debian/CoreElec. 


I do get errors from mydumper:

Broken table detected, please review: sys.x$schema_table_statistics_with_buffer

However, I ran mysqlcheck several timers on every database and it lists all the databases as "OK"



thanks again

joe
Reply
Anyone got any experience running MySql from a NAS for kodi? Good idea or bad idea? I just bought a Netgear RN214 and I see that MySql can be installed. So looking for some tips before I try it. Smile
Reply
(2019-01-23, 02:47)flhthemi Wrote: Anyone got any experience running MySql from a NAS for kodi? Good idea or bad idea? I just bought a Netgear RN214 and I see that MySql can be installed. So looking for some tips before I try it. Smile

I don't think you will ever know how well your NAS performs as a MYSQL server until you actually try it.


My experience with Zyxel NSA320  was not positive, Mysql installed OK and worked OK but was too slow, I had troubles with other Zyxel :  NAS326 and never got that NAS working very well. I think I tried a  Raspberry Pi and it was too slow,  but it has been a while and I do not remember all the devices I tried before using an old Dell Inspiron 531S desktop running Ubuntu Mate. I added a faster network card, usb 3.0 card and a Probox 4 bay  external drive bay to the Dell and now it works for library files as well.
Reply
(2013-02-25, 22:27)Ned Scott Wrote: click here -> HOW-TO:Share libraries using MySQL (wiki)
 It can resue from stopped not paused, but I think it can be improved.
It's just a software issue, but not that important after all.
Reply
Now that Kodi 18 is here is it OK to use MySql V8.0.15?
Reply
(2019-02-01, 17:25)flhthemi Wrote: Now that Kodi 18 is here is it OK to use MySql V8.0.15?
 Great question it only mentions the minimum version whereas 2 years ago it said only to use version 5.5  for the update to K18 I decided to update from V5.5 to v5.6 since that was the new minimum.  It would be great if the wiki would list the versions and what the recommended version would be.
Reply
Yeah and it appears V8.0.14 is the latest for Windows....When I checked for 8.0.15 Windows isn't listed in the operating systems list (yet?).
Reply
  •   
  • 1
  • 32
  • 33
  • 34
  • 35
  • 36(current)
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
HOW-TO:Share libraries using MySQL: Wiki Edition52