•   
  • 1
  • 35
  • 36
  • 37
  • 38(current)
  • 39
  •   
HOW-TO:Share libraries using MySQL: Wiki Edition
(2019-10-22, 16:41)notrui Wrote:
(2019-10-22, 16:22)Radicale Wrote: Hi.
I don't know why, but since I installed Kodi 18.4 the series no longer works.
I see the series but Kodi doesn't let me into the episodes. It's definitely due to the DB because when I use Kodi default (local) everything is fine.

My advancedsettings:
<advancedsettings>
    <videodatabase>
      <type>mysql</type>
      <host>192.168.2.110</host>
      <name>kodi_video</name>
      <user>kodi</user>
      <pass>kodi</pass>
    </videodatabase>

<musicdatabase>
 <type>mysql</type>
  <host>192.168.2.110</host>
  <name>kodi_music</name>
      <user>kodi</user>
      <pass>kodi</pass>
</musicdatabase>

    <pathsubstitution>
    <substitute>
      <from>special://masterprofile/Thumbnails/</from>
      <to>smb://192.168.2.110/KODI/Thumbnails/</to>
    </substitute>
    </pathsubstitution>
</advancedsettings>


I tried deleting (drop) and rebuilding the DB on my nas but nothing.
The movie work fine!

Hello.
I use mysql with a NAS (DS418) with NFS ethernet gigabit.
I had problems in the beginning to setup everything and understand.


Check this:

https://kodi.wiki/view/MySQL/Setting_up_...ttings.xml

In your advancedsettings.xml it misses this: 
<port>3306</port>

My problem was in the mariadb port, i had to change port to 3307

Now is working very well  


I also use MariaDB, how do you know the port you use?

With the 3306 nothing changes (I see the series but not the episodes), with the 3307 I see nothing.
Reply
(2019-10-22, 16:52)Radicale Wrote:
(2019-10-22, 16:41)notrui Wrote:
(2019-10-22, 16:22)Radicale Wrote: Hi.
I don't know why, but since I installed Kodi 18.4 the series no longer works.
I see the series but Kodi doesn't let me into the episodes. It's definitely due to the DB because when I use Kodi default (local) everything is fine.

My advancedsettings:
<advancedsettings>
    <videodatabase>
      <type>mysql</type>
      <host>192.168.2.110</host>
      <name>kodi_video</name>
      <user>kodi</user>
      <pass>kodi</pass>
    </videodatabase>

<musicdatabase>
 <type>mysql</type>
  <host>192.168.2.110</host>
  <name>kodi_music</name>
      <user>kodi</user>
      <pass>kodi</pass>
</musicdatabase>

    <pathsubstitution>
    <substitute>
      <from>special://masterprofile/Thumbnails/</from>
      <to>smb://192.168.2.110/KODI/Thumbnails/</to>
    </substitute>
    </pathsubstitution>
</advancedsettings>


I tried deleting (drop) and rebuilding the DB on my nas but nothing.
The movie work fine!

Hello.
I use mysql with a NAS (DS418) with NFS ethernet gigabit.
I had problems in the beginning to setup everything and understand.


Check this:

https://kodi.wiki/view/MySQL/Setting_up_...ttings.xml

In your advancedsettings.xml it misses this: 
<port>3306</port>

My problem was in the mariadb port, i had to change port to 3307

Now is working very well  


I also use MariaDB, how do you know the port you use?

With the 3306 nothing changes (I see the series but not the episodes), with the 3307 I see nothing.
You have to go to the nas web configuration:
Go to mariadb configuration and try to see the port that mariadb uses . I use maria db 10 (i think).
Reply
If you have all well configured when you copy a new episode to your NAS you need to scan the library again (client) .

And with that a new episode will appear in your kodi client.
Reply
I am not new in this forum but i could not find , (i don't know if it possible ) to edit my post.
Also use static ip (fixed ip) in your NAS.

The best configuration you can have for fixed ip is doing that in your router instead of the device itself (in this case your NAS).
Reply
(2019-10-22, 17:08)notrui Wrote:
(2019-10-22, 16:52)Radicale Wrote:
(2019-10-22, 16:41)notrui Wrote: Hello.
I use mysql with a NAS (DS418) with NFS ethernet gigabit.
I had problems in the beginning to setup everything and understand.


Check this:

https://kodi.wiki/view/MySQL/Setting_up_...ttings.xml

In your advancedsettings.xml it misses this: 
<port>3306</port>

My problem was in the mariadb port, i had to change port to 3307

Now is working very well  


I also use MariaDB, how do you know the port you use?

With the 3306 nothing changes (I see the series but not the episodes), with the 3307 I see nothing.  
You have to go to the nas web configuration:
Go to mariadb configuration and try to see the port that mariadb uses . I use maria db 10 (i think).  
I use mariadb 5, and don't find it
 
Quote:I am not new in this forum but i could not find , (i don't know if it possible ) to edit my post.
Also use static ip (fixed ip) in your NAS.
The best configuration you can have for fixed ip is doing that in your router instead of the device itself (in this case your NAS).

I Have...
Reply
Check for maria 5 port.

Or unistall and install maria db 10 - port number in my ds 418 is 3307.

Don't give up, try reading more and check everything.

In my case i thought i was doing everything well.
To solve the problem what i checked everything again (many many times) , including maria db 10 settings.
Reply
Does anyone know where I can get a working Easy Advanced Settings Add On? I recently upgraded from a cheap Android box to an Nvidia Shield TV with Kodi 18 and I need to create an advanced settings xml file so I can connect/redo the kodi database on my linux server. Since ES File Explorer is no longer available, I can't just copy an existing file to the Shield and I haven't found an app that shows the file structure.
Thanks
Jim
Reply
(2019-10-22, 16:22)Radicale Wrote: I don't know why, but since I installed Kodi 18.4 the series no longer works.

Start with enabling debugging in Kodi, if necessary also enable the Database component in the debugging section.

Restart Kodi, do your (TV) thing, and provide the debug log (wiki).
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
(2019-10-22, 20:27)jimkoh Wrote: Since ES File Explorer is no longer available,

Use X-plore File Manager instead. No ads, no nagging screens.
For a Nvidia Shield, enable the SMB server for easy access via a network. That way you can also copy a new advancedsettings.xml file to the Shield.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
(2019-10-22, 21:37)Klojum Wrote:
(2019-10-22, 16:22)Radicale Wrote: I don't know why, but since I installed Kodi 18.4 the series no longer works.

Start with enabling debugging in Kodi, if necessary also enable the Database component in the debugging section.

Restart Kodi, do your (TV) thing, and provide the debug log (wiki)

https://paste.kodi.tv/raw/yizonubalu
Reply
2019-10-22 22:46:02.196 T:123145339019264   DEBUG: RunQuery took 585 ms for 1 items query: SELECT * FROM tvshow_view  WHERE watchedCount != 0 AND totalCount != watchedCount ORDER BY c00
2019-10-22 22:46:02.574 T:123145339019264 DEBUG: RunQuery took 137 ms for 6 items query: SELECT * FROM tvshow_view WHERE ((tvshow_view.watchedcount = 0)) AND ((tvshow_view.totalCount > 0))
2019-10-22 22:46:02.767 T:123145342238720 DEBUG: RunQuery took 188 ms for 99 items query: select * from episode_view WHERE ((episode_view.dateAdded > '2012-01-01')) AND ((episode_view.playCount IS NULL OR episode_view.playCount < 1
2019-10-22 22:46:12.237 T:123145347604480 DEBUG: RunQuery took 73 ms for 7 items query: SELECT * FROM tvshow_view WHERE totalCount IS NOT NULL AND totalCount > 0
There is some content in the tvshow section, but it isn't much.
Did you change the filter on the TV show listing to Unwatched or Watched, instead of All ?
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
@Klojum @Radicale 

Is there some data missing in this db ?
2019-10-22 22:46:12.085 T:123145347604480 ERROR: SQL: Missing result set!
2019-10-22 22:46:12.086 T:123145347604480 ERROR: GetSeasonsByWhere failed
2019-10-22 22:46:12.112 T:123145347604480 ERROR: GetDirectory - Error getting videodb://tvshows/titles/71/
Reply
(2019-10-23, 07:25)Klojum Wrote:
2019-10-22 22:46:02.196 T:123145339019264 DEBUG: RunQuery took 585 ms for 1 items query: SELECT * FROM tvshow_view WHERE watchedCount != 0 AND totalCount != watchedCount ORDER BY c00
2019-10-22 22:46:02.574 T:123145339019264 DEBUG: RunQuery took 137 ms for 6 items query: SELECT * FROM tvshow_view WHERE ((tvshow_view.watchedcount = 0)) AND ((tvshow_view.totalCount > 0))
2019-10-22 22:46:02.767 T:123145342238720 DEBUG: RunQuery took 188 ms for 99 items query: select * from episode_view WHERE ((episode_view.dateAdded > '2012-01-01')) AND ((episode_view.playCount IS NULL OR episode_view.playCount < 1
2019-10-22 22:46:12.237 T:123145347604480 DEBUG: RunQuery took 73 ms for 7 items query: SELECT * FROM tvshow_view WHERE totalCount IS NOT NULL AND totalCount > 0
There is some content in the tvshow section, but it isn't much.
Did you change the filter on the TV show listing to Unwatched or Watched, instead of All ?
yes, but nothing....
I can't enter in the episode room
Reply
(2019-10-23, 08:36)black_eagle Wrote: Is there some data missing in this db ?

Hmm.. I overlooked that. That's an odd one. Two lines in the middle of nowhere.
The previous query that was done was related to the music database.
And all the previous queries to the video database have a result set of several records AFAICT.

It's pretty difficult to pinpoint the real problem from a distance.
At this point I would ask if you have any database backups... and do a library update from there on.
Otherwise it's probably best to start with a new fresh video library.

MYSQL: Connected to version 5.5.47-MariaDB is a pretty old version, support is only 6 months left until April 2020 by Maria.
I believe they are at 10.4.18 stable something now?
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply
Since Kodi is complaining about my mysql version, I'd like to fix it. But I couldn't find any info on how to update mysql in a FreeNAS jail, so I tried creating a new one. I can't get it to start though. Can somebody walk me through how to create a new one with the correct version of mysql? I'm lost.
Reply
  •   
  • 1
  • 35
  • 36
  • 37
  • 38(current)
  • 39
  •   
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
HOW-TO:Share libraries using MySQL: Wiki Edition52