[SOLVED-FAILED] MySQL server update - Libraries Empty
#1
Question 
Hello.

I recently had to rebuild my WHS that contained all of my movies (shares), music, and MySQL server.

I backed up my databases using mysqldump and after a reinstall (WHS2011) managed to setup my shares and MySQL databases. Everything looks ok, as the database is visible from the server and clients (using Navicat to view the tables).

However, when I start up XBMC v12, and enter into Movies, Music or TV Shows, my libraries are empty. I can navigate to the files directly using "Files" for each, so I know that the SMB works ok. I've tried to delete the source, recreate it and rescan the entire library, but nothing works.

My log file is located here: http://xbmclogs.com/show.php?id=2048

EDIT: I'm using Aeon MQ4, if it matters...

Can anyone please helpHuh
Reply
#2
So I recreated the source, and tried to refresh the library...now I'm really confused.

http://xbmclogs.com/show.php?id=2297
Reply
#3
Another tidbit of info I neglected to mention...

I have 5 XBMC clients, 3 wired GigE HTPCs and 2 Wifi-N laptops. All have the same issue. I'm beginning to think that it has something to do with the "source" not being setup right, since I haven't changed any of my other clients (except my laptop, where I've been experimenting).
Reply
#4
Hey there...
Sorry to hijack your thread but don't wanna start another one for the exact same issue.

I am having the exact same problem. I recently installed MYSQL (which I know absolutely nothing about) so as to allow all my XBMC systems to sync no matter which room I decide to watch my movies/series.

I go to "Video" & add source and can see the files and can even play the movie/series episode. I set the content and then press ok. When I go to the "Movie" or "TV Show" tab there is nothing in there.

I have also followed the tutorials for setting up MYSQL & XBMC but yet I seem to be missing something or doing something wrong.

I have seen something about a "source.xml" but as I don't understand the coding language it all seems gibberish to me.
Could it be that we need to add this "source.xml"?

Are there any of you great minded guys out there that could possibly assist us please...
Reply
#5
Ok jhhoffma...

Here's the log: http://xbmclogs.com/show.php?id=2592 (main pc)
http://xbmclogs.com/show.php?id=2595 (htpc)

All weird to me but I see something about the password but I am using the correct password.

Anyway any and all help is appreciated.
Reply
#6
What version of mySQL?
There's a known issue with 5.6...
http://trac.xbmc.org/ticket/14117
Reply
#7
Using: Server version: 5.5.30 MySQL Community Server (GPL)
Reply
#8
Did you "grant all" to user 'xbmc' per Step 2 in the wiki?

6. Enter the following commands:
6.1 Type in: CREATE USER 'xbmc' IDENTIFIED BY 'xbmc'; and press return
6.2 Type in: GRANT ALL ON *.* TO 'xbmc'; and press return

Thanks edrikk, I think we're narrowing in on something (at least for my issue), as I saw a similar post in the General Forum

http://forum.xbmc.org/showthread.php?tid...pid1358051

I'm going to change versions of MySQL when I get home and see how that plays out.

Will post an update when I finish.
Reply
#9
ERROR 1396 (HY000): Operation CREATE USER failed

Getting this message when doing step 6.1
Reply
#10
But I did do those steps...

Checked now SHOW DATABASES; and mymusic shows there.

Started up XBMC and I could add my music to the library.
So now the movies is the problem now....
Reply
#11
Well, I'm getting nowhere fast...

I've completely uninstalled MySQL 5.6 and deleted any residuals manually. I've installed 5.5.30 and restored my old db using console commands. Using NavCat I can see the database just fine, but xbmc goes nowhere. If I clean the database and try to update it library, it changes the database (starts it over from scratch), so I know it's not a MySQL setup issue.

The only thing I can think of is that something with the way the SOURCE is setup is not allowing the XBMC "Library" to connect with the database internally.

Here's a log of trying to access the DB by entering the "Movie" section from HOME.

http://xbmclogs.com/show.php?id=2692

And here's one of me trying to update the db...

http://www.safebin.net/9504

Can any admins out there lend some light to this?
Reply
#12
Hey jhhoffma...

You by chance get to check my logs?

You or anyone else that can let me know what the prob could be with my setup.
Reply
#13
Sorry, I'm here for support just like you. Last log I looked at said your 'xbmc' user didn't have access to the MyVideos database, which points to you not giving permissions properly.

Try the additional steps in the wiki at the bottom of Step 2 where you grant access to the db's by name:

In the SQL Client.
GRANT ALL ON `MyMusic%`.* TO 'xbmc'@'%' IDENTIFIED BY 'xbmc';
GRANT ALL ON `MyVideos%`.* TO 'xbmc'@'%' IDENTIFIED BY 'xbmc';

See if that helps...

Also try using NavCat to access your db and see what (if any) errors it throws your way.
Reply
#14
Oh ok then...

Thanx though bud. Guess I'll start a new thread then
Reply
#15
Is there anyone else that could take a look at these logs and possibly give me direction as to what the issue might be...

http://xbmclogs.com/show.php?id=2592 (main pc)
http://xbmclogs.com/show.php?id=2595 (htpc)
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[SOLVED-FAILED] MySQL server update - Libraries Empty51