•   
  • 1
  • 16
  • 17
  • 18(current)
  • 19
  • 20
  •   
VNSI4 alpha
After using vnsi4 for a while I got only one thing I don't really get.

Example:

You are recording the BTCC coverage on Sunday, it will run from 11.00 in the morning until 18.00 in the evening, you watch race 1, take a break for 3-4h come back to the TV and want to watch race 2, what vnsi will now do is playback the 4h long recording from the very beginning, forcing you to fast forward to the live picture. I don't think it should do that, if you turn on live TV you want to watch live TV and not recordings, if you wanted to watch a partial recording you could do that in the recordings view.

Or am I doing something wrong here?
Reply
The recordings view is inappropriate for recordings in progress. Recordings form that view go directly to ffmpeg demuxer which does not reevalute the file size. I am going to exclude not finished recordings from that list.
Currently the skins and PVR API lacking some desired features like displaying current buffer position and buffered length of content. Also a function "got to live pos" is desired.
Until we have those you can hold down big step forward. It should bring you quickly to live position.

That's the current state. Good ideas are always welcome.
Reply
Thanks for the explanation. I'll change my remote.xml then so it is more convenient to work around this.
Reply
@FernetMenta

is saw the issue: https://github.com/opdenkamp/xbmc-pvr-addons/pull/181 is merged into opdenkamps master branch. so do you think the problem is finally solved?
Reply
I hope so.
Reply
2 things I stumbled upon while using vnsi4

First: Quite easy to reproduce not sure if it's a limitation or a bug, only a problem if you've got more then 1 dvb card.

1. Start recording on Channel 1.
2. Start another recording on Channel 2.
3. Turn on livetv on the currently recording Channel 1 -> livetv will start from beginning of recording as expected.
4. Stop, turn on livetv on currently recording Channel 2 -> livetv will start at current point, not at the beginning of the recording.


Second: Sometimes I run into a strange situation while timeshifting, the picture will play back in slow motion (19-20fps instead of 50), this only seems to happen on SD mpeg2 channels while I rapidly move through the timeshift file to get to the end of the buffer, or to a certain place in the buffer. The only way I can make it work as expected again is if I stop livetv and start it again. I tried reproducing it with a finished recording on my list but it doesn't happen then, so I would guess it's something the timeshift code is doing differently.

Debug log: http://www.xbmclogs.com/show.php?id=49986 (gets interesting at somewhere around 18:03:04)
Reply
thanks, you should open a new thread for this though

4.) for some season it does not recognize that channels 2 is recording and then it does not open the file.


Second:
you have lots of those in the log:
18:03:15 T:2265496384 DEBUG: CVDPAU:Big Grinecode long wait: 101

but nothing which points in direction of a demuxer problem. maybe vdpau.

will have a closer look after having finished some work on AE.
Reply
I'm still having issues with timeshift buffer seeks not working properly sometimes. Is debug log enough to help identifying this issue? I don't watch much tv lately, so it will take some time to get the correct debug info for this.

BigStepBack/Forward should go 600secs back/forward (timeseek method) when you have 10+mins in buffer instead of 10% percentseek method, right? According to OSD (which indicates +10:00 or -10:00) I'm using timeseek method in such cases where it doesn't work.

Can anyone else, who use RAM timeshift buffer check/confirm whether their timeshift seeking is working reliably or not?

(2013-05-06, 16:51)ezechiel1917 Wrote: Maybe a stupid question, Is seeking also supposed to work with:

StepForward Step forward 30 seconds in a video.
StepBack Step back 30 seconds in a video.
SmallStepBack Step back 7 seconds in the current video.
BigStepForward Step forward 10% in the movie.
BigStepBack Step back 10% in the movie.

I believe it used to work here, but it seems that now seeking only works reasonably with FastForward and Rewind and any of the above keymaps sometimes randomly seeks to beginning of the LiveTV buffer instead of desired position (mostly tested StepForward+StepBack with several minutes LiveTV buffer).

(2013-05-06, 18:58)FernetMenta Wrote: The methods which use percent don't work because player currently does not know about the buffer size. The other methods should work but I haven't tested on recent builds.
Reply
What's still missing is the buffer indicators in the GUI. You'll never know exactly where you are in the buffer. Makes testing hard as well.
The indicators were on top my dodo list before I started the new audio engine.
Reply
Here's a debug log:
http://pastebin.com/Wb9h9ZqQ


I've opened TV channel, waited 90s, then used StepBack (that got me to the beginning of buffer) and after that several times StepForward (which got me to the beginning of the buffer everytime except the one with (VDPAU) Error: An invalid handle value was provided.(3) at VDPAU.cpp:883 which got me to LiveTV buffer position I guess...

Hope it helps.
Reply
I compiled frodo version, but i still get "VNSI: Welcome client 'XBMC Media Center' with protocol version '3'".
Reply
guys what repository should i be using to use latest/beta vnsi and latest nighttly 13.0 xbmc?

everything was working perfect now all is ruined, i messed yp.... i dunno what branch to use for vnsi, and/or wich xbmc nightly to use...

i try to install VNSI i compiled and XBMC says missing dependencies
Image
Reply
if using gotham xbmc use opdenkamp master branch of pvr-addons
Guide to building an all in one Ubuntu Server - TV(vdr),File,Music,Web

Server Fractal Designs Define XL, Asus P5QL/EPU, Dual Core E5200, 4gb, L4M-Twin S2 v6.2, Supermicro AOC-USAS-L8I, 1*SSD & 13*HDD drives (24TB total) - Ubuntu Server
XBMC 1 ASRock Z77E-ITX, G850, 8GB RAM, SSD, BD - Ubuntu / OpenElec frodo
XBMC 2 Revo 3700 - OpenElec frodo
XBMC 3 Raspb Pi
Reply
ok thank you, so i did

git clone https://github.com/FernetMenta/xbmc-pvr-...tree/vnsi4
cd xbmc-pvr-addons
./bootstrap
./configure
make zip


then i go to XBMC and to install add-on from zip and it says it's missing dependencies.
Image
Reply
you could but that's a testing branch. Change to the following for a stable build:

git clone https://github.com/opdenkamp/xbmc-pvr-addons.git

You also need to install the VDR plugin vdr-vnsiserver. Instructions for installing it are in the 1st post of the sticky thread:
http://forum.xbmc.org/showthread.php?tid=147852

Edit: Gotham has the PVR addons already so you don't need to build and copy the zip over. You just need to compile the vdr-vnsiserver for your VDR
Guide to building an all in one Ubuntu Server - TV(vdr),File,Music,Web

Server Fractal Designs Define XL, Asus P5QL/EPU, Dual Core E5200, 4gb, L4M-Twin S2 v6.2, Supermicro AOC-USAS-L8I, 1*SSD & 13*HDD drives (24TB total) - Ubuntu Server
XBMC 1 ASRock Z77E-ITX, G850, 8GB RAM, SSD, BD - Ubuntu / OpenElec frodo
XBMC 2 Revo 3700 - OpenElec frodo
XBMC 3 Raspb Pi
Reply
  •   
  • 1
  • 16
  • 17
  • 18(current)
  • 19
  • 20
  •   



Logout Mark Read Team Forum Stats Members Help
VNSI4 alpha3
This forum uses Lukasz Tkacz MyBB addons.