No cast artwork showing in Frodo when scraping with TMDB or Universal Scraper
#1
I'm using Frodo and have tried both the TMDB and Universal Movie Scraper but the cast art work doesn't show. The only way to get the cast (actors / actress) art work is by refreshing each item individually. I have tried removing and adding source but the same every time. Any one else with this issue? I am running xbmc with shared mysql database. A method to refresh all movies would definitely help but doesn't exist?

I guess the question is.. what is different between a single refresh and re-scanning all items (or even single item) by deletion first? in my case only a refresh pulls all the images but this is not practical on large database.

I am getting the exact same issue on atv2 and XP and Vista. Any help appreciated. Thanks
Reply
#2
(2013-03-14, 18:25)skeeney Wrote: A method to refresh all movies would definitely help but doesn't exist?

I've written a script to do that but may have discovered a bug which will prevent cast artwork from being pre-cached.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#3
Wow.. thanks MilhouseVH that's what I am after.. I will give that a go tonight. Cheers Smile
Reply
#4
Did have a go at running this but no luck as yet. Any ideas what I am doing wrong?

~$ ./texturecache.py c
Querying localhost:9090 for all Movies...
Movie: <MOVIE NAME> [ fanart ] [ poster ] [ + thumb ]Traceback (most recent call last):
File "./texturecache.py", line 1296, in <module>
main(sys.argv[1:])
File "./texturecache.py", line 1251, in main
libraryQuery("cache", "movies")
File "./texturecache.py", line 335, in libraryQuery
libraryAllMovies(action, filter, force, extraFields, rescan)
File "./texturecache.py", line 469, in libraryAllMovies
loadImage(force, "cast %02d" % n, actor["thumbnail"], imgErrors)
File "./texturecache.py", line 766, in loadImage
URL = getImageURL(filename)
File "./texturecache.py", line 743, in getImageURL
data = sendJSON(REQUEST, "1")
File "./texturecache.py", line 254, in sendJSON
return json.loads(web.getresponse().read())
File "/usr/lib/python2.7/httplib.py", line 1030, in getresponse
response.begin()
File "/usr/lib/python2.7/httplib.py", line 407, in begin
version, status, reason = self._read_status()
File "/usr/lib/python2.7/httplib.py", line 371, in _read_status
raise BadStatusLine(line)
httplib.BadStatusLine: ''
Reply
#5
Have you enabled the webserver in XBMC (default port 8080, and don't set a password)?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#6
Hi MilhouseVH.. I have webserver enabled, port 8080, xbmc as username and no password. I also have allow control from remote and local system enabled. I can also connect ok with localhost:8080 in webrowser and I get open message also when I telnet on port 9090 as well..

Not sure if you can spot anything from below? thanks

Debug output
Reply
#7
(2013-03-22, 23:34)skeeney Wrote: Hi MilhouseVH.. I have webserver enabled, port 8080, xbmc as username and no password. I also have allow control from remote and local system enabled. I can also connect ok with localhost:8080 in webrowser and I get open message also when I telnet on port 9090 as well..

Not sure if you can spot anything from below? thanks

Nothing jumps out at me. The error is rather odd, it suggests the webserver is returning an invalid status response to Python.

Could you download the latest version of the script (I added some debug) and run as follows:

Code:
export PYTHONDEBUG=Y && ./texturecache.py c movies <somepartialmovienamethatneedsupdating>

and then paste the output (here, preferably surrounded by [code] blocks! Or on pastebin). Thanks.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#8
Hi MilhouseVH, I ran wget again and your above above command.. output below.. thanks

running on all movies

debug for two individual queries
Reply
#9
(2013-03-23, 13:46)skeeney Wrote: Hi MilhouseVH, I ran wget again and your above above command.. output below.. thanks

output with debug

You've run the old version - when wget downloaded the new version, it saw the old version and downloaded the new version as texturecache.py.1.

Can you "mv texturecache.py.1 texturecache.py" and try again? Thanks.

Or download as:
Code:
wget http://www.nmacleod.com/public/texturecache.py -O ./texturecache.py && chmod +x ./texturecache.py
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#10
Just spotted that just before your response Smile Updated my previous post above with two new pastebins.. thanks
Reply
#11
(2013-03-23, 14:02)skeeney Wrote: Just spotted that just before your response Smile Updated my previous post above with two new pastebins.. thanks

It looks like the Files.PrepareDownload JSON method is failing to return sensible results.

For the movie "2 Days in New York", what poster do you have? It seems to be trying to extract it from the mkv.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#12
I also just tried querying my apple tv 2 to rule out the xbmc intstall on my ubuntu laptop.. I got the below.. I am using mysql shared database, that shouldn't cause any issues should it as changes would simply be written to that after?

debug when running against atv2
Reply
#13
(2013-03-23, 14:12)skeeney Wrote: I also just tried querying my apple tv 2 to rule out the xbmc intstall on my ubuntu laptop.. I got the below.. I am using mysql shared database, that shouldn't cause any issues should it as changes would simply be written to that after?

debug when running against atv2

MySQL shouldn't be an issue, it's what I use, and besides the script is using JSON to query the media library (so shouldn't care if it's MySQL or sqlite).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#14
"For the movie "2 Days in New York", what poster do you have? It seems to be trying to extract it from the mkv."

Sorry MillhouseVH, how would I check that? From the xbmc install on both machines I can see fanart and dvd art. All that is missing is the majority of cast artwork. It's the same with all my movies. Thanks
Reply
#15
@skeeney: Can you try downloading the script again, I just uploaded a version that closes the web connection before reusing it, just in case this is the problem.

(2013-03-23, 14:23)skeeney Wrote: "For the movie "2 Days in New York", what poster do you have? It seems to be trying to extract it from the mkv."

Sorry MillhouseVH, how would I check that? From the xbmc install on both machines I can see fanart and dvd art. All that is missing is the majority of cast artwork. It's the same with all my movies. Thanks

Where you have the movie (presumably on your NAS), do you have any local artwork with the mkv? If so, what do you have? Or do you just have the mkv?

When it is trying to download the poster, it is using the following filename:
Code:
[email protected]://W7MC/HDfilms4/2 Days in New York (2012)/2 Days in New York (2012) part1.mkv
so I'm guessing the "poster" is being extracted from the MKV container (which isn't something I've ever tried myself, do you have a sample file I can download?)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
No cast artwork showing in Frodo when scraping with TMDB or Universal Scraper00