Win RE: Which Audio output? HD Audio or Normal 5.1 [SOLVED]
#1
Hi All,

Here is my setup:

XBMC --->Yamaha RX-V467 Receiver ----> TV

HTPC connected to receiver via HDMI & receiver connected to TV via HDMI

HTPC:
AsRock FM2A75M-ITX
AMD A6 5400K Black Edition CPU
Win 7 Ultimate
Frodo 12
Neon skin
All drivers updated

When i select the HDMI option in the audio settings, i get no sound. I have tried lots of settings but nothing has worked
However, if i select analog 5.1 in xbmc audio settings, i get sound through all the speakers. It's a 5.1 Setup

Now, my question is when i play movies with HD Audio, is the output HD sound or just 5.1?

Here is the settings when playing an MKV file with DTS-HD
Image
Image
Reply
#2
Are you using the AMD drivers for the HDMI audio? as Realtek is known to cause problems with AMD HDMI audio.

Check the sticky http://forum.xbmc.org/showthread.php?tid=146911

Start off by checking Supported Formats in Windows as described in Part 3 - Section 3, this will tell you the formats the graphics driver is reporting it can pass, you'll probably find DTS-HD is missing from here.

Btw Analog is not really analog, what that setting does is make XBMC decode the audio to LPCM, this LPCM can then be fed to an analog audio output or passed out as LPCM on SPDIF or HDMI. So in the above example with a DTS-HD track, the embedded DTS Core 5.1 track is decoded to Multichannel LPCM 5.1 with Analog set.
Reply
#3
Thanks jjd-uk

I'll go through the sticky again. I did check the supported formats in windows and i saw DTS-HD and TrueHD included but i am not sure it's showing that because i selected analog in xbmc not HDMI.
I also noticed when i launch the Configure wizard to set the speaker layout, i only saw stereo option and when i select the "Test" button, i got sound from only two speakers
Image
Reply
#4
Check the number of channels reported in Support Formats, if everything is working correctly it should show 8 Channels (for 7.1), if it's anything other than that such a 6 Channels (for 5.1) then HD audio will not work on XBMC even though TrueHD & DTS-HD might show in the encoded formats box.

If you do have only 6 channels or less showing then you could either have a driver or an EDID problem.
Reply
#5
Thanks Again. I'll check the whole configuration and driver later today
Image
Reply
#6
(2013-03-19, 12:27)tboggie Wrote: XBMC --->Yamaha RX-V467 Receiver ----> TV

HTPC connected to receiver via HDMI & receiver connected to TV via HDMI

HTPC:
AsRock FM2A75M-ITX
AMD A6 5400K Black Edition CPU
Win 7 Ultimate
Frodo 12
AMD iGPU is little harder to configure audio output for bitstreaming. If you configure Frodo audio output as shown in the last screenshot below, it should bitstreaming HD audio codecs and decodes other audio codecs correct. For AMD iGPU, I am recommending options below to insure bitstreaming HD audio and playback video fluently-

1. Update the latest AMD driver from here- Graphics Drivers & Software
2. Disable everything other than "enforce smooth playback" in CCC video quality
3. Uninstall (generic pnp) monitor driver (leave the Display/GPU stuffs alone)
4. Disable "Use a fullscreen window rather than true fullscreen" in XBMC settings/system/video output
5. Enable "Allow hardware acceleration (DXVA2)" and select "Auto detect" as Render method in XBMC system/settings/video/playback
6. Below are the three screenshots of my audio configurations in Windows control panel

Image
Image
Image


Image
>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
Reply
#7
(2013-03-19, 16:57)bluray Wrote: Image
Shouldn't we select 24 bits as most blu-rays use that for sound?
And can the human ear even make the difference?
Just wondering...
Box 1: ODroid N2+ 4GB
Box 2: Intel NUC D34010WYK (Windows afedchin's Krypton MVC Build)
Box 3: Vero 4K
RIP schimi2k | I miss you buddy :(
Reply
#8
(2013-03-19, 20:41)ArieS Wrote: Shouldn't we select 24 bits as most blu-rays use that for sound?
And can the human ear even make the difference?
Just wondering...
You can try it for yourself.....I tried it, and I never can tell any different in sound quality on my 7.2 and 3.1 systems.....
>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
Reply
#9
Thanks.I have followed all the steps below and still no luck. No sound via HDMI

1. Update the latest AMD driver from here- Graphics Drivers & Software
2. Disable everything other than "enforce smooth playback" in CCC video quality
3. Uninstall (generic pnp) monitor driver (leave the Display/GPU stuffs alone)
4. Disable "Use a fullscreen window rather than true fullscreen" in XBMC settings/system/video output
5. Enable "Allow hardware acceleration (DXVA2)" and select "Auto detect" as Render method in XBMC system/settings/video/playback
6. Below are the three screenshots of my audio configurations in Windows control panel

Image

Image
Image
Reply
#10
seems to be an issue with ur avr (edid?)
as long as ur sound configuration shows ur TV instead of ur AVR, u will not get any supported compressed audio formats like u see in ur last screenshot.
u can try to play with ur HDMI settings in the AVR´s menu...things such as HDMI Control can cause issues...

maybe another yamaha user can give u some tips..
Ryzen5 2400g @gigabyte AorusM
Marantz AV7702/MM8003 Combo
Philips 55PFL8007k/12
Sony VW-270ES
Reply
#11
As mentioned above, it looks like your TV is being detected as the connected device, on your Yamaha AVR make sure HDMI Control is turned off and HDMI Audio Output is set to Amp.

If that doesn't work then to get sound you'll need to do the following in XBMC's Audio Settings:

Audio Output: Analog
Speaker configuration: 2.0
Audio output device: WASAPI - HDMI

Then you'll need to look into getting an EDID override.
Reply
#12
(2013-03-20, 00:22)bimme Wrote: seems to be an issue with ur avr (edid?)
as long as ur sound configuration shows ur TV instead of ur AVR, u will not get any supported compressed audio formats like u see in ur last screenshot.
u can try to play with ur HDMI settings in the AVR´s menu...things such as HDMI Control can cause issues...

maybe another yamaha user can give u some tips..

Woooooooooohooooooooooooooooooooooooooooooooooooooooooo Big Grin Big Grin Smile Smile Smile

I totally forgot i was messing around with the avr settings a while ago and i had HDMI control off. Turned it on and i now see 5.1 / 7.1 options in windows sound settings. Completed the windows config, checked xmbc settings again and rebooted

Played the same file with DTS-HD via hdmi 5.1 and i'm getting audio through all the speakers

Thanks to everyone who replied this thread. Really appreciate it Blush

(2013-03-20, 01:31)jjd-uk Wrote: As mentioned above, it looks like your TV is being detected as the connected device, on your Yamaha AVR make sure HDMI Control is turned off and HDMI Audio Output is set to Amp.

If that doesn't work then to get sound you'll need to do the following in XBMC's Audio Settings:

Audio Output: Analog
Speaker configuration: 2.0
Audio output device: WASAPI - HDMI

Then you'll need to look into getting an EDID override.

Thanks jjd-uk. It was turned off and no sound. Set it to ON and i now get sound through HDMI.
Image
Reply
#13
(2013-03-19, 23:58)tboggie Wrote: Image
If you did everything as I suggested in post #6, you'll have a very stable/smooth bitstreaming/playback using AMD iGPU. By the way, you can leave "Dolby Digital (AC3) capable receiver" option un-check and set the speaker configuration to 7.1 in Frodo audio output.....5.1 surround sound mapping for AC3 is a little mess up in Frodo.....

If you want to test your surround sound mapping through Frodo, you can using this "Channel Check" from Dolby Digital site....you can read about it in post #22...
>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
Reply
#14
(2013-03-20, 05:15)bluray Wrote:
(2013-03-19, 23:58)tboggie Wrote: Image
If you did everything as I suggested in post #6, you'll have a very stable/smooth bitstreaming/playback using AMD iGPU. By the way, you can leave "Dolby Digital (AC3) capable receiver" option un-check and set the speaker configuration to 7.1 in Frodo audio output.....5.1 surround sound mapping for AC3 is a little mess up in Frodo.....

If you want to test your surround sound mapping through Frodo, you can using this "Channel Check" from Dolby Digital site....you can read about it in post #22...

All done as suggested. All audio tracks including HD Audio via HDMI works
Image
Reply



Logout Mark Read Team Forum Stats Members Help
RE: Which Audio output? HD Audio or Normal 5.1 [SOLVED]0
This forum uses Lukasz Tkacz MyBB addons.