Easiest Way to Get HD Audio
#1
Hey guys,

I've been using XBMC for a while and saw a few different threads about bitstreaming HD Audio. I have tried to follow a few guides but seem to be having issues.

I'm currently running a windows 7 HTPC and the latest version of XBMC ( 12.1 ) with an AMD 6450. HDMI from the 6450 goes to my Denon 2313 AVR. I'm using a 5.1 setup.

I have noticed when I go into System > Audio Settings I can change analogue to HDMI and the different formats become highlighted ( DTS, Dolby etc ) but when I change from 2.0 to 5.1 I lose all sound and if I have a movie or TV show playing it becomes all choppy and doesn't work properly.

Wanted to know if anyone can assist me and tell me what I'm doing wrong.

Cheers Big Grin
Reply
#2
Check out my post #6 to configure Windows audio output, and your Frodo should looks similar to my screenshot below (your should be AMD/Dennon)-

Image
>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
Reply
#3
I made a mistake when I said I was using an AMD 6450. I'm actually using a 6870 in this htpc. I have deleted the realtek audio drivers. I then tried to setup my AMD audio drivers the same as jjd's audio troubleshooting guide. I noticed in the AMD HDMI Output Properties it lists " Max number of channels " as 2. Also there are no encoded formats listed.

Does this mean my graphics card is unable to output HD surround audio?

*edit * Just checked, 6870 apparently has:

"Integrated HD audio controller
Output protected high bit rate 7.1 channel surround sound over HDMI or DisplayPort with no additional cables required
Supports AC-3, AAC, Dolby TrueHD and DTS Master Audio formats"

So it's something else :S

Maybe this: "If formats are missing that you know your hardware is capable of then this points to there being either a driver problem or if using HDMI then it maybe a EDID handshaking problem. " ?
Wtf is an EDID problem :S Should I change HDMI cable?
Reply
#4
You have massive GPU and AVR, and both supports bitstreaming DTS-HD/TrueHD audio codecs. With the correct connections and configurations, it should work. Try these-

1. if you enabled CEC in your Denon, try disable it for now.
2. make sure to select the correct HDMI input in Denon for AMD HD6870
3. read my post #2 above carefully, especially the instructions in my post #6

If you did all the above and it still doesn't work, then we can talk about Edid afterward....
>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
Reply
#5
It's working now. I think all I did was change my XBMC settings to the ones you posted on the screenshot. After I did that I tried a movie and it was playing normal ( no freezing / jumping ) then when the sound started BAM!
Big smile on my face!! DTS on the receiver screen instead of direct or whatever it was before as proof but I could tell just by listening straight away. tested the opening scene on Saving Private Ryan and some parts of Transformers 1 and it is so good.
I'm sitting here watching different parts of movies I know have loud moments ( action scenes, fights etc ) with a big goofy smile on my face.

I checked the AMD Driver Properties and all the good formats are now listed, just by changing some settings through XBMC. I think I was trying to get it right through windows before even trying too much in XBMC.

One last question. When I play a movie with Dolby it comes up as " Multi " on the Receiver screen and AC3 5.1 on the XBMC Audio list. Is that correct?
Reply
#6
Dolby Digital and ac3 is same.

uNi
Reply
#7
awesome, thanks for your help!
Reply
#8
(2013-03-28, 06:20)Whomastadon Wrote: I checked the AMD Driver Properties and all the good formats are now listed, just by changing some settings through XBMC. I think I was trying to get it right through windows before even trying too much in XBMC.

One last question. When I play a movie with Dolby it comes up as " Multi " on the Receiver screen and AC3 5.1 on the XBMC Audio list. Is that correct?

It's not possible that changing something in XBMC would have changed what the AMD drivers report to Windows, it's most likely something else was going on, did you perhaps start your PC before switching on the AVR? bear in mind HDMI is a two way link so the AVR should be on before the PC is started otherwise Windows can not ask the AVR for the formats it supports.

If playing back Dolby Digital (AC3) files shows as "Multi" on the AVR then that means the XBMC is decoding the Dolby Digital track then sending LPCM to the receiver, this will happen if you don't have "Dolby Digital (AC3) capable receiver" selected in in the XBMC audio settings. I'm guessing you followed bluray's screenshot exactly which is wrong if you want to bitstream Dolby Digital, I think bluray has it like that because of a bug with Dolby Digital Plus but unless you have any ripped HDDVD's that bug is generally not something to worry about.
Reply
#9
Yeah right, i guess it was when i gave up, turned everything off, came back and turned everything on. I think I did copy that screenshot exact so i'll check the dolby digital ac3 point in xbmc and it ahould be right.

Thanks guys, helped me alot and have made a massive difference to my new home theatre setup
Reply
#10
(2013-03-28, 12:37)Whomastadon Wrote: Yeah right, i guess it was when i gave up, turned everything off, came back and turned everything on. I think I did copy that screenshot exact so i'll check the dolby digital ac3 point in xbmc and it ahould be right.

Thanks guys, helped me alot and have made a massive difference to my new home theatre setup
I posted the screenshot in post #2 for a reason. You should keep it exactly the same as the screenshot for everything to work right. If you select AC3 capable receiver and output stereo to all speakers or speaker configuration to 5.1, it'll mess up AC3 5.1 channel mapping. I played around with Frodo audio output configurations quite a bit before I got everything working right with the screenshot above. The only way to get AC3 to work right is by having Frodo decoding it to LPMC, then sending it to AVR....

If you want to verify it yourself, you can use "Channel Check" from Dolby Digital website.....you can verify it using Windows sound configuration first, and then try it with Frodo.....
>Alienware X51- do it all HTPC
>Simplify XBMC configurations
>HOW-TO Bitstreaming using XBMC
I refused to watch movie without bitstreaming HD audio!
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Easiest Way to Get HD Audio00
This forum uses Lukasz Tkacz MyBB addons.