[FRODO] mp3s display wrong duration in xbmc (Length tag correct!)
#1
Hello there! Big Grin

I recently upgraded to frodo and reinstalled xbmcbuntu. But now half of my music displays the wrong length in XBMC (arround 10x the actual duration). Theese files are self-converted from m4a to mp3 VBR with avconv. The files worked on Eden.

Here two files as a comparison:

FILE 1 - WORKING VBR MP3 BOUGHT ON AMAZON (shows correct duration)

mp3info output:
Code:
Media Type:  MPEG 1.0 Layer III
Audio:       Variable kbps, 44 kHz (joint stereo)
Emphasis:    none
CRC:         No
Copyright:   No
Original:    Yes
Padding:     No
Length:      3:39

mpck output:
Code:
version                       MPEG v1.0
    layer                         3
    average bitrate               257020 bps (VBR)
    samplerate                    44100 Hz
    frames                        8391
    time                          3:39.193
    unidentified                  0 b (0%)
    errors                        none
    result                        Ok

FILE TWO - SELF-CONVERTED (avconv -i "$i" -ab 256k -y "${i%m4a}mp3" {m4a files to mp3}):

mp3info:
Code:
Media Type:  MPEG 1.0 Layer III
Audio:       256 kbps, 44 kHz (joint stereo)
Emphasis:    none
CRC:         No
Copyright:   No
Original:    Yes
Padding:     Yes
Length:      4:51

mpck:
Code:
version                       MPEG v1.0
    layer                         3
    average bitrate               255948 bps (VBR)
    samplerate                    44100 Hz
    frames                        11159
    time                          4:51.500
    unidentified                  0 b (0%)
    errors                        none
    result                        Ok



The only thing I can think of beeing the problem could be the following lines in mp3info:
FILE1:
Audio: Variable kbps, 44 kHz (joint stereo)
FILE2:
Audio: 256 kbps, 44 kHz (joint stereo)

XBMC could assume that the file is a 256kbps CBR file for the calculation of the duration. But I would not know how to easily solve this problem.

EDIT: It works fine in all other players. I post this to the general support forum because I don't think this is a problem with xbmcbuntu
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[FRODO] mp3s display wrong duration in xbmc (Length tag correct!)00
This forum uses Lukasz Tkacz MyBB addons.