• 1
  • 2(current)
  • 3
  • 4
  • 5
  • 39
[i.MX6] XBMC running on Freescale SoC's
(2013-04-14, 16:13)wolfgar Wrote: (on one side I still need to open the stick, replace the sdcard, plug a header to access UART quite often while hacking and on the other side a real cooling solution would require to close it for good and ensure good conduction between the case and my heatsink... So it is not easy to find a good compromise)

The heatpad doesn't hold up well to this sort of handling either.

I suggest running wires out for the UART (yes, it's ugly...) and putting only uboot on the internal sdcard, then put your rootfs on external. Saves a lot of flipping that @#(@# little latch too!

- abrasive
Hi abrasive,

Thanks for your post, you are definitively right (except my own heatpad is ok with this handling because it is not thick enough to ensure contact with case ... Which is even worse for heat dissipation of course ;-) )
Anyway I have setup my device in a similar way you suggest : An internal sdcard with a uboot which boots an image on the external card... And it is definitively easier to work that way !

By the way does anyone know the exact imx6 part number which is is used in gk802 and so the max temperature ? (I guess it is not an extended version and so the max temperature is 95°C, Am I right ?)

(2013-04-17, 23:57)wolfgar Wrote: Hi,

I have just been able to test
Unfortunately when I launch xbmc in your image, I get the following error :
xcb_connection_has_error() returned true
and the screen remains black
I am investigating


edit : Here is the log when xbmc starts, not so bad... I wonder why my screen remains black...

Big Grin Got it run from within a light weight Xubuntu image that I have created, seems to run although CPU and temp is very high, the imx6 will go into 1/64 gpu lock down unless a good heatsink is in place.

Need to see if I can play a video.
More A10/GK802/I.MX6 stuff on my blog
I get a segmentation fault when try to play any video:

Aiur: 3.0.5
Core: MPEG4PARSER_06.04.25 build on Dec 10 2012 16:29:48
mime: video/quicktime; audio/x-m4a; application/x-3gp
file: /usr/lib/imx-mm/parser/lib_mp4_parser_arm11_elinux.so.3.1
Content Info:
Idx File:
Seekable : Yes
Size(byte): 94441522

Movie Info:
Seekable : Yes
Live : No
Duration : 0:02:05.458800000
ReadMode : File
Track : 3

Track 00 [video_000000] Enabled
Duration: 0:02:05.458800000
Language: und
video/x-h264, parsed=(boolean)true, width=(int)1280, height=(int)544, framerate=
(fraction)2997/125, codec_data=(buffer)00000001274d401fa9180a008b600d4040406db0a
[INFO] Product Info: i.MX6Q/D/S
vpudec versions Smile
plugin: 3.0.5
wrapper: 1.0.28(VPUWRAPPER_ARM_LINUX Build on Apr 4 2013 19:33:33)
vpulib: 5.4.10
Track 01 [audio_000000] Enabled
Duration: 0:02:05.461128000
Language: und
audio/mpeg, mpegversion=(int)4, channels=(int)2, rate=(int)48000, bitrate=(int)1
28000, framed=(boolean)true, stream-format=(string)raw, codec_data=(buffer)1190
Track 02 [subtitle]: Disabled
Codec: 0, SubCodec: 0
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
[INFO] bitstreamMode 1, chromaInterleave 1, mapType 0, tiled2LinearEnable 0
Beep: 3.0.5
Core: AAC decoder Wrapper build on Nov 29 2012 14:46:28
mime: audio/mpeg, mpegversion=(int){2,4}
file: /usr/lib/imx-mm/audio-codec/wrap/lib_aacd_wrap_arm12_elinux.so.3
CODEC: BLN_MAD-MMCODECS_AACD_ARM_03.07.00 build on Jul 17 2012 17:47:46.
Segmentation fault (core dumped)
More A10/GK802/I.MX6 stuff on my blog

Very interesting !
I was pretty sure it was indeed working behind the scene (at least the gui) even if I was unable to figure out why the screen remains black in the ubuntu image...
You seem to have the exact same issue I have in my other environment (I mean the framebuffer build for my yocto image) and it is by itself a very interesting result (even if I would have preferred that it simply works Wink )
In my other build the crash happens in the auir demuxer

Could you please try to create a core dump so that I can check that the Segmentation happens at the same place as for my other build ?
to do so you can issue the following commands
ulimit -c unlimited
echo "/tmp/core.%e.%p" > /proc/sys/kernel/core_pattern
And then you will get the core file in /tmp folder ...

Best regards

NB : For temperature I guess it is more related to GPU activity than to CPU and it is a shame that gk802 is so badly designed regarding heat dissipation ...
By the way enabling dirty regions should improve pressure on the GPU ...
I confirm that using dirty regions improves DRASTICALLY the temperature issue
To use dirty regions, refer to the howto here
algorithm 2 seesm to provide the best improvement...

By the way, most of the load on the main page comes from the RSS feed which scrolls at the bottom of the screen : Think about disabling it in the settings...
Coupled with dirty regions, It will significantly reduce the load on the main page...
Looks like the same problem in aiurdemux, core dump is here
More A10/GK802/I.MX6 stuff on my blog
Thank you very much
I had a close look but found nothing more
Here is the backtrace :
#0 __libc_do_syscall () at ../ports/sysdeps/unix/sysv/linux/arm/eabi/libc-do-syscall.S:47
#1 0x2bf34e62 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:67
#2 0x2bf37238 in __GI_abort () at abort.c:91
#3 0x2bf5c268 in __libc_message (do_abort=2, fmt=0x2bfda984 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:201
#4 0x2bf62bc6 in malloc_printerr (action=3, str=0x2bfdab90 "free(): invalid pointer", ptr=<optimized out>) at malloc.c:5007
#5 0x3d99a5c0 in av_fast_malloc () from /usr/lib/imx-mm/parser/lib_mp4_parser_arm11_elinux.so.3.1
#6 0x3d99abf4 in ff_h264_decode_nal () from /usr/lib/imx-mm/parser/lib_mp4_parser_arm11_elinux.so.3.1
#7 0x3d99d3fc in ParseH264Frames () from /usr/lib/imx-mm/parser/lib_mp4_parser_arm11_elinux.so.3.1
#8 0x3d98dc18 in MP4GetDecoderSpecificInfo () from /usr/lib/imx-mm/parser/lib_mp4_parser_arm11_elinux.so.3.1

It indeed confirms that it is the exact same bug...
Unfortunately aiur demux relies on these closed libraries which cannot be debuged : lib_*_parser_arm11_elinux.so

Well I am working on trying to get rid of aiurdemux ;-)

Hi, if you could upload the code base then I could also look into it.
More A10/GK802/I.MX6 stuff on my blog
What about 1080p high profile play on such key ?
Can XBMC bitstream Dolby True HD and DTS-HD on such devices ?

I am a daily user of XBMC on a Windows Server 2012 in my living room and would like to try a such devices for similar use but I still find it difficult to get infos about HW decoding support for example.
Hi mtx,

The source code for the X11 build is exactly rob's repository with commits 44a7a77 4d8a77c 2604f6b 304ac05 reverted.
I am currently uploading the whole source + config + build objects so that you can have full access to everyhting
I will post the link as soon as it is uploaded (expect a few hours as my internet uplink is slow and the archive is big Wink )

I tried to replace aiurdemux by the open source qtdemux
Unfortunately it is not a drop in replacement as one may think (or hope... )
In fact i does not work at all for the samples I tried : The vpudec aborts decoding very quickly when fed by this component.

So i have just decided to do it the hard way (Mainly because it is funnier than just replacing aiurdemux Wink ) : I will plug the vpu decoder in xbmc as a dvdvideocodec for dvdplayer using the fsl vpu wrapper library
I am currently working on a proof of concept to be sure I am able to decode a raw bitstream with my own source code.
It is very encouraging so far I think I should be able to have a working demo at the end of the week..
I will need a few additional days to integrate properly the whole thing in xbmc (everything depends on my free time... )

Hi jclb

From an hardware point of view the imx6 HDMI is able to send HD audio thanks to the parallel audio HBR
Yet I don't know whether the sound driver (imx-hdmi-soc) enables HBR pass through in its current state : I will have a close look at it

mtx : The whole X11 build (source + configuration + objects) is downloadable here
(2013-04-24, 21:32)wolfgar Wrote: mtx : The whole X11 build (source + configuration + objects) is downloadable here

Thank, will give it a try.
More A10/GK802/I.MX6 stuff on my blog
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 39

Logout Mark Read Team Forum Stats Members Help
[i.MX6] XBMC running on Freescale SoC's4
This forum uses Lukasz Tkacz MyBB addons.