•   
  • 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 39
  •   
[i.MX6] XBMC running on Freescale SoC's
Hi ProsjektX

Sorry I can't see obvious explanations : The few VPU errors ( IPU Warning - IPU_INT_STAT_10) appear even on working board
Don't you have anything on screen?
Do you have anything relevant in the xbmc log ?

Regards
Reply
(2013-04-11, 02:25)wolfgar Wrote: I have the exact same goal : Getting XBMC to run on GK802 with GPU and VPU acceleration.
As far as I am aware, there is no public port to support iMX VPU.

I can see 2 ways to address the problem :
* Let's develop a DVDVideoCodec to support the iMX VPU for dvdplayer
* Let's enable the use of gstreamer as the underlying player (and benefit from the gstreamer plugins which are already available) : Rob Clark did the job for the pandaboard a year ago : https://github.com/robclark/xbmc/tree/linaro
Hi Stephan,

Is your goal to submit your iMX VPU code upstream to XBMC as a patch pull request for mainstream inclusion as generic HW playback on all i.MX devices?

Will that in that case be the gstplayer gstreamer based player?

or the iMX VPU DVDVideoCodec for dvdplayer similar to Pivos AMLogic HW playback?

or both?

Keep up the great work!
Reply
Hi Hedda

(2013-07-28, 22:49)Hedda Wrote: Is your goal to submit your iMX VPU code upstream to XBMC as a patch pull request for mainstream inclusion as generic HW playback on all i.MX devices?
Yes it is my longterm objective, at least for i.MX6
Quote:Will that in that case be the gstplayer gstreamer based player?
No I have been faced with issues with the gstplayer port (crash in freescale dexumers which are closed sources).
Besides gstplayer is not mainlined so I have dropped this idea after a few tests...
Quote:or the iMX VPU DVDVideoCodec for dvdplayer similar to Pivos AMLogic HW playback?
Yes it is exactly the way my current port works...

Best regards
Reply
what are your thoughts on wandboard vs odroid u2 wolfgar? I'm keeping a keen interest in your development of wand board and this board might be the best bang/buck board out their, so thank-you and can't wait to see more development.

I'm currently on a Raspberry Pi
Reply
Hi MediaPi,

odroid u2 seems to be a nice piece of hardware similar to wandboard but, as a developer, i preferred to get a wandboard as freescale provides full support (I mean you have the whole source code in their BSP, you have great low level documentation...) for android and for linux for their iMX6 soc (including for the VPU, the only binary blobs being GPU libraries)
I was (and I am still) quite unsure about bare linux and vpu support for Exynos4412 so I opted for a wandboard as I guess exynos are, as many soc, only focused on android...


Best regards
Reply
Hi! I just bought a Zealz GK802 and want latest image for it with XBMC.. I will run dreambox plugin and stream thru XBMC to watch TV so Wifi is needed to be working to.. Is it possible yet?
Reply
Hi coolgate

Please try the image I released in post #86 : http://forum.xbmc.org/showthread.php?tid...pid1444576
You may have a codec issue (I can't remenber if I added mpeg2 before or after this release) but I will release a fresh XBMC build if it is the case.
Only one BIG warning : cool your GK802 (add a heatsink and/or a fan) because out of the box this device is not properly designed regarding heat dissipation and you will have a black screen while browsing XBMC GUI...

Best regards
Stephan
Reply
Hi Stephan,

I've now used your post #86 image for a while and have some questions/remarks but not before thanking you again for the great work!
-My timezone is off by 2 hours. I changed /etc/profile, forelast line into export TZ=UTC-2. This has now set my system time correctly, but xbmc is still off. Any ideas?
-Some vids make the gk802 crash and a reboot is needed. Not sure if it's related to earlier posts about mpeg-2 capability, but the log mentions codecid 22 is not (yet) handled just before is crashes
-The synergy client works to some extent (it's /usr/bin/usynergy, right?), but it seems to keep sending commands to the terminal that's running behind xbmc instead of working in the actual xbmc program itself. If I type something, a login prompt with the text that I'm typing is appearing overlayed on xbmc.
-In running a movie from my home server, over smb, I get a lot of the following types of messages in the log:
ERROR: GetPicture - player is ahead of time (440861.045220)
NOTICE: RenderFrame - No frame available to render !
NOTICE: Previous line repeats 6 times.
It seems the files are playing quite ok, although at times a bit choppy. I did some u/d rate checks and wifi seems to be quite ok, with around 12MB/s.


I apologize for the list, but I decided to spare up my questions so I won't need to bother you every time Smile.

Best,
Toverkwark
Reply
Hi Toverkwark,

- For timezone you should try to set TZ in /etc/rc.local just before launching xbmc
- codec 22 is CODEC_ID_FLV1 : there is no support in VPU for this one but sw decoding now works. I solved the bug which makes xbmc crash last week : I will upload a new build so that you can upgrade you xbmc
- usynergy client works fine for me (including in xbmc), you have to edit /etc/hosts and to change the line :
192.168.10.2 synergy_server
to set the IP address of your own synergy server
- The error messages "player is ahead of time" is a known bug which appears with some vids (not all). I am still tracking this one. I have an open bug here

Best regards
Stephan

PS : I compile a new XBMC compatible with your image and will post the upload link here ...

Update : New xbmc
Reply
Thanks a bundle! The time and codec issues seem solved now. Synergy still is the same, but it's ok as it is since yatse works very well too now.

(2013-08-12, 01:33)wolfgar Wrote: Hi Toverkwark,

- For timezone you should try to set TZ in /etc/rc.local just before launching xbmc
- codec 22 is CODEC_ID_FLV1 : there is no support in VPU for this one but sw decoding now works. I solved the bug which makes xbmc crash last week : I will upload a new build so that you can upgrade you xbmc
- usynergy client works fine for me (including in xbmc), you have to edit /etc/hosts and to change the line :
192.168.10.2 synergy_server
to set the IP address of your own synergy server
- The error messages "player is ahead of time" is a known bug which appears with some vids (not all). I am still tracking this one. I have an open bug here

Best regards
Stephan

PS : I compile a new XBMC compatible with your image and will post the upload link here ...

Update : New xbmc
Reply
Thanks Stephan! Everything seems to work now, except for synergy (same problem), but that's ok since I can do pretty much everything I want with yatse anyways.
Keep up the good work!
Reply
Hi Toverwark,


Great to read that almost everything works fine..

Regarding the synergy client, your symptoms are strange : Normally the synergy client is launched before xbmc it works while in xbmc (I use it very often as I only have an old PS2 mouse on my dev computer... ) Maybe there is a configuration issue ? On the server you have to call the client gk802 if I remember properly...
Anyway, as you say, yatse is just fine Wink

Regards
Stephan
Reply
Is there a good fan that u recomend? and is easy to install Smile
Reply
Good afternoon! Kindly please lay someone full image of the latest xbmc format. Iso for GK802. Thanks in advance.
Reply
Stephan,

Thanks for your work and sharing it with the community. I noticed your comparison between the wandboard and the utilite on your blog and was wondering your thoughts on the GK802 hardware. I know you mentioned heating problems and I think I can fix that with some mods/fans. I plan on adding a usb-ethernet adapter and just need something simple to play network content. I can get a GK802 with ethernet adapter for under $70 shipped to the states and find it hard to justify $60 + shipping for the wand quad and even more for the Utilite unless the 2GB ram and SATA makes a real difference for XBMC use. I appreciate your thoughts.
Reply
  •   
  • 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 39
  •   
 
Thread Rating:
  • 4 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[i.MX6] XBMC running on Freescale SoC's54