• 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 101
librtmp - Help Thread
#46
Ok -- so I downloaded latest XBMC April 18 build, installed, overwrote the librtmp and it works.

Google Drive librtmp.0.dylib location

Now I am trying to decode a stream and I get this error message

Code:
17:18:50 T:4602982400  NOTICE:   audiodevice             VHAudioCustom
17:18:50 T:4602982400  NOTICE:   audiosamplerate         16000.00
17:18:50 T:4602982400  NOTICE:   audiochannels           1.00
17:18:50 T:4602982400  NOTICE:   audioinputvolume        100.00
17:18:50 T:4602982400  NOTICE:   audiocodecid            11.00
17:18:50 T:4602982400  NOTICE:   audiodatarate           27.15
17:18:50 T:4602982400  NOTICE:   bufferSize              600k
17:18:50 T:4602982400  NOTICE:   maxBitrate              300k
....

17:19:20 T:4602982400 WARNING: OpenAudioStream - Unsupported stream 1. Stream disabled.

Anyone has any idea ? It was working with older XBMC I had (which I foolishly deleted when I installed this one)
#47
(2013-04-22, 02:32)mwahal Wrote: Ok -- so I downloaded latest XBMC April 18 build, installed, overwrote the librtmp and it works.

Google Drive librtmp.0.dylib location

Now I am trying to decode a stream and I get this error message

Code:
17:18:50 T:4602982400  NOTICE:   audiodevice             VHAudioCustom
17:18:50 T:4602982400  NOTICE:   audiosamplerate         16000.00
17:18:50 T:4602982400  NOTICE:   audiochannels           1.00
17:18:50 T:4602982400  NOTICE:   audioinputvolume        100.00
17:18:50 T:4602982400  NOTICE:   audiocodecid            11.00
17:18:50 T:4602982400  NOTICE:   audiodatarate           27.15
17:18:50 T:4602982400  NOTICE:   bufferSize              600k
17:18:50 T:4602982400  NOTICE:   maxBitrate              300k
....

17:19:20 T:4602982400 WARNING: OpenAudioStream - Unsupported stream 1. Stream disabled.

Anyone has any idea ? It was working with older XBMC I had (which I foolishly deleted when I installed this one)

Why are you using 12.0 Alpha? Your above post seems to say that but 12.1 has been released.
#48
(2013-04-22, 02:35)RedPenguin Wrote:
(2013-04-22, 02:32)mwahal Wrote: Ok -- so I downloaded latest XBMC April 18 build, installed, overwrote the librtmp and it works.

Google Drive librtmp.0.dylib location

Now I am trying to decode a stream and I get this error message

Code:
17:18:50 T:4602982400  NOTICE:   audiodevice             VHAudioCustom
17:18:50 T:4602982400  NOTICE:   audiosamplerate         16000.00
17:18:50 T:4602982400  NOTICE:   audiochannels           1.00
17:18:50 T:4602982400  NOTICE:   audioinputvolume        100.00
17:18:50 T:4602982400  NOTICE:   audiocodecid            11.00
17:18:50 T:4602982400  NOTICE:   audiodatarate           27.15
17:18:50 T:4602982400  NOTICE:   bufferSize              600k
17:18:50 T:4602982400  NOTICE:   maxBitrate              300k
....

17:19:20 T:4602982400 WARNING: OpenAudioStream - Unsupported stream 1. Stream disabled.

Anyone has any idea ? It was working with older XBMC I had (which I foolishly deleted when I installed this one)

Why are you using 12.0 Alpha? Your above post seems to say that but 12.1 has been released.

I was using Alpha 12.0 earlier, but it was crashing with librtmp. So, I just upgraded to 12.2 Beta and now I am seeing this unsupported stream 1 disabled issue. It was not there with Alpha 12.0.

BTW - this is not librtmp issue as librtmp works fine!

Code:
17:48:18 T:140735300538752  NOTICE: Starting XBMC (12.1 Git:20130317-0d373cc), Platform: Darwin OSX (12.3.0 x86_64, Version 10.8.3 (Build 12D78)). Built on Mar 17 2013

Code:
17:48:35 T:4646952960  NOTICE:   audiodevice             VHAudioCustom
17:48:35 T:4646952960  NOTICE:   audiosamplerate         16000.00
17:48:35 T:4646952960  NOTICE:   audiochannels           1.00
17:48:35 T:4646952960  NOTICE:   audioinputvolume        100.00
17:48:35 T:4646952960  NOTICE:   audiocodecid            11.00
17:48:35 T:4646952960  NOTICE:   audiodatarate           27.15
17:48:35 T:4646952960  NOTICE:   bufferSize              600k
17:48:35 T:4646952960  NOTICE:   maxBitrate              300k
17:48:35 T:4646952960  NOTICE:   xsplitBroadcasterVersion1.3.0.95
17:48:35 T:4646952960  NOTICE:   xsplitCoreVersion       1.2.1303.0101 Version 1.2
17:48:35 T:4646952960  NOTICE:   xsplitGameSourceVersion 1.1.1.30
17:48:35 T:4646952960  NOTICE:   xsplitMediaLibVersion   2.0.0.209
17:49:05 T:4646952960  NOTICE: Opening video stream: 0 source: 256
17:49:05 T:4646952960  NOTICE: Creating video codec with codec id: 28
17:49:05 T:4761493504  NOTICE: Thread CVideoReferenceClock start, auto delete: false
17:49:05 T:4646952960  NOTICE: Creating video thread
17:49:05 T:4768403456  NOTICE: Thread CDVDPlayerVideo start, auto delete: false
17:49:05 T:4768403456  NOTICE: running thread: video_thread
17:49:05 T:4646952960  NOTICE: Opening audio stream: 1 source: 256
17:49:05 T:4646952960  NOTICE: Finding audio codec for: 86054
17:49:05 T:4646952960   ERROR: Unsupported audio codec
17:49:05 T:4646952960 WARNING: OpenAudioStream - Unsupported stream 1. Stream disabled.
#49
(2013-04-22, 02:47)mwahal Wrote:
(2013-04-22, 02:35)RedPenguin Wrote:
(2013-04-22, 02:32)mwahal Wrote: Ok -- so I downloaded latest XBMC April 18 build, installed, overwrote the librtmp and it works.

Google Drive librtmp.0.dylib location

Now I am trying to decode a stream and I get this error message

Code:
17:18:50 T:4602982400  NOTICE:   audiodevice             VHAudioCustom
17:18:50 T:4602982400  NOTICE:   audiosamplerate         16000.00
17:18:50 T:4602982400  NOTICE:   audiochannels           1.00
17:18:50 T:4602982400  NOTICE:   audioinputvolume        100.00
17:18:50 T:4602982400  NOTICE:   audiocodecid            11.00
17:18:50 T:4602982400  NOTICE:   audiodatarate           27.15
17:18:50 T:4602982400  NOTICE:   bufferSize              600k
17:18:50 T:4602982400  NOTICE:   maxBitrate              300k
....

17:19:20 T:4602982400 WARNING: OpenAudioStream - Unsupported stream 1. Stream disabled.

Anyone has any idea ? It was working with older XBMC I had (which I foolishly deleted when I installed this one)

Why are you using 12.0 Alpha? Your above post seems to say that but 12.1 has been released.

I was using Alpha 12.0 earlier, but it was crashing with librtmp. So, I just upgraded to 12.2 Beta and now I am seeing this unsupported stream 1 disabled issue. It was not there with Alpha 12.0.

BTW - this is not librtmp issue as librtmp works fine!

Code:
17:48:18 T:140735300538752  NOTICE: Starting XBMC (12.1 Git:20130317-0d373cc), Platform: Darwin OSX (12.3.0 x86_64, Version 10.8.3 (Build 12D78)). Built on Mar 17 2013

Code:
17:48:35 T:4646952960  NOTICE:   audiodevice             VHAudioCustom
17:48:35 T:4646952960  NOTICE:   audiosamplerate         16000.00
17:48:35 T:4646952960  NOTICE:   audiochannels           1.00
17:48:35 T:4646952960  NOTICE:   audioinputvolume        100.00
17:48:35 T:4646952960  NOTICE:   audiocodecid            11.00
17:48:35 T:4646952960  NOTICE:   audiodatarate           27.15
17:48:35 T:4646952960  NOTICE:   bufferSize              600k
17:48:35 T:4646952960  NOTICE:   maxBitrate              300k
17:48:35 T:4646952960  NOTICE:   xsplitBroadcasterVersion1.3.0.95
17:48:35 T:4646952960  NOTICE:   xsplitCoreVersion       1.2.1303.0101 Version 1.2
17:48:35 T:4646952960  NOTICE:   xsplitGameSourceVersion 1.1.1.30
17:48:35 T:4646952960  NOTICE:   xsplitMediaLibVersion   2.0.0.209
17:49:05 T:4646952960  NOTICE: Opening video stream: 0 source: 256
17:49:05 T:4646952960  NOTICE: Creating video codec with codec id: 28
17:49:05 T:4761493504  NOTICE: Thread CVideoReferenceClock start, auto delete: false
17:49:05 T:4646952960  NOTICE: Creating video thread
17:49:05 T:4768403456  NOTICE: Thread CDVDPlayerVideo start, auto delete: false
17:49:05 T:4768403456  NOTICE: running thread: video_thread
17:49:05 T:4646952960  NOTICE: Opening audio stream: 1 source: 256
17:49:05 T:4646952960  NOTICE: Finding audio codec for: 86054
17:49:05 T:4646952960   ERROR: Unsupported audio codec
17:49:05 T:4646952960 WARNING: OpenAudioStream - Unsupported stream 1. Stream disabled.

Seems to be something wrong with your codecs in some manner. Can you use 12.1 stable? Maybe something is broken in Alpha is all I can figure.
#50
Let me find 12.1 stable release and try that. Is this not 12.1 stable ?
Code:
17:48:18 T:140735300538752  NOTICE: Starting XBMC (12.1 Git:20130317-0d373cc), Platform: Darwin OSX (12.3.0 x86_64, Version 10.8.3 (Build 12D78)). Built on Mar 17 2013
#51
Oh, sure looks it. Do you have a lonk to the stream because I can test it if you like?
#52
@RedPenguin

This is the list item in live-streamer.

Code:
<item>
    <title>cricpass</title>
        <link>rtmp://$doregex[rtmp]/stream playpath=corona1?id=90763 swfUrl=http://www.liveflash.tv/resources/scripts/eplayer.swf conn=S:OK pageUrl=http://www.liveflash.tv/embedplayer/corona1/1/600/420 live=1 swfVfy=1 timeout=30</link>
        <regex>
            <name>rtmp</name>
            <expres>.*redirect=([\.\d]+)</expres>
            <page>http://www.liveflash.tv:1935/loadbalancer</page>
       </regex>
</item>


Code:
18:00:18 T:4694134784  NOTICE: URL: rtmp://198.105.217.36/stream playpath=corona1?id=90763 swfUrl=http://www.liveflash.tv/resources/scripts/eplayer.swf conn=S:OK pageUrl=http://www.liveflash.tv/embedplayer/corona1/1/600/420 live=1 swfVfy=1 timeout=30
#53
(2013-04-13, 14:23)RedPenguin Wrote: Due to increasing demand for support on librtmp relating to XBMC and the fact that it covers many different video add-ons, I am creating this thread for any support releating to librtmp.

librtmp stands for RTMP Library which is part of rtmpdump (rtmpdump.mplayerhq.hu/) which is used in XBMC to play RTMP Video Servers. The reason you can't always use the one included in XBMC is because some servers purposely break stuff so that third-party players are broken so folks like KSV and others make patches yet a new librtmp file needs to be made and placed into XBMC to play said streams. Also some features such a redirects are not supported in the main official version of rtmpdump.

Note: I will never put in the Xeebo Handshake 10 patch for two reasons, for one it's usually immediately given a take down notice and it's only for x86 and known not to work well in librtmp form, making it very impractical for these uses.

Links for librtmp:

My librtmp files always with latest KSV patches and other related patches like Xeebo's (not Handshake 10 patches)
http://www.mediafire.com/?x4cvp5hl4m9xr

Note: More info on which folder to download from and what patches have been applied are located in the readme.txt in the root of the MediaFire folder.

My modified Android APKs with S74ck3r's librtmp.so:
http://www.mediafire.com/?x4cvp5hl4m9xr

Wiki Link to for librtmp: (Check this out on how to "install" the replacement librtmp file)
http://wiki.xbmc.org/index.php?title=HOW...te_librtmp

Please while asking for support, specify your exact Operating System and/or Distro especially if you are using the Raspberry Pi, Linux, or ATV1 (factory OS or Linux)!

OK I DOWNLOADED YOUR"My librtmp files always with latest KSV patches and other related patches like Xeebo's (not Handshake 10 patches)
http://www.mediafire.com/?x4cvp5hl4m9xr "

CAN YOU PLEASE SHOW ME STEP BY STEP WHERE AND HOW TO INSTALL THIS PLEASE!?!?!?!?!?!?!?!?!?! i have windows 7 as my OS
#54
you just replace the file librtmp file on OS. so for win7x86: go here C:\Program Files\XBMC\system\players\dvdplayer and replace the old file.
#55
My librtmp files always with latest KSV patches and other related patches like Xeebo's (not Handshake 10 patches)
http://www.mediafire.com/?x4cvp5hl4m9xr

What about this ow to install

What file to install.

sorry for the double post. I got what you are saying.Thank you
#56
(2013-04-22, 05:19)mwahal Wrote: @RedPenguin

This is the list item in live-streamer.

Code:
<item>
    <title>cricpass</title>
        <link>rtmp://$doregex[rtmp]/stream playpath=corona1?id=90763 swfUrl=http://www.liveflash.tv/resources/scripts/eplayer.swf conn=S:OK pageUrl=http://www.liveflash.tv/embedplayer/corona1/1/600/420 live=1 swfVfy=1 timeout=30</link>
        <regex>
            <name>rtmp</name>
            <expres>.*redirect=([\.\d]+)</expres>
            <page>http://www.liveflash.tv:1935/loadbalancer</page>
       </regex>
</item>


Code:
18:00:18 T:4694134784  NOTICE: URL: rtmp://198.105.217.36/stream playpath=corona1?id=90763 swfUrl=http://www.liveflash.tv/resources/scripts/eplayer.swf conn=S:OK pageUrl=http://www.liveflash.tv/embedplayer/corona1/1/600/420 live=1 swfVfy=1 timeout=30

This channel must only be on at certain times because it flat out refuses to play for me at all with or without sound.
#57
Hey redpeg...

What is the difference between downloading the livestreams file as an xml or as url at your signature?
If I helped you please add to my reputation a positive note

School has started, This Means Lots Of Homework[/color]


No Sharing XML's Anymore Per Forum Rules
#58
(2013-04-23, 00:59)crusader88 Wrote: Hey redpeg...

What is the difference between downloading the livestreams file as an xml or as url at your signature?

Well if you add it as a file, every single time I update it, you will have to redownload it and it replace your current file.

I add/delete (only delete deads) usually once every 2 weeks, more often more than not, so that could get very exhausting.

Yet if it add it as a URL, a fresh copy is downloaded every time you load LiveStreams, so it's always fresh. Smile.
#59
(2013-04-23, 01:22)RedPenguin Wrote:
(2013-04-23, 00:59)crusader88 Wrote: Hey redpeg...

What is the difference between downloading the livestreams file as an xml or as url at your signature?

Well if you add it as a file, every single time I update it, you will have to redownload it and it replace your current file.

I add/delete (only delete deads) usually once every 2 weeks, more often more than not, so that could get very exhausting.

Yet if it add it as a URL, a fresh copy is downloaded every time you load LiveStreams, so it's always fresh. Smile.

Thank you for pointing that out Smile
If I helped you please add to my reputation a positive note

School has started, This Means Lots Of Homework[/color]


No Sharing XML's Anymore Per Forum Rules
#60
Just to let folks know, I did not forget about ATV1 and MacOS.

It's been taking a lot longer to get a toolchain working than the instructions claim.

I've been fixing one error after another, LoL.

Mainly the problem is only stuff I can find for older ATV1/MacOS 10.4 is all old code and I had to use an old Ubuntu because everything is explodes in newer gcc/g++ as everything is from around 2009.
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 101

Logout Mark Read Team Forum Stats Members Help
librtmp - Help Thread8
This forum uses Lukasz Tkacz MyBB addons.