• 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 101
librtmp - Help Thread
#91
(2013-04-27, 17:12)smbs Wrote: QUOTE
"Also my apks are just the original Team XBMC released ones but I have placed the librtmp.so in and then resigned it, due to Android APK signing where the replaced librtmp.so is replaced every single reboot. Because of the different signature though, you cannot keep the original XBMC installed which causes you to lose all of your settings unless you back them up, but there is really no other way to do it."


Trying to understand!
Even though I manually replace the original librtmp.so with your librtmp.so before I load Xbmc it is only for the current session (also have doubts nothing seems to load)--- because next reboot will load original librtmp.so -is my understanding correct?
If so pls disregard my earlier post "however not one "*" channel works-- all fail to load most of your other channels work now with your librtmp.so installed" --this is incorrect because I rebooted the system thinking that your updated lib was installed.
Is it true to say that changing manually the libr before loading Xbmc will not cause Xbmc to read the updated libr?-- or will Xbmc work with updated libr until next reboot?

Due to Android's APK signing the file will only work in your current boot session, the original XBMC file will be placed back in on your very next re(boot). This is why folks use my APK.
#92
Hello @RedPenguin, sorry I wasn't able to test the ATV1 files posted by you earlier. I checked them today by copying the three files given by you in the ATV1(StockFW) folder to my ATV1 (stock). Unfortunately, my xbmc wouldn't start after copying these files.. I keep getting the 'XMBC exited with code blah blah' error. So, I can't even send you the log.. I had to put my old files back for xbmc to start.. Let me know if I could do anything else.

Thanks for your help.
#93
(2013-04-28, 03:53)agemineye Wrote: Hello @RedPenguin, sorry I wasn't able to test the ATV1 files posted by you earlier. I checked them today by copying the three files given by you in the ATV1(StockFW) folder to my ATV1 (stock). Unfortunately, my xbmc wouldn't start after copying these files.. I keep getting the 'XMBC exited with code blah blah' error. So, I can't even send you the log.. I had to put my old files back for xbmc to start.. Let me know if I could do anything else.

Thanks for your help.

Well another ATV1 user said if you put all 3 .dylib files in /usr/local/lib it worked fine for him/her.

I believe though you should only need to put the libcrypto and libssl into /usr/local/lib and put the librtmp.0.dylib into the XBMC folder, but appearntly either config should work.

Just make sure you are giving the files the correct permissions/owner/group, I know this easy can cause XBMC to crash.
#94
I put the 3 files in /mnt/Scratch/Users/frontrow/Applications/XBMC.app/Contents/Frameworks, as the older versions of these 3 files were here. Do you suggest something else? Permissions may be an isse as I do not know how to change them. Please advice.

(2013-04-28, 04:12)RedPenguin Wrote:
(2013-04-28, 03:53)agemineye Wrote: Hello @RedPenguin, sorry I wasn't able to test the ATV1 files posted by you earlier. I checked them today by copying the three files given by you in the ATV1(StockFW) folder to my ATV1 (stock). Unfortunately, my xbmc wouldn't start after copying these files.. I keep getting the 'XMBC exited with code blah blah' error. So, I can't even send you the log.. I had to put my old files back for xbmc to start.. Let me know if I could do anything else.

Thanks for your help.

Well another ATV1 user said if you put all 3 .dylib files in /usr/local/lib it worked fine for him/her.

I believe though you should only need to put the libcrypto and libssl into /usr/local/lib and put the librtmp.0.dylib into the XBMC folder, but appearntly either config should work.

Just make sure you are giving the files the correct permissions/owner/group, I know this easy can cause XBMC to crash.
#95
If you are in ssh, run the following command:

"ls -lh /mnt/Scratch/Users/frontrow/Applications/XBMC.app/Contents/Frameworks"

Be sure to either place in between or put it on Pastebin or pastie as it's likely to be huge.
#96
Sorry, I didn't get this one.. should I put the three files (from your website) back into xbmc and then do the ssh? I normally use FTP to transfer my file but could try SSH but it will take some time for me to figure out.
#97
(2013-04-27, 23:57)RedPenguin Wrote:
(2013-04-27, 17:12)smbs Wrote: QUOTE
"Also my apks are just the original Team XBMC released ones but I have placed the librtmp.so in and then resigned it, due to Android APK signing where the replaced librtmp.so is replaced every single reboot. Because of the different signature though, you cannot keep the original XBMC installed which causes you to lose all of your settings unless you back them up, but there is really no other way to do it."


Trying to understand!
Even though I manually replace the original librtmp.so with your librtmp.so before I load Xbmc it is only for the current session (also have doubts nothing seems to load)--- because next reboot will load original librtmp.so -is my understanding correct?
If so pls disregard my earlier post "however not one "*" channel works-- all fail to load most of your other channels work now with your librtmp.so installed" --this is incorrect because I rebooted the system thinking that your updated lib was installed.
Is it true to say that changing manually the libr before loading Xbmc will not cause Xbmc to read the updated libr?-- or will Xbmc work with updated libr until next reboot?

Due to Android's APK signing the file will only work in your current boot session, the original XBMC file will be placed back in on your very next re(boot). This is why folks use my APK.

Redpenguin many thanx for your patience
I now understand the procedure to replace libr.
I have an Mk808 android tv stick running JB 4.1.1. I installed XBMC 13.00 alpha1 compiled 19 Fb 2013 with HW accel,
The original libr works fine however when I replace it with your S74ck3r Compiled libr very few streams load one example is your channel Bravo it loaded with original libr but won't load with replaced libr- most channels which loaded with original libr won't load with new libr--- it seems that the new libr is not compatible with my android stick
Any ideas would be great
Thanx
#98
RedPenguin, the Rasp Pi ver I am using from your link is so.0, and I see both so & so.0 in the lib folder, am I correct in just replacing the .0 file ?
#99
(2013-04-28, 04:38)agemineye Wrote: Sorry, I didn't get this one.. should I put the three files (from your website) back into xbmc and then do the ssh? I normally use FTP to transfer my file but could try SSH but it will take some time for me to figure out.

Well I meant run that command from a terminal in some manor or possibly your FTP client can see if the replacement files are the same owner/group/permissions.

(2013-04-28, 19:26)smbs Wrote: Redpenguin many thanx for your patience
I now understand the procedure to replace libr.
I have an Mk808 android tv stick running JB 4.1.1. I installed XBMC 13.00 alpha1 compiled 19 Fb 2013 with HW accel,
The original libr works fine however when I replace it with your S74ck3r Compiled libr very few streams load one example is your channel Bravo it loaded with original libr but won't load with replaced libr- most channels which loaded with original libr won't load with new libr--- it seems that the new libr is not compatible with my android stick
Any ideas would be great

I will see what I can do but anything from the original library would/should be in the replacement library. Try running those "bad" streams with the replacement library and your debug log (http://wiki.xbmc.org/?title=Log_file)

(2013-04-28, 22:38)privado Wrote: RedPenguin, the Rasp Pi ver I am using from your link is so.0, and I see both so & so.0 in the lib folder, am I correct in just replacing the .0 file ?

That's because on Linux, some programs like symbolic links which are like Windows shortcuts. "librtmp.so" is actually pointing to "librtmp.so.0" so when you replace it, you technically "replace both".

If you can type "ln -lh" in the dir you will see it show an "arrow" from librtmp.so to librtmp.so.0.
(2013-04-29, 02:13)RedPenguin Wrote:
(2013-04-28, 04:38)agemineye Wrote: Sorry, I didn't get this one.. should I put the three files (from your website) back into xbmc and then do the ssh? I normally use FTP to transfer my file but could try SSH but it will take some time for me to figure out.

Well I meant run that command from a terminal in some manor or possibly your FTP client can see if the replacement files are the same owner/group/permissions.

(2013-04-28, 19:26)smbs Wrote: Redpenguin many thanx for your patience
I now understand the procedure to replace libr.
I have an Mk808 android tv stick running JB 4.1.1. I installed XBMC 13.00 alpha1 compiled 19 Fb 2013 with HW accel,
The original libr works fine however when I replace it with your S74ck3r Compiled libr very few streams load one example is your channel Bravo it loaded with original libr but won't load with replaced libr- most channels which loaded with original libr won't load with new libr--- it seems that the new libr is not compatible with my android stick
Any ideas would be great

I will see what I can do but anything from the original library would/should be in the replacement library. Try running those "bad" streams with the replacement library and your debug log (http://wiki.xbmc.org/?title=Log_file)

(2013-04-28, 22:38)privado Wrote: RedPenguin, the Rasp Pi ver I am using from your link is so.0, and I see both so & so.0 in the lib folder, am I correct in just replacing the .0 file ?

That's because on Linux, some programs like symbolic links which are like Windows shortcuts. "librtmp.so" is actually pointing to "librtmp.so.0" so when you replace it, you technically "replace both".

If you can type "ln -lh" in the dir you will s
ee it show an "arrow" from librtmp.so to librtmp.so.0.
Many thanx log file link
http://www.mediafire.com/?q5klj58afbtmua...87vnise92s
(2013-04-29, 19:56)smbs Wrote: Many thanx log file link
http://www.mediafire.com/?q5klj58afbtmua...87vnise92s

Mediafire states:

Access Denied

This download link has already been bound to another user. Please request a new link from the file owner.
(2013-04-29, 23:10)RedPenguin Wrote:
(2013-04-29, 19:56)smbs Wrote: Many thanx log file link
http://www.mediafire.com/?q5klj58afbtmua...87vnise92s

Mediafire states:

Access Denied

This download link has already been bound to another user. Please request a new link from the file owner.

Sorry about that see your pm
Thanx
You have the same error "ERROR: Problem accessing the DNS." that my buddy gets on his Nexus 7 and I have tried everything possible. For some reason if you put an IP instead of a domain name in the XML it bypasses this error but this would cause my list to break for other things such as if servers change IP but leave same domain name, I'd have to maybe update my list constantly and it would be very frustrating to users.

I have searched Google like a mad man and can't seem to find any solution to this at all and I even had my buddy put the original librtmp and even then original XBMC apk back on and no go Sad.

One time this issue only lasted for a day then it started for a week non-stop. Not sure why it comes and goes.
(2013-04-30, 06:40)RedPenguin Wrote: You have the same error "ERROR: Problem accessing the DNS." that my buddy gets on his Nexus 7 and I have tried everything possible. For some reason if you put an IP instead of a domain name in the XML it bypasses this error but this would cause my list to break for other things such as if servers change IP but leave same domain name, I'd have to maybe update my list constantly and it would be very frustrating to users.

I have searched Google like a mad man and can't seem to find any solution to this at all and I even had my buddy put the original librtmp and even then original XBMC apk back on and no go Sad.

One time this issue only lasted for a day then it started for a week non-stop. Not sure why it comes and goes.
Ok I understand there's a problem and you dont want to cause problems for other uses---just an idea is there no way I could download list every now and then and change problematic domain names to IP and run from local file---then I would have to do the updating!!! until a solution is found?
Thanx
smbs
(2013-04-30, 17:17)smbs Wrote:
(2013-04-30, 06:40)RedPenguin Wrote: You have the same error "ERROR: Problem accessing the DNS." that my buddy gets on his Nexus 7 and I have tried everything possible. For some reason if you put an IP instead of a domain name in the XML it bypasses this error but this would cause my list to break for other things such as if servers change IP but leave same domain name, I'd have to maybe update my list constantly and it would be very frustrating to users.

I have searched Google like a mad man and can't seem to find any solution to this at all and I even had my buddy put the original librtmp and even then original XBMC apk back on and no go Sad.

One time this issue only lasted for a day then it started for a week non-stop. Not sure why it comes and goes.
Ok I understand there's a problem and you dont want to cause problems for other uses---just an idea is there no way I could download list every now and then and change problematic domain names to IP and run from local file---then I would have to do the updating!!! until a solution is found?
Thanx
smbs

Yes you could if you wanted but I hope to find the issue soon.
  • 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 101

Logout Mark Read Team Forum Stats Members Help
librtmp - Help Thread8
This forum uses Lukasz Tkacz MyBB addons.