Pre XMBC 12.2 bug report -- missing cover art
#16
I don't know how you are running the script - what command are you actually running?

As I previously asked you, can you confirm if you have Movie Sets defined in your media library? It's possible you're getting an internal error because your library has no sets, and json returns this error when queried for sets.

Add the following to to texturecache.cfg:
Code:
logfile = +/tmp/tc.log
logfile.verbose = yes
to enable the logfile, run the script again, then upload the log to pastebin using the command "pastebinit -u /tmp/tc.log".

Remember, your problem relates to Artists, not Sets (which you may not have), so to query Artists you need to run the script with something like:

Code:
./texturecache.py jd artists beatles

and to pre-load artists:

Code:
./texturecache.py c artists
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#17
(2013-06-06, 19:36)MilhouseVH Wrote: Remember, your problem relates to Artists, not Sets (which you may not have), so to query Artists you need to run the script with something like:

I didn't have a cfg file. Now that I do, I believe things are working

Quote:
Code:
./texturecache.py jd artists beatles

This gives me:
[
{
"fanart": "",
"artistid": 226,
"label": "The Beatles",
"thumbnail": "",
"artist": "The Beatles"
}
]

Does this mean there is no artwork for the Beatles? I don't understand this since I've had Universal Artist Scraper search for artwork for my whole library on many occasions.

I had a whole whack of artwork prior to installing the latest version of OpenELEC and then doing a restore of my XBMC back up.

Could something have gone wrong with the restore? Even if it had, why won't the scraper find new artwork?

Quote:and to pre-load artists:

Code:
./texturecache.py c artists

And the output of this is:

Cache pre-load activity summary for "artists":

| fanart | thumbnail | TOTAL
--------------+-------------+-------------+-------------
Cached | - | - | 0
Deleted | - | - | 0
Duplicate | - | - | 0
Error | - | - | 0
Ignored | - | - | 0
Skipped | 2 | 3 | 5
========================================================
TOTAL | 2 | 3 | 5

Loading: 00:00:05.34
Parsing: 00:00:00.26
Comparing: 00:00:00.48
TOTAL RUNTIME: 00:00:06.12

Any ideas as to what this all means?

Thanks again for the help!
Reply
#18
(2013-06-07, 20:10)jdhanley Wrote: Does this mean there is no artwork for the Beatles? I don't understand this since I've had Universal Artist Scraper search for artwork for my whole library on many occasions.

Yes, you have no artwork for the Beatles. Try the same query for an artist you DO have artwork for (ie. for which thumbnails are visible in the GUI).

You can identify the artists that have artwork with the following query:
Code:
./texturecache.py query artists 'thumbnail != "" or fanart != ""'

(2013-06-07, 20:10)jdhanley Wrote: I had a whole whack of artwork prior to installing the latest version of OpenELEC and then doing a restore of my XBMC back up.

Could something have gone wrong with the restore? Even if it had, why won't the scraper find new artwork?

It does look like something has gone wrong with the restore. Have you confirmed that the backup contains the artwork files you are expecting to be restored? Maybe the backup only contains NFO files, and no artwork?

(2013-06-07, 20:10)jdhanley Wrote: and to pre-load artists:

Code:
./texturecache.py c artists

And the output of this is:

Code:
Cache pre-load activity summary for "artists":

              |    fanart   |  thumbnail  |    TOTAL    
--------------+-------------+-------------+-------------
Cached        |      -      |      -      |      0      
Deleted       |      -      |      -      |      0      
Duplicate     |      -      |      -      |      0      
Error         |      -      |      -      |      0      
Ignored       |      -      |      -      |      0      
Skipped       |      2      |      3      |      5      
========================================================
TOTAL         |      2      |      3      |      5      

       Loading: 00:00:05.34
       Parsing: 00:00:00.26
     Comparing: 00:00:00.48
TOTAL RUNTIME: 00:00:06.12

Any ideas as to what this all means?

This is confirming that you only have 2 fanart and 3 thumbnails defined in your database that are associated with Artists.

So the problem is not that Artists artwork is being scraped but is inaccessible, it is that NO artwork (or almost no artwork) is being scraped at all for Artists.

If you are "restoring a backup" or importing an exported library, then assuming the backup/export contains valid artwork, the restore or import is simply failing to import any artwork.

How did you create the backup, and what tool/addon are you using to restore it?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#19
(2013-06-07, 20:31)MilhouseVH Wrote: How did you create the backup, and what tool/addon are you using to restore it?

I used the XBMC 12.0 backup utility to backup (I backup daily) and I restored it into my 12.2 installation. Everything else seemed to restore ok (I think). Just not my Artist artwork.

But besides all that, why won't the Artist scraper work now and get me new artwork for all my artists?
Reply
#20
I've never used this utility. Have you ever restored your backup prior to 12.2, or is this the first time you've attempted a restore into a 12.x system? Maybe contacting the utility author would should more light on the problem.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#21
That was my first attempt at restoring anything.

But does anyone know why my artist scraper won't find new artwork for me?
Reply
#22
Well, not that it helps but you wouldn't be the first person on the planet to have meticulously taken backups of their system without ever testing whether the backups were any good and actually capable of restoring the expected data, only to find the backups were all useless when they are most needed... at least you don't have a business riding on this restoration process! Smile

My advice would be to start a new thread with a more eye catching and relevant title - something like "XBMC Backup not restoring artists artwork" - maybe someone with experience of the backup utility will then see it and chime in. Or if it's this utility you are referring to, add a post in that thread.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#23
(2013-06-07, 23:09)jdhanley Wrote: But does anyone know why my artist scraper won't find new artwork for me?

If you don't restore your backup - that is, start with a totally empty library - are you then able to scrape and find new artwork? I wonder if the (partially) restored data is confusing the scraper into thinking it doesn't need to go out and find new artwork (just a guess).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#24
Good idea.

Do you know how to "empty" my library? I've looked for a way to remove music from my library and I can't seem to figure it out.

Thanks again.
Reply
#25
(2013-06-08, 00:02)jdhanley Wrote: Do you know how to "empty" my library? I've looked for a way to remove music from my library and I can't seem to figure it out.

Thanks again.

Code:
rm ~/.xbmc/userdata/Database/MyMusic32.db; sync; reboot
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
#26
Ah yes. This worked in getting many of my artists artwork back. Thanks.

I notice quite a few artist thumbs are still not there. I am thinking this may be due to the scraper not finding them. But I only see a few album scrapers in the XBMC repository. Artist scrapers like MusicBrainz simply aren't there despite being listed in the XBMC repository http://wiki.xbmc.org/index.php?title=Add...usicBrainz

Anyone have any ideas why only a few of these are actually in the Frodo XMBC repo (http://wiki.xbmc.org/index.php?title=Cat...er_add-ons)?

And where I can actually find them?

Thanks!
Reply
#27
Only 7 of them are, and you can see by clicking on the "show" button where it says "v12 Frodo XBMC.org repo". at the top of the category listing.
Reply
#28
Yes. You are right. However, in XBMC itself, when I go to Add-Ons and Artist Information, there are only 5 listed (no Yo-Yo-MusicBrainz and no FreeBase).

Any ideas how to find and enable MusicBrainz and FreeBase for Artist Information?

Thanks!
Reply
#29
Ah, seems they got pulled from the Frodo repo and the pages hadn't been updated for that (since they just disappeared from the Frodo repo, rather than showing a change in info). Looks like those two are only compatible with Eden.
Reply
#30
Will they be added to the Frodo repo?
Or are the few scrapers that are there my only options? (I still find it hard to believe about 75% of my artists have no thumbnails)
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Pre XMBC 12.2 bug report -- missing cover art00
This forum uses Lukasz Tkacz MyBB addons.