•   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 8
  •   
Deprecated Addon Tag overview
#16
Could it be your addon is not compatible with MySQL type library setup?

Code:
02:59:46 T:452   DEBUG: Tag: CDatabase Using built-in SQLite via sqlite3!
Image

If my replies help you, please click on my reputation Image below :) thanks :)
#17
yes, at the moment it is only compatible with the sqlite database
i plan to make the addon also compatible with the mysql database.

but the to recognize the movie is not database dependent
it only reads some infolabels.
can you please tell me the skin you use?
i try something with that skin.
maybe you can provide me a logfile?
#18
Aeon Nox, but if you say that its not compatible with MySql, then thats the problem why it wont work for me. My log file above is aeon nox machine. I also have another machine with Cirrus Extended v3.
Image

If my replies help you, please click on my reputation Image below :) thanks :)
#19
ok, sorry.
please check here again in 2 or 3 weeks.
i first have to setup a mysql server to test the addon with mysql.
and i must add some mysql setting to the

i tested the addon now with following skins:

confluence
confluence-MOD
Aeon Nox
Cirrus Extended v3Cirrus Extended v3
diffuse
Hybrid
PM3.HD
#20
@olivaar

nice addon thanks for this addon

i have test it under openelec with aeon nox skin and it work great. I only have one problem but dont know if it was on my side or come from the addon.
If i select a movie and press key for open you addon, the addon opens and if i want then select one of my tags for the first time press down there will nothing happens. If i press down again the cursor goes to the selectable tags.

Eisi
#21
(2013-05-19, 17:27)Eisi2005 Wrote: i have test it under openelec with aeon nox skin and it work great. I only have one problem but dont know if it was on my side or come from the addon.
If i select a movie and press key for open you addon, the addon opens and if i want then select one of my tags for the first time press down there will nothing happens. If i press down again the cursor goes to the selectable tags.

i noticed this problem allready,
now i found a problem with the defaultcontrol in the xml
an empty list cannot get the focus
the defaultcontrol is now set in the script

changed in Version 0.0.5
#22
@olivaar

thanks for the new version, it works perfekt, but i think i have found a new bug. If the title have german letters like "ä,ö,ü" Your script did not start. There is no popup to select tag.

Eisi
#23
(2013-05-21, 19:08)Eisi2005 Wrote: @olivaar
thanks for the new version, it works perfekt, but i think i have found a new bug. If the title have german letters like "ä,ö,ü" Your script did not start. There is no popup to select tag.
Eisi

i have found a bug with the unicode conversion, but this kind of bug is a little bit tricky and maybe there are more bugs in the code (i dont hope so)
but thats the matter of an alpha version

i additionally added now full support for MySQL. the connection settings should be configured seperateley in the addon settings
the MySQL caused major changes in CDatabase and CVideoDatabase
All code for mysql support is inside the addon. no extra addons or modules are needed.
#24
(2013-05-22, 01:13)olivaar Wrote:
(2013-05-21, 19:08)Eisi2005 Wrote: @olivaar
thanks for the new version, it works perfekt, but i think i have found a new bug. If the title have german letters like "ä,ö,ü" Your script did not start. There is no popup to select tag.
Eisi

i have found a bug with the unicode conversion, but this kind of bug is a little bit tricky and maybe there are more bugs in the code (i dont hope so)
but thats the matter of an alpha version

i additionally added now full support for MySQL. the connection settings should be configured seperateley in the addon settings
the MySQL caused major changes in CDatabase and CVideoDatabase
All code for mysql support is inside the addon. no extra addons or modules are needed.

Still not working with MYSQL...

Code:
17:13:20 T:1380   DEBUG: CApplication::OnKey: tab (f009) pressed, action is RunScript(script.tagoverview)
17:13:20 T:1380    INFO: initializing python engine.
17:13:20 T:1380   DEBUG: new python thread created. id=135
17:13:20 T:1184  NOTICE: Thread XBPyThread start, auto delete: false
17:13:20 T:1184   DEBUG: Python thread: start processing
17:13:20 T:1184  NOTICE: -->Python Interpreter Initialized<--
17:13:20 T:1184   DEBUG: XBPyThread::Process - The source file to load is C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview\default.py
17:13:20 T:1184   DEBUG: XBPyThread::Process - Setting the Python path to C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.module.chardet\lib;C:\Program Files (x86)\XBMC\addons\script.module.simplejson\lib;C:\Users\htpc\AppData\Roaming\XBMC\addons\weather.wunderground\resources\lib\wunderground;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.module.myconnpy\lib;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.module.beautifulsoup\lib;C:\Program Files (x86)\XBMC\addons\script.module.pil\lib;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.common.plugin.cache\lib;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.module.simple.downloader\lib;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.module.mechanize\lib;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.module.parsedom\lib;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.module.elementtree\lib;C:\Program Files (x86)\XBMC\addons\script.module.pysqlite\lib;C:\Program Files (x86)\XBMC\system\python\DLLs;C:\Program Files (x86)\XBMC\system\python\Lib;C:\Program Files (x86)\XBMC\python26.zip;C:\Program Files (x86)\XBMC\system\python\lib\plat-win;C:\Program Files (x86)\XBMC\system\python\lib\lib-tk;C:\Program Files (x86)\XBMC;C:\Program Files (x86)\XBMC\system\python;C:\Program Files (x86)\XBMC\system\python\lib\site-packages;
17:13:20 T:1184   DEBUG: XBPyThread::Process - Entering source directory C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview
17:13:20 T:1184   DEBUG: Instantiating addon using automatically obtained id of "script.tagoverview" dependent on version 2.1.0 of the xbmc.python api
17:13:20 T:1184   DEBUG: Tag: main before
17:13:20 T:5044   DEBUG: Tag: CThreadTagMovies run start
17:13:20 T:5044   DEBUG: Tag: CDialogTagMovies new
17:13:20 T:5044   DEBUG: Tag: CDialogTagMovies init
17:13:20 T:5044   DEBUG: Tag: CDialogTagMovies getFileInfos
17:13:20 T:1184   DEBUG: Tag: main after
17:13:20 T:1184    INFO: Scriptresult: Success
17:13:20 T:1184    INFO: Scriptresult: Waiting on thread 5044
17:13:20 T:5044   DEBUG: Tag: CDatabase init using sqlite
17:13:20 T:5044   DEBUG: Tag: CDatabase Using built-in SQLite via sqlite3!
17:13:20 T:5044   DEBUG: xxx
17:13:20 T:5044   DEBUG: Tag: {0}#{1}#La boîte noire
17:13:20 T:5044   DEBUG: Tag: CDialogTagMovies getData
17:13:20 T:5044   DEBUG: xxx
17:13:20 T:5044   DEBUG: Tag: {0}#{1}#La boîte noire
17:13:20 T:5044   DEBUG: xxx
17:13:20 T:5044   DEBUG: Tag: {0}#{1}#La boîte noire
17:13:20 T:5044   DEBUG: xxx
17:13:20 T:5044   DEBUG: Tag: {0}#{1}#La boîte noire
17:13:20 T:5044   DEBUG: xxx
17:13:20 T:5044   DEBUG: Tag: {0}#{1}#La boîte noire
17:13:20 T:5044   DEBUG: xxx
17:13:20 T:5044   DEBUG: Tag: {0}#{1}#La boîte noire
17:13:20 T:5044   DEBUG: Tag: CDialogTagMovies No valid item selected
17:13:20 T:5044   DEBUG: Tag: CDialogTagMovies modal
17:13:20 T:1380   DEBUG: ------ Window Init (C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview\resources\skins\Default\720p\TagMovies.xml) ------
17:13:20 T:1380    INFO: Loading skin file: C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview\resources\skins\Default\720p\TagMovies.xml, load type: LOAD_ON_GUI_INIT
17:13:20 T:1380   DEBUG: LocalizeStrings: no strings.po file exist at C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview\resources\language\English, fallback to strings.xml
17:13:20 T:1380 WARNING: Skin has invalid include: dialogeffect
17:13:20 T:1380   DEBUG: LocalizeStrings: no strings.po file exist at C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview\resources\language\English, fallback to strings.xml
17:13:20 T:1380   DEBUG: Previous line repeats 2 times.
17:13:20 T:1380   DEBUG: CGUIMediaWindow::GetDirectory ()
17:13:20 T:1380   DEBUG:   ParentPath = []
17:13:20 T:5044   DEBUG: Tag: CDialogTagMovies onInit
17:13:20 T:5044   DEBUG: Tag: CDialogTagMovies call to open CDialogTagOverview window
17:13:20 T:1184    INFO: Scriptresult: Waiting on thread 2008
17:13:20 T:2008   DEBUG: Tag: CThreadTagOverview run start
17:13:20 T:2008   DEBUG: Tag: CDialogTagOverview open
17:13:20 T:2008   DEBUG: Tag: CDialogTagOverview init
17:13:20 T:1380   DEBUG: ------ Window Init (C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview\resources\skins\Default\720p\TagOverview.xml) ------
17:13:20 T:1380    INFO: Loading skin file: C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview\resources\skins\Default\720p\TagOverview.xml, load type: LOAD_ON_GUI_INIT
17:13:20 T:1380 WARNING: Skin has invalid include: dialogeffect
17:13:20 T:1380   DEBUG: LocalizeStrings: no strings.po file exist at C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview\resources\language\English, fallback to strings.xml
17:13:20 T:1380   DEBUG: Previous line repeats 6 times.
17:13:20 T:1380   DEBUG: CGUIMediaWindow::GetDirectory ()
17:13:20 T:1380   DEBUG:   ParentPath = []
17:13:20 T:2008   DEBUG: Tag: CDialogTagOverview onInit
17:13:20 T:2008   DEBUG: Tag: CDialogTagOverview buildList
17:13:20 T:2008   DEBUG: Tag: CDatabase init using sqlite
17:13:20 T:2008   DEBUG: Tag: CDatabase Using built-in SQLite via sqlite3!
17:13:20 T:5044   DEBUG: Tag: CThreadTagMovies run stop
17:13:20 T:1380   DEBUG: ------ Window Deinit (C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview\resources\skins\Default\720p\TagMovies.xml) ------
17:13:20 T:1380   ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview
17:13:20 T:2008   DEBUG: xxx
17:13:20 T:2008   DEBUG: Tag: {0}#{1}#La boîte noire
17:13:20 T:2008   DEBUG: LocalizeStrings: no strings.po file exist at C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview\resources\language\English, fallback to strings.xml
17:13:21 T:1380    INFO: initializing python engine.
17:13:21 T:1380   DEBUG: new python thread created. id=136
17:13:21 T:704  NOTICE: Thread XBPyThread start, auto delete: false
17:13:21 T:704   DEBUG: Python thread: start processing
17:13:21 T:704  NOTICE: -->Python Interpreter Initialized<--
17:13:21 T:704   DEBUG: XBPyThread::Process - The source file to load is C:\Users\htpc\AppData\Roaming\XBMC\addons\script.metadata.actors\resources\lib\service.py
17:13:21 T:704   DEBUG: XBPyThread::Process - Setting the Python path to C:\Users\htpc\AppData\Roaming\XBMC\addons\script.metadata.actors\resources\lib;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.module.chardet\lib;C:\Program Files (x86)\XBMC\addons\script.module.simplejson\lib;C:\Users\htpc\AppData\Roaming\XBMC\addons\weather.wunderground\resources\lib\wunderground;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.module.myconnpy\lib;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.module.beautifulsoup\lib;C:\Program Files (x86)\XBMC\addons\script.module.pil\lib;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.common.plugin.cache\lib;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.module.simple.downloader\lib;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.module.mechanize\lib;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.module.parsedom\lib;C:\Users\htpc\AppData\Roaming\XBMC\addons\script.module.elementtree\lib;C:\Program Files (x86)\XBMC\addons\script.module.pysqlite\lib;C:\Program Files (x86)\XBMC\system\python\DLLs;C:\Program Files (x86)\XBMC\system\python\Lib;C:\Program Files (x86)\XBMC\python26.zip;C:\Program Files (x86)\XBMC\system\python\lib\plat-win;C:\Program Files (x86)\XBMC\system\python\lib\lib-tk;C:\Program Files (x86)\XBMC;C:\Program Files (x86)\XBMC\system\python;C:\Program Files (x86)\XBMC\system\python\lib\site-packages;
17:13:21 T:704   DEBUG: XBPyThread::Process - Entering source directory C:\Users\htpc\AppData\Roaming\XBMC\addons\script.metadata.actors\resources\lib
17:13:21 T:704   DEBUG: LocalizeStrings: no strings.po file exist at C:\Users\htpc\AppData\Roaming\XBMC\addons\script.metadata.actors\resources\language\English, fallback to strings.xml
17:13:21 T:704   DEBUG: JSONRPC: Incoming request: {"jsonrpc":"2.0", "id":"1", "method":"Files.GetDirectory", "params":{"directory":"musicdb://2/", "sort":{"method":"label", "order":"ascending"}}}
17:13:21 T:704   DEBUG: JSONRPC: Calling files.getdirectory
17:13:21 T:704   DEBUG: CUtil::GetMatchingSource: no matching source found for [musicdb://2/]
17:13:21 T:704   DEBUG: Previous line repeats 4 times.
17:13:21 T:704   DEBUG: CMusicDatabase::GetArtistsByWhere query: SELECT artistview.* FROM artistview  WHERE (artistview.idArtist IN (SELECT song_artist.idArtist FROM song_artist) OR artistview.idArtist IN (SELECT album_artist.idArtist FROM album_artist)) and artistview.strArtist != '' and artistview.idArtist <> 1
17:13:21 T:704   DEBUG: Time to retrieve artists from dataset = 1
17:13:22 T:1380   DEBUG: Keyboard: scancode: 0e, sym: 0008, unicode: 0008, modifier: 0
17:13:22 T:1380   DEBUG: CApplication::OnKey: backspace (f008) pressed, action is Back
17:13:22 T:2008   DEBUG: Tag: CThreadTagOverview run stop
17:13:22 T:1184    INFO: Python script stopped
17:13:22 T:1184   DEBUG: Thread XBPyThread 1184 terminating
17:13:22 T:1380   DEBUG: waiting for python thread 135 (C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview\default.py) to stop
17:13:22 T:1380   DEBUG: python thread 135 (C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview\default.py) destructed
17:13:22 T:1380   DEBUG: ------ Window Deinit (C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview\resources\skins\Default\720p\TagOverview.xml) ------
17:13:22 T:1380   ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Users\htpc\AppData\Roaming\XBMC\addons\script.tagoverview
17:13:23 T:1380   ERROR: Previous line repeats 1 times.
Image

If my replies help you, please click on my reputation Image below :) thanks :)
#25
did you configure the mysql access in the addon settings?

17:13:20 T:2008 DEBUG: Tag: CDatabase init using sqlite
#26
Win!..didnt think of settings since there was none in previous versions Smile
Image

If my replies help you, please click on my reputation Image below :) thanks :)
#27
So i gave it a try and i found a problem.

You hard coded the XBMC video DB name so we can use Tag overview if we dont have the default DB name MyVideso75. I have 2 DBs...1 is for my wife and one is mine. Her's is called something else.

Also, Had to exit the movie section entirely and go back in for it to allow me to get the menu that allows you to pick which tag you want to apply. If you create the tag and then try to set a movie to it right away, it just pops up the overview window.
Image

If my replies help you, please click on my reputation Image below :) thanks :)
#28
(2013-05-24, 21:44)saitoh183 Wrote: So i gave it a try and i found a problem.

You hard coded the XBMC video DB name so we can use Tag overview if we dont have the default DB name MyVideso75. I have 2 DBs...1 is for my wife and one is mine. Her's is called something else.

Also, Had to exit the movie section entirely and go back in for it to allow me to get the menu that allows you to pick which tag you want to apply. If you create the tag and then try to set a movie to it right away, it just pops up the overview window.

thanks for your test.
for the first point, i have to look further into the profile-management. is it right that you define the media database for you and your wife in the advancedsettings.xml as name under the videodatabase-section (in separate profiles)?

for the second point i didnt get the second point exactly, i understand that you have done the following steps
1. if you are in movie section, highlighted a movie an press your hotkey: nothing happens
2. you go back to the main menu and select the movie section again
3. after selecting/highlighted a movie, pressing hotkey the dialog opens (title: add tag, in second row is the movie name)
4. all available tags are listed. if a tag is allready assigned to the movie, the radio button in front of the tag is higlighted
5. you create a new tag
6. the tag is added to the list
7. you select the new tag (to highlite it, and create a relation in the database between movie and tag) and
8 now the overview dialog appears?

to add a tag to the movie, only the dialog with the title: "add tag" and in second row the movie name is necessary.
the overview dialog is only necessary if you are interested for films without a tag, the rest is the same than the intrinsic xbmc-dialog

One warning about deleting movies from a tag: if you remove the last movie, tvshow or music video from a tag. xbmc deletes automaticly the tag (with a database trigger). i think about, to regenerate the tag automaticly or to make this behaviour selectable in the settings
#29
for the first point: you just need it to find the db name and not assume its the default name.

wife advsetting:
Code:
<videodatabase>
        <type>mysql</type>
        <host>192.168.13.190</host>
        <port>3306</port>
        <name>sissi_xbmc</name>
        <user>xbmc</user>
        <pass>xbmc</pass>
    </videodatabase>

when using default db name, you dont have to define it in advancesettings.xml.

mine
Code:
<videodatabase>
        <type>mysql</type>
        <host>192.168.13.190</host>
        <port>3306</port>
        <user>xbmc</user>
        <pass>xbmc</pass>
</videodatabase>

for the second point:

I realized the problem was me. i press the hotkey when i was on a movieset and it was the Tag Overview window that opened. When im on a movie it works as intended.

(2013-05-25, 10:47)olivaar Wrote: One warning about deleting movies from a tag: if you remove the last movie, tvshow or music video from a tag. xbmc deletes automaticly the tag (with a database trigger). i think about, to regenerate the tag automaticly or to make this behaviour selectable in the settings

I tried this. I had added 2 movies, then i went into the Tag overview window, selected the tag, selected Show movies, unselected the 2 movies and exited and the tag remained even if it was empty.
Image

If my replies help you, please click on my reputation Image below :) thanks :)
#30
@olivaar

thanks for the new version, but after upgrading from 0.5 to 0.6 i have the problem that i highlighted a movie and press my hotkey like the versions before, but i dont get the menu to select my tag i want to add i become the menu like i press the hotkey without highlighted a movie. i become the menu how i could see how much movies have a tag. If i go back to version 0.5 all works fine. Dont know if it is important i am on openelec (linux)
  •   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 8
  •   



Logout Mark Read Team Forum Stats Members Help
Addon Tag overview0
This forum uses Lukasz Tkacz MyBB addons.