•  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 13
  • Next 
 
Thread Rating:
  • 3 Vote(s) - 5 Average
Windows - Advanced MCE Remote Mapper Tool
#16
is there a way to program a button to trigger a scan for new content

i have been able to set this up with my openelec machines as it uses lirc and i can create a keymap.xml but haven't been able to get it working with the MCE Addon from the xbmc repo

i think the code is UpdateLibrary(video)

this would a great additional to be able to keymap

this looks like a great tool i am gonna test it out and see if it will be a alternative to the excellent MCE remote addon


also when you press save to file where does it save that file so i can back it up in case i need to re-install windows
Reply
#17
I use the button '*" mapped to Shift+Ctrl+8 to update my library. The keymap entry is <eight mod="ctrl,shift">UpdateLibrary(video)</eight>. You can use other combinations also.

File is saved in the same location as the exe file. So it is recommended to put the exe file in a dedicated folder.
Reply
#18
i think a nice feature might be the ability to create a keyboard.xml or keymap.xml (Whatever is required for windows i think keymap.xml is for linux) you could program the keys in this then export to a xml file that xbmc would recognise

We can then copy that over to other machines for the same keys on all machines instead of having to program each remote which can be a little annoying when you have multiple machines (i have 4 myself)
Reply
#19
hi guys, first time here and also a new adept of the wonderful XBMC cause i recently built my first HTPC
could someone help me? i need some assistance to setup the EJECT button from my HP control
i have control with number 2 and i'd like to make the eject button functional to open and close the tray
i don't know the Eject ID, well by guess i think maybe 34 but is a confuse process to manipulate the registry

i find this tool and i think this can solve my problem but still confuse with the process

when i press EJECT on showkey it returns nothing...
correct me if i'm wrong as i understand in order to make this works i need to add a registry key which BTW this program can help me and then use the EjectTray() keymapedit shows this so i think is a built in feature

can someone guide me on this journey please?
thanks in advance

Image
Reply
#20
Hi, Welcome to XBMC.

In the software, the button ID 34 corresponds to 'Eject'. Change the 'Key' value to say 'F12' or any combination of your choice and apply to registry. Create a keyboard.xml file in your xbmc application data folder which is usually under C:\Users\<your username>\AppData\Roaming\XBMC\userdata\keymaps. Enter %appdata% in Win 7 start search box to open the Roaming folder. You can copy the keyboard.xml file from 'C:\Program Files\XBMC\system\keymaps' if it is not present. Open this xml file in notepad++ and add <f12>XBMC.ejecttray</f12> in the global section as shown below:

Code:
<keymap>
  <global>
    <keyboard>
    
      <f12>XBMC.ejecttray</f12>
      <p>Play</p>
      <q>playlist.clear</q>
      <f>FastForward</f>
Reply
#21
that did the trick!!!
THANK YOU VERY MUCH

i really appreciate, it's amazing see guys making such a good software for free and helping a lot of people like me
keep all the great work you improved a great tool making it even better then before...

have a nice weekend pal!!!
Reply
#22
Hi baijuxavior,

Thank you for your very nice soft !
I have some questions :

I'm using like Chiforimpula, a HP MCE Remote but, for me, this is the number 1 (with 4 colored buttons).

I'm trying to remapped some buttons because out of the box, some don't work.

I'm using Showkey.exe and your soft.

For some buttons, I don't know what I have to set in your soft.
For example, with Showkey.exe, for the button 1 of my remote, this is the result : <ampersand>Notification(Key, ampersand, 3)</ampersand>

But, in your soft, I don't know how to set "Ampersand" because it doesn't appear in the list...

Can you help me ?

The list of the button I cant' remap :
Button 1 : <ampersand>Notification(Key, ampersand, 3)</ampersand>
Button 3 : <doublequote>Notification(Key, doublequote, 3)</doublequote>
Button 4 : <quote>Notification(Key, quote, 3)</quote>
Button 5 : <leftbracket>Notification(Key, leftbracket, 3)</leftbracket>
Button 6 : <minus>Notification(Key, minus, 3)</minus>
Button 7 : <underline>Notification(Key, underline, 3)</underline>

Thank you for your help Wink
Reply
#23
Sorry, I can't figure out which buttons you want to remap from your description. You have the first HP mce remote.

Image

Do you want to configure the numerical buttons (1, 2, 3 ,4 ... ) or some other buttons like the colored ones?
Reply
#24
Yes, I'm trying to configure the numerical buttons, in the green box.

Image

Lists of buttons doesn't work :
Button 1 : <ampersand>Notification(Key, ampersand, 3)</ampersand>
Button 3 : <doublequote>Notification(Key, doublequote, 3)</doublequote>
Button 4 : <quote>Notification(Key, quote, 3)</quote>
Button 5 : <leftbracket>Notification(Key, leftbracket, 3)</leftbracket>
Button 6 : <minus>Notification(Key, minus, 3)</minus>
Button 7 : <underline>Notification(Key, underline, 3)</underline>

(but others works, like button 2, 8 or 9)

If you can help me...

Thank you
Reply
#25
If you need other precisions, I can tell you.
Reply
#26
In the software set the 'Key' value to '1' , '3' and so on and remove all modifier keys like alt, ctrl for these buttons. Column 'Key Stroke' will show the resulting value. Apply to registry and reboot.
Reply
#27
I have tried what you say but it is already what is configured...
And this won't work Undecided

I have to screenshot (with Showkey on the right) :

For the button 2, if works fine
Image

But not for the button 3
Image

I don't know how to set this button with some character... Huh

Thanks !
Reply
#28
Run the application in Administrator mode. Otherwise changes will not update.
Reply
#29
I have already do what you said but nothing change.
The problem is not to configure the button but is to find what key correspond to ampersand in your soft...

Sad
Reply
#30
I am still not clear what your problem is. If my understanding is correct, when you press button '2', you are getting '2' which is normal. But when you press '1' you get '&' instead of '1'. Am I right?

You can try 'Load Original MCE' and 'Apply to Registry'. Then configure the other buttons.

Ampersand is not listed in the scancode table. Refer the wiki.
Reply
  •  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 13
  • Next 



Advanced MCE Remote Mapper Tool53