Solved keyboard key to subtitle menu (XBMC subtitles addon)
#1
Hey

I have installed the XBMC subtitles addon and i'm using it with the default skin and added the button to video osd. Now I have a problem, I have a harmony one remote but I can't find the keyboard key that access the subtitles menu where I can download a correct subtitle. L and T buttons on the keyboard just disables or enables the subtitles, but that won't be enough. Does someone know which button access the subtitle download menu?
Reply
#2
I think there is not a specific action linked to opening directly the subtitle download menu ...
What is stated on the page of the plugin:

To bind the add-on to a key use RunScript(script.xbmc.subtitles) in the keyboard.xml file.

So what you need to do is: find the key that you want to bind the subtitle action to
Then enable debuggin, and press that key, it will give you the key id.

Then go to your installation to : userdata/keymaps and add there (if it not exists create the keyboard.xml) with inside:

<keymap>
<global>
<keyboard>
<key id="####">RunScript(script.xbmc.subtitles)</key>
</keyboard>
</global>
</keymap>

with #### being the keyid you fetched from the debug log.
Reply
#3
I tried that but nothing happens. I added this line to keyboard.xml in XBMC/System/Keymaps folder

<key id="f044">RunScript(script.xbmc.subtitles)</key>

it is the key d

What I'm doing wrong?
Reply
#4
I checked the log after editing this keyboard.xml but when i'm pressing d the log indicates that there's no action assigned to d key and it does nothing. Hopefully this helps to solve this problem...
Reply
#5
I also tried to do in XBMC\Userdata\keymaps\keyboard.xml containing only this:

<keymap>
<global>
<keyboard>
<key id="f044">RunScript(script.xbmc.subtitles)</key>
</keyboard>
</global>
</keymap>

But still it doesn't work log indicates that theres nothing going on when I press d key

Here's a piece of the log file when I'm pressing d

14:57:33 T:31780 DEBUG: Keyboard: scancode: 20, sym: 0064, unicode: 0064, modifier: 0
14:57:33 T:31780 DEBUG: CApplication::OnKey: d (f044) pressed, action is
14:57:33 T:31780 DEBUG: ------ Window Deinit (Pointer.xml) ------
14:57:33 T:31780 DEBUG: ------ Window Init (VideoOSD.xml) ------
14:57:33 T:31780 DEBUG: ------ Window Init (Pointer.xml) ------
Reply
#6
Still trying to figure this out. It is like the keyboard.xml doesn't work. Is there some setting that I have to enable these added keyboard.xml commands?
Reply
#7
Download ShowKey.exe and run it. Press the key you want to assign and press the copy button. Create a new keyboard.xml file (I would suggest) with:

<keymap>
<FullscreenVideo>
<keyboard>
here paste what you copied, and replace the content between > < with: RunScript(script.xbmc.subtitles)
</keyboard>
</FullscreenVideo>
</keymap>

and copy it to your special folder\Userdata\keymaps\ so you won't have to modify the original keyboard.xml every time you update xbmc.
Also enable remote control sends keyboard presses in settings/system/input devices in xbmc.
Reply
#8
Worked perfectly, thanks very much!!!
Reply
#9
Marked as solved
Image  Come fight me in Torn City - a mostly-text browser massive multiplayer RPG
Reply
#10
Maybe this is another (Better?)solution?Wink

Automated subtitles. (Install as zip-file)

Auto Subtittle
Reply
#11
Hello. I tried to use the "RunScript(script.xbmc.subtitles)" shortcut on Gotham but nothing happens.
Since there was a change on the substitles engine, did that shortcut changed?

Here's the debug log:
Code:
23:47:54 T:8816   DEBUG: Keyboard: scancode: 0x58, sym: 0x0125, unicode: 0x0000, modifier: 0x0
23:47:54 T:8816   DEBUG: CApplication::OnKey: f12 (0xf09b) pressed, action is RunScript(script.xbmc.subtitles)
23:47:56 T:8252   DEBUG: CPullupCorrection: detected pattern of length 1: 41708.33, frameduration: 41708.333333
23:47:57 T:8816   DEBUG: ------ Window Init (VideoOSD.xml) ------
23:47:57 T:8816   DEBUG: ------ Window Init (Pointer.xml) ------
23:47:58 T:8816   DEBUG: CWinEventsWin32::WndProcWindow is active
Reply
#12
any suggestions how to get my 'u' key to work again and go directly to the subtitles menu?
Now that I installed xbmc 13 Gotham, the script.xbmc.subtitles doesn't work any more...
Reply
#13
ActivateWindow(subtitlesearch)
Reply
#14
works like a charm. Thanks!
Reply
#15
I have tried this but couldn't get it to work with my remote, appreciate if anyone can help. I did:

Code:
<keymap>
<global>
<keyboard>
<key id="u">ActivateWindow(subtitlesearch)</key>
</keyboard>
</global>
</keymap>

In C:\Users\Me\AppData\Roaming\Kodi\userdata\keymaps\keyboard.xml

I then went into the MCERemote program in Kodi and set my blue button to "u", rebooted, but hitting the Blue button didn't bring up the subtitle search window. All other settings for the remote are working fine.
Reply



Logout Mark Read Team Forum Stats Members Help
keyboard key to subtitle menu (XBMC subtitles addon)0
This forum uses Lukasz Tkacz MyBB addons.