volume extremely low
#1
Hi,

I'm running xbmc 12.2 downloaded from http://michael.gorven.za.net/content/xbmc-raspberry-pi on raspbian. The volume is extremely quiet when I play video. It is turned all the way up through xbmc, but I can barely hear it unless I turn my TV's volume up pretty high. I've tried various settings in the GUI, but none of them make any difference. I've tried turning the volume all the way up with a keyboard, but the highest it seems to go to is 0db.

I'm using the 3.5mm speaker jack which connects to my (standard def) TV through the red and white RCA ports.

It works with omxplayer on the command line (if I increase the current volume to 30db or so by using + in the omxplayer interface), so it seems like an XBMC specific issue.

Anyone else having this problem?

Thanks.
Reply
#2
Using Frodo v12.1 and analog volume has always been quite low.. no idea how to fix..
Reply
#3
Downmixing reduces volume, so if the audio is multichannel, it will be quieter than stereo sources.
Use "boost volume level on downmix" to compensate for this (although with the possibility of clipping).

By default xbmc doesn't allow the volume to go above 100%. If the audio source didn't encode with full range audio (e.g. only 25% of range is used) there is no way to get that back to full range.
There is an advancedsetting.xml setting you can add to mitigate this.
Code:
<audio>
<!-- Amount of gain (dB) to be applied to audio. Default is 12.0. Valid values are: -96.0 to 96.0. -->
<ac3downmixgain>12.0</ac3downmixgain>
</audio>

Note: despite the name, on the Pi this is applied to all audio types. Try setting it to 24, or 48 and you should find you can effectively set the audio to > 100%.
If the audio was full range to begin with, this may clip and distort, although in that case, reduce the xbmc volume until the clipping stops and you should have the maximum volume possible.
Reply
#4
(2013-05-15, 12:09)popcornmix Wrote: Downmixing reduces volume, so if the audio is multichannel, it will be quieter than stereo sources.
Use "boost volume level on downmix" to compensate for this (although with the possibility of clipping).

By default xbmc doesn't allow the volume to go above 100%. If the audio source didn't encode with full range audio (e.g. only 25% of range is used) there is no way to get that back to full range.
There is an advancedsetting.xml setting you can add to mitigate this.
Code:
<audio>
<!-- Amount of gain (dB) to be applied to audio. Default is 12.0. Valid values are: -96.0 to 96.0. -->
<ac3downmixgain>12.0</ac3downmixgain>
</audio>

Note: despite the name, on the Pi this is applied to all audio types. Try setting it to 24, or 48 and you should find you can effectively set the audio to > 100%.
If the audio was full range to begin with, this may clip and distort, although in that case, reduce the xbmc volume until the clipping stops and you should have the maximum volume possible.

I have "boost volume level on downmix" on and it doesn't make a difference. I also tried setting ac3downmixgain to 48, and that didn't change anything, either. My advancedsetting.xml looks like this:

Code:
<advancedsettings>
  <audio>
    <ac3downmixgain>48.0</ac3downmixgain>
  </audio>
</advancedsettings>

Any other suggestions?

Thanks.
Reply
#5
(2013-05-16, 05:09)Planswep Wrote:
(2013-05-15, 12:09)popcornmix Wrote: Downmixing reduces volume, so if the audio is multichannel, it will be quieter than stereo sources.
Use "boost volume level on downmix" to compensate for this (although with the possibility of clipping).

By default xbmc doesn't allow the volume to go above 100%. If the audio source didn't encode with full range audio (e.g. only 25% of range is used) there is no way to get that back to full range.
There is an advancedsetting.xml setting you can add to mitigate this.
Code:
<audio>
<!-- Amount of gain (dB) to be applied to audio. Default is 12.0. Valid values are: -96.0 to 96.0. -->
<ac3downmixgain>12.0</ac3downmixgain>
</audio>

Note: despite the name, on the Pi this is applied to all audio types. Try setting it to 24, or 48 and you should find you can effectively set the audio to > 100%.
If the audio was full range to begin with, this may clip and distort, although in that case, reduce the xbmc volume until the clipping stops and you should have the maximum volume possible.

I have "boost volume level on downmix" on and it doesn't make a difference. I also tried setting ac3downmixgain to 48, and that didn't change anything, either. My advancedsetting.xml looks like this:

Code:
<advancedsettings>
  <audio>
    <ac3downmixgain>48.0</ac3downmixgain>
  </audio>
</advancedsettings>

Any other suggestions?

Thanks.


I try me too this option... without any result...

...it will be really really nice if anyone could fix the problem relative to the analogic audio output and the movie with AC3 audio track. The voice is really really low... impossible to enjoy.... There was an option in XBMC to increase the gain on volume output, but in not present anymore......

Thank you in advance.
Reply
#6
I opened a bug in trac for this issue: http://trac.xbmc.org/ticket/14350
Reply
#7
I think is a problem of raspberry, not for XBMC....
Reply
#8
Not if it works with another video player (omx command line). Sounds like an issue in XBMC.
Reply
#9
I've made a fix to the firmware that allows volume to go above 100%.
If you download start.elf and fixup.dat from here:
https://github.com/Hexxeh/rpi-firmware

and replace the ones on your boot partition, you should find the ac3downmixgain works.
Reply
#10
...if it works, you are the king!

Thanks a lot!
Reply
#11
(2013-06-25, 13:13)popcornmix Wrote: I've made a fix to the firmware that allows volume to go above 100%.
If you download start.elf and fixup.dat from here:
https://github.com/Hexxeh/rpi-firmware

and replace the ones on your boot partition, you should find the ac3downmixgain works.

Hi, in my boot partition I have only start_x.elf and fixup_x.dat.... where I must copy start.elf and fixup.dat ??

Thank you
Reply
#12
The _x variants means they have camera and software codec (vp6/vp7/theora) support.

Just download the _x versions and replace the ones you have.


SOLVED!

Thank you very much!!!!! You rock man!
Reply
#13
(2013-06-25, 13:34)surfparadise Wrote: ...if it works, you are the king!

Thanks a lot!
Sad not works to me
Reply
#14
(2013-07-12, 00:45)alohl669 Wrote: Sad not works to me

Can you post a log?
Reply
#15
(2013-07-12, 00:52)popcornmix Wrote:
(2013-07-12, 00:45)alohl669 Wrote: Sad not works to me

Can you post a log?

Sorry, how can i make it? (find the log? or describe my situation??)
Reply
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
volume extremely low52