XBMC Error: Unable to create application. Exiting.
#1
Question 
Hi All,

I have a problem with XBMC on my Windows 8 server.

It was running fine and then one day when i booted it brought up the following;

XBMC: Error
Error: Unable to create application. Existing.

I tried a reinstall but the same problem exists. I have searched but cant find anyone else with this issue or Windows 8 instruction.

I am using version 12.2 of XBMC.

Server is Windows 8, 64 bit, 4GB ram, Intel core i5 2.8GHz, NVIDIA GeForce 10, 10gb storage.

I would like sent the error log but would need some instruction on how I find it on Windows 8! I cannot open XBMC to select it as an option either. Please could someone advise?

Will appreciate any advice, I want my XBMC back Sad

Cheers.
Reply
#2
BUMP

Could someone please advise how I can get a log on Windows 8 without needing to open XBMC as it crashes on startup?

Is there anyway I can do a compete 'wipe and reinstall' aswell? I did a basic uninstall/reinstall but problem still exists.

Any help would really be appreciated. Cheers.
Reply
#3
Really?
Tried searching the forum because this has been asked so many times.....
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#4
I cannot find this issue on Win 8 but I now found the general log but this doesn't contain any info. relating to why it wont start-up.

What I have now discovered is that if I move/rename the log, it opens fine. If I close and try and reopen, I can't? The log only contains info relating to the successful boot but nothing as to why it won't open the second time?
Reply
#5
I have the exact same problem and would like to know what to do about it.
I have reinstalled xbmc 3 times and the same thing happens every time I restart xbmc... This started about a week ago.
Im running xbmc on a Windows 8 machine to.
Reply
#6
I ran I to this with win7 when restarting xbmc after using a emulator via ROM collection browser. This is how I got around it

http://forum.xbmc.org/showthread.php?tid...pid1429029
Reply
#7
I have had the same problem on my x64 Windows 8. I installed into "C:\Program Files (x86)\XBMC" and I got the error. When I installed to C:\XBMC it just worked! Maybe some extra security due to Windows 8 or x64/x86 has anything to do with it??
Reply
#8
Getting the same error message here. Running Frodo 12.3 on Win7 64-bit. I also had my installation in C:\Program Files (x86)\XBMC and saw that re-installing to a different directory would help so I installed to C:\XBMC but I'm still getting the error message. I have the latest drivers for my Radeon 7770. Anyone have any other ideas?
Reply
#9
Tried my link? Or even try to delete the xbmc.log file when you get the error. Everyti.e I get the error the log file is not writable by non admin users.
Reply
#10
(2014-01-11, 05:07)teeedubb Wrote: Tried my link? Or even try to delete the xbmc.log file when you get the error. Everyti.e I get the error the log file is not writable by non admin users.

I did try your link. I used the Unlocker program to figure out what was keeping the XBMC.log file from being deleted - turns out it was the NetfliXBMC serivce. So I killed the process and deleted the XBMC.log which allowed me to open up XBMC again. I guess my question is - why does this even happen in the first place? Will setting up the Task Launcher prevent the error from coming up in the future? I don't have any restrictions on my UAC but is that still the issue?
Reply
#11
Not sure why it happens. I used to get the problem a lot with rcb in solo mode until I started using the .vbs scripts, but I would still get the error with only Mame, hence why I have to use unlocker. Using a vbs script also prevents the error with my steam launcher add on. I've never used netflixbmc so I don't know how its run and not sure how to integrate either methods into it.
Reply
#12
(2014-01-11, 21:44)teeedubb Wrote: Not sure why it happens. I used to get the problem a lot with rcb in solo mode until I started using the .vbs scripts, but I would still get the error with only Mame, hence why I have to use unlocker. Using a vbs script also prevents the error with my steam launcher add on. I've never used netflixbmc so I don't know how its run and not sure how to integrate either methods into it.

I'm gonna go ahead and show my lack of nerd street-cred by saying I have absolutely no clue what you just said, LOL Smile
Reply
#13
Haha no worries man. Maybe mention this problem/solution in the netfilxbmc thread
Reply
#14
(2014-01-11, 22:41)teeedubb Wrote: Haha no worries man. Maybe mention this problem/solution in the netfilxbmc thread

Yeah, good call. Strange that the plug-in service would still be running after XBMC closes.
Reply
#15
I can confirm that this is an issue which can be caused by NetflixBMC not exiting correctly, leaving a lock on the xbmc.log file. Killing the process, deleting the log file and restart xbmc fixes this.
Reply



Logout Mark Read Team Forum Stats Members Help
XBMC Error: Unable to create application. Exiting.0
This forum uses Lukasz Tkacz MyBB addons.