•   
  • 1
  • 6
  • 7
  • 8
  • 9
  • 10(current)
Fanart Grabber - Current Version 0.15.1
Hi @robweber

I am receiving errors with script.grab.fanart since the new v0.15.1 updated onto my system.

Log is here. Error at line 1241... acoqakafes.kodi (paste)

I use Transparency! and AeonNox:SiLVO, but not sure which skin is using this script.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
i getting an error message at startup  "GRAB FANART ERROR​"

i have new install of  LE9.0.2 (kodi18) on my ceneric HTPC, with Aeon Nox Silvo skin

is this an know error??

i already enabled  "settings/libreElec/network and enable wait for network to be online​​ 

yowehuyisu.kodi (paste)
Reply
Looks like my old friend - the Unicode Error. 

Looking at the trace for both of the above posts the issue is with a JSON call. Unforantely the actualyl error is being thrown by the "kodi-six" module; which is used as a wrapper for Python2 to Python3 conversion with Kodi specific libraries. So while the error affects the Fanart Grabber addon, it's kodi-six that is actually generating the error. Not trying to pass the buck but I won't be able to fix this. I'll post your files in the Kodi-six thread and see what comes back.
Reply
(2019-09-08, 22:25)robweber Wrote: Looks like my old friend - the Unicode Error. 

Looking at the trace for both of the above posts the issue is with a JSON call. Unforantely the actualyl error is being thrown by the "kodi-six" module; which is used as a wrapper for Python2 to Python3 conversion with Kodi specific libraries. So while the error affects the Fanart Grabber addon, it's kodi-six that is actually generating the error. Not trying to pass the buck but I won't be able to fix this. I'll post your files in the Kodi-six thread and see what comes back.
@robweber 

sorry i cannot follow you, with kodi-six. But nevertheless thanks for tring to help me with this
Reply
@Karellen  and @NiekN 

Not the best news on the error you submitted. In order to achieve Python 2 and Python 3 compatibility (required for newer versions of Kodi) I used a library called "kodi-six" which takes care of the compatibility issues. The idea is it does the right conversions based on if you're on Py2 or Py3. 

The developer got back to me and explained an issue regarding character set encodings is causing the problem. You can read his full explanation here. This isn't something that can be fixed based on the response I got. Kodi is storing data on your system in byte sequence formats and the error is thrown trying to convert them to UTF-8.  In past versions of this addon that conversion hasn't been happening since Python2 does the same thing for string data. With the move to Python 3 strings are now Unicode, which is something the kodi-six library tries to standardize for Python 2 strings. 

What I would do is rollback the version of this addon on your system to the previous version. It will function the same and actually work. Moving to Python 3 (Kodi Matrix and above) you're likely to see this error happen again since Python 3 will treat the character encodings different at a very low level and throw errors as well. I imagine this will affect other addons as they start to migrate as well. I have a Python3 version of Kodi setup as a dev environment. I'm going to try and duplicate this to confirm but the @Roman_V_M 's explanation makes sense.
Reply
Thanks @robweber

For other members that need to roll back the update, follow these steps
  1. Download v0.14.1 as a zip file from here... http://mirrors.kodi.tv/addons/leia/script.grab.fanart/
  2. Install the add-on using Settings>Addons>Install from zip file
  3. You must disable automatic updates for this add-on otherwise it will update itself again to the broke version
  4. This add-on is found in Settings>System>Add-ons>Manage dependencies
  5. Open the add-on settings page and disable Auto-update
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)  
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki)  ||  Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
@robweber

thanks for your help

jeez,  i hoped kodi 18 will work better for me(fix some small issues) ..  but i found only more issues at my system, running kodi18/LE9 
i think i will go back to kodi17, and hope after a 6  mnd they are solved
Reply
Hi, does this work with, or can it be extended to work with, extra fanart that's named fanart1, fanart2 etc...or is it just limited to the single "default" fanarts?
Reply
  •   
  • 1
  • 6
  • 7
  • 8
  • 9
  • 10(current)
 
Thread Rating:
  • 3 Vote(s) - 4 Average



Logout Mark Read Team Forum Stats Members Help
Fanart Grabber - Current Version 0.15.143