XBMC / ATV2 disconnecting after 45-55 mins
#1
Hi there,

I am having a repeating issue with playing series on my ATV2 via XBMC, from and external HDD that is connected via USB on my TP-Link TL-WR1043ND router. The ATV2 is connected via ethernet on this router as well.

Every time when I am about 45 to 55 mins into an episode, the screen freezes and the file stops playing. After a couple of seconds I get thrown to the menu and an error message saying "Operation timed out" appears. By this time, the router kind of stops working (it remains turned on), losing all internet/LAN connections.

The log can be seen here. I don't know enough about code to decipher this, hope anyone could tell me what exactly is going wrong so I can do something about it. Thanks a lot in advance!

What is happening here? Sad
Reply
#2
The samba server on your router refuses to deliver any data in the middle of playing that video. So its an issue located on your router. I have the same router btw - but i don't use it as NAS but only as router. Are you using the stock firmware? Or did you install DD-WRT or OpenWRT on it?

Whatsoever - the problem is not in XBMC.
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#3
(2013-06-17, 15:04)Memphiz Wrote: The samba server on your router refuses to deliver any data in the middle of playing that video. So its an issue located on your router. I have the same router btw - but i don't use it as NAS but only as router. Are you using the stock firmware? Or did you install DD-WRT or OpenWRT on it?

Whatsoever - the problem is not in XBMC.
Thanks for the reply.

I use the stock firmware on the router. on the admin page it says "3.13.12 Build 120405 Rel.33996n".

Does the log give any clue on why it refuses to deliver that data after that specific set of time?
Reply
#4
It just doesn't respond anymore ... its like pulling the ethernet cable while playing a video. Of course it doesn't tell us "I refuse to work from now on because i am bored" <- its not that easy Wink
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#5
(2013-06-17, 15:12)Memphiz Wrote: It just doesn't respond anymore ... its like pulling the ethernet cable while playing a video. Of course it doesn't tell us "I refuse to work from now on because i am bored" <- its not that easy Wink
Will it ever be XD

Give me an hour and I will post a log of the router itself as well.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
XBMC / ATV2 disconnecting after 45-55 mins00