Solved -  Streacom IR & Remote - Easy custom setup that works with XBMC
#16
@o_dog: sorry i don't get your 2nd comment, can you explain some more?
Reply
#17
nailed it. I flashed the RC260-20120515-SLEEP.bin into the IRRC and modified the keyboard.xml to have the following sleep action:

<sleep>XBMC.Suspend()</sleep>

Then i disabled usb wakeup for the device through udev rules (after finding out the correct id's:

sudo nano /etc/udev/rules.d/90-disableirwakeup.rules

ACTION!="remove", SUBSYSTEM=="usb", ATTRS{idVendor}=="1241", ATTRS{idProduct}=="e000" RUN+="/bin/sh -c 'echo disabled > /sys$env{DEVPATH}/../power/wakeup'"

after a reboot now i can use the powerbutton to have the HTPC supended AND wake only on pressing the powerbutton again, disregarding all other RC6 codes.


----------------------------------
edit: sorry i see this thread is on windows support; instructions above are for linux ofcourse

From streacom support i got the following instructions:

1. Go into the device manager and locate the IRRC (it will be one of the HID compliant mouse devices, hardware ID HID\VID_124&PID_E000&MI_01&CoI1)

2. Under power management tab, UNTICK the 'allow this device to wake the computer'
Reply
#18
Is it possible to use the Harmony (icm with MCE keyboard mode) with this receiver? I have tried this but the ir receiver doesn't respond.
Reply
#19
(2014-01-09, 14:38)awakener Wrote: Is it possible to use the Harmony (icm with MCE keyboard mode) with this receiver? I have tried this but the ir receiver doesn't respond.

I'd be interested to know this too.
Reply
#20
it's possible to use the harmony. BUT you need to set the right remote. I think i just picked "Windows Media Center" or something like that. You cannot send keyboard commands, the receiver translates the ir codes to keyboard commands that you specified int he firmware. So just set your harmony to windows media center and it should work just like the original remote. But you still need to change the firmware if you want it to work as you want it to, since the original mapping sucks.
Reply
#21
Hello there,

Thank you o_dog, for providing basic guidelines to the proper use of this ¨¨¨ software. I almost lost reason trying to figure it out (and seriously messed up the keyboard commands of my system)!

Do you know why some keys aren't correctly mapped? For example, if I try to assign the "A" key to the red button, it does not work. But if I try to assign another letter, it works. Any idea if the software has some bug regarding some keyboard keys? I'm not using Streacom remote but another RC6 remote (Hauppauge).

Also, do you know how to properly configure the Windows button as to allow to launch a software? I figure it's related to the "command" function of the software. But I'm not eager anymore to randomly browse through the software capabilities since it has the potential to wreak havoc...

Sincerely,

Antoine
Reply
#22
I have tried this remapping software but it fails immediately on launch with a "Runtime error '9'.Subscript out of range'.

This is on Windows 8.1 64-bit.
Reply
#23
try running as admin
Reply
#24
I did - right-click and select Run as Administrator. No difference.
Reply
#25
no idea then, the program works, either you're missing some runtimes or it doesn't work on windows 8.1.
Reply
#26
I have emailed Streacom, fingers crossed they will know what is wrong.
Reply
#27
(2014-05-07, 12:10)quartermain Wrote: I have tried this remapping software but it fails immediately on launch with a "Runtime error '9'.Subscript out of range'.

This is on Windows 8.1 64-bit.

I had the same problem on my HTPC (Win 8). I got around it by using another computer (Win 7) to remap the module. The problem went away when I upgraded 8.1
Reply
#28
I asked Streacom support about that error 9 issue in win 8.1.

Streacom Support Wrote:It appears that Runtime error '9' problems are related to the way the software is enumerating devices, combined with the hardware changes on your system.

Users have reported that the solution is to uninstall all entries in the device manager for HID devices (except keyboard and mouse) and then scanning for new hardware. Once the hardware is detected and installed again, the re-mapping software should run correctly.

Removing and re-detecting the HID devices worked for me.
Reply
#29
Me too, though I had to remove quite a lot of devices. Fortunately the keyboard and mouse kept working.
Reply
#30
Dear Sirs,

My name is Levente Benedek from Hungary, i am building HTPC computers, i discovered your cases and love them.
The most i am using for the moment is the FC8 Evo. The only problems i have is the IRRC and IRPB. I am using for my systems Harmony Ultimate remotes configuring them in a way where everything can be controlled from the remote. I must have the ability to use the remapping software but the problem is that i bought already 2 sets of IRRC and IRPB and the remapping software is not recognizing the infra device. The only thing is working on the IRRC remote version is to turn on and shut down the device, nothing else, i tried of course the red and blue button switching but with no luck. Now i red on your forum that the problem could be that the IRCC/IRPB that i purchased is an older version and it is not compatible with the remapping software or no proper driver has been installed for them. I purchased all my cases and IRCC/IRPB from Caseking in Germany as your official reseller point. Please help me further, how can i solve this issue, where can i buy the proper IRCC/IRPB devices or what alternative Infra can i buy to make it work, as i would love to use your cases for the future.
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Streacom IR & Remote - Easy custom setup that works with XBMC51