Thread Closed
Android Nightly builds video/audio playing too fast
#1
Since Gotham Alpha 4, the nightly versions play video too fast and audio sounds like someone is talking underwater.
This problem exists for almost a month on SD,HD and streaming video(everything).
The bug started somewhere between 1-2 June 2013?
When I turn on debug log it shows video is playing between 24-28 fps with lots of dropped frames.

Log
Test with TMZ plugin included in default xbmc
http://xbmclogs.com/show.php?id=34894
Device: MK808B, Android 4.2.2

error from line 790
CDVDPlayerAudio:: Discontinuity1 - was:161563.125000, should be:1334.573596, error:-160228.551404

Does anyone know when it will be fixed?, Is it a codec issue(ffmpeg) perhaps?
#2
Anyone?
#3
Thought I'd ping on this as well. Same issues here. Can post a log if useful.
#4
To be specific, the problem appeared between the 29/05 and the 1/06 nightly. Investigating...
#5
Same here with alpha 5 & 6, Works fine on alpha 4.

Windows 8 & Core i3-530
#6
In case anyone is interested, the problem was present only in directsound spdif mode with dts. Changing to wasapi spdif solved it
#7
And the topic said android ... but thx for jacking the thread ...
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
#8
And the topic can be closed really. It is solved in latest alpha and in nightlies.
#9
Still have this problem in Alpha 7 on Windows 8.

I can't use wasapi because I get no audio (because of some other issue I read about a while back that I can't remember).

Going back to Frodo or alpha 4.

BTW, a few people here are reporting the same issue...

http://xbmc.org/xbmc-13-gotham-april-and-may-cycles/
#10
(2013-09-01, 19:22)lazcool Wrote: Still have this problem in Alpha 7 on Windows 8.

I can't use wasapi because I get no audio (because of some other issue I read about a while back that I can't remember).

Going back to Frodo or alpha 4.

BTW, a few people here are reporting the same issue...

http://xbmc.org/xbmc-13-gotham-april-and-may-cycles/

Please read the thread title. This thread is/was about an android-specific issue and has nothing to do with WASAPI or Windows.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not e-mail Team Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
  Thread Closed
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Nightly builds video/audio playing too fast00
This forum uses Lukasz Tkacz MyBB addons.