•  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 44
  • Next 
 
Thread Rating:
  • 8 Vote(s) - 4.63 Average
MovieLib - Your movie database on web
#16
(2013-07-05, 12:28)Regss Wrote: I forgot about the local files. I'll try to add support for it as soon as I get back from vacation.

Great thanks!
Reply
#17
The table is empty. I checked the 'config' table also and this table is filled. One line with the standard config.
I added the user admin to the 'user' table and now i'm able to login.

In the settings i changed sync with XBMC database and i checked the connection with 'Check connection' --> Connected found 840 movies.
I tried 'Sync Now' but nothing happens. No error. I checked the table 'movies' but the table is empty. So no sync.
Reply
#18
During installation, an error must have occurred and the users table is not correctly filled.

Movies synchronize when You go to main site: index.php

If the movies can not be synchronized. And users do not want to add. The problem lies in the execution of the INSERT statement to the database. Check whether the user through which you connect to the database has permission to execute INSERT statement.

Connection Configuration to the database is in the db.php file.

EDIT:
I forgot about one decimal point and there may be a problem with synchronization. I just added the amendment. Download function.php again from here: movielib
Reply
#19
Hello

I'm pretty sure my user 'movielib' has all rights to access the database. To check i logged into MySQL Workbench with the user 'movielib' and i could insert,update, create without problems. I did from 'localhost'
The webserver with PHP 5.4.7 and MySQL 5.5.22 server is installed at the same machine.

I reinstalled your package with the latest function.php. I did the installation again but the table 'user' is empty and the table 'config' is filled. So i assume no access issue.
After adding the user with MySQL Workbench i entered the admin panel and checked sync with xbmc database and entered my access data to the xbmc database i noticed after pressing 'save'
the database name for xbmc is still 'xbmc_video75' but in the 'config' table the name is correct. Maybe an display issue?

I clicked on 'check connection' and i get Connected. Found movies: 840

After that i clicked on 'sync now' and went to index.php. I get an error 'Notice: Undefined variable: conn_ml in C:\xampp\htdocs\movielib\function.php on line 399'

To debug i insert the line 'echo $insert_sql;' and i can see all insert statements. They are filled with my XBMC movies. So i assume the XBMC database is readable.
But the var conn_ml is void so no insert into the movielib database. But why?
Reply
#20
(2013-07-05, 23:46)_Andy_ Wrote: I reinstalled your package with the latest function.php. I did the installation again but the table 'user' is empty and the table 'config' is filled. So i assume no access issue.

Before reinstall You must manually delete table in movielib database.

(2013-07-05, 23:46)_Andy_ Wrote: After adding the user with MySQL Workbench i entered the admin panel and checked sync with xbmc database and entered my access data to the xbmc database i noticed after pressing 'save'
the database name for xbmc is still 'xbmc_video75' but in the 'config' table the name is correct. Maybe an display issue?

Yes, it is display issue. Thanks, I fix it.

(2013-07-05, 23:46)_Andy_ Wrote: I clicked on 'check connection' and i get Connected. Found movies: 840

After that i clicked on 'sync now' and went to index.php. I get an error 'Notice: Undefined variable: conn_ml in C:\xampp\htdocs\movielib\function.php on line 399'

To debug i insert the line 'echo $insert_sql;' and i can see all insert statements. They are filled with my XBMC movies. So i assume the XBMC database is readable.
But the var conn_ml is void so no insert into the movielib database. But why?

Hmm... Try copy one or all this insert query to phpmyadmin and run it. Example:

Code:
INSERT INTO `movies` ( `title`, `plot`, `rating`, `year`, `poster`, `fanart`, `runtime`, `genre`, `director`, `originaltitle`, `country`, `v_codec`, `v_aspect`, `v_width`, `v_height`, `v_duration`, `a_codec`, `a_channels`, `play_count`, `last_played`, `date_added` ) VALUES ( "Skyfall", "When Bond\'s latest assignment goes gravely wrong and agents around the world are exposed, MI6 is attacked forcing M to relocate the agency. These events cause her authority and position to be challenged by Gareth Mallory (Ralph Fiennes), the new Chairman of the Intelligence and Security Committee. With MI6 now compromised from both inside and out, M is left with one ally she can trust: Bond. 007 takes to the shadows - aided only by field agent, Eve (Naomie Harris) - following a trail to the mysterious Silva (Javier Bardem), whose lethal and hidden motives have yet to reveal themselves.", "6.400000", "2012", "http://cf2.imgobject.com/t/p/original/hunPAt4uxeFXhoNtEVe9xxhRozS.jpg", "http://cf2.imgobject.com/t/p/original/AunH2MIKIbnU9khgFp45eJlydPu.jpg", 143, "Action / Adventure / Thriller", "Sam Mendes", "Skyfall", "United Kingdom", NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, NULL, "2013-06-27 21:31:22" )

Download package again I fix some bugs.

(2013-07-05, 16:10)Aenima99x Wrote:
(2013-07-05, 12:28)Regss Wrote: I forgot about the local files. I'll try to add support for it as soon as I get back from vacation.

Great thanks!

I added support for local files, can You see if it works?
Reply
#21
(2013-07-06, 08:54)Regss Wrote: I added support for local files, can You see if it works?

Did a complete fresh pull from git and it still doesn't seem to be pulling in local files. I have one movie in XBMC that I set to use a url and that's the only poster it added to the cache.

Url info in XBMC db, movie table c08
Code:
<thumb aspect="poster" preview="http://cf2.imgobject.com/t/p/w500/ehCzedovkiM8CnDeuSSHlRbdfxI.jpg">http://cf2.imgobject.com/t/p/original/ehCzedovkiM8CnDeuSSHlRbdfxI.jpg</thumb>

Local info in XBMC db, movie table c08
Code:
<thumb>/home/xbmc/Media/Movies/Zombies! Zombies! Zombies! (2008)/poster.jpg</thumb>
Reply
#22
What is in movielib db for this movie in "poster" field?
Reply
#23
(2013-07-06, 16:56)Regss Wrote: What is in movielib db for this movie in "poster" field?

Code:
http://cf2.imgobject.com/t/p/original/ehCzedovkiM8CnDeuSSHlRbdfxI.jpg
Reply
#24
For movies have a local poster.
Reply
#25
Hello Regss

I guess i found the error. You defined the field 'file' in table 'movies' not null but in your insert statement you don't have a field 'file'. I redefined the field to null and the sync is now working.
Maybe you can verify that.

I would like to have 2 columns of movies. Most of the screens are big in my case all my screens are 1920x1080. Only one column is a waste of space :-)
So maybe you can add an option for 2 columns or even better make it dependable from the screen resolution. If is space for 2 columns use 2 if not use 1 column.
Maybe you can add my wish. I would like it.
Reply
#26
(2013-07-06, 17:42)Regss Wrote: For movies have a local poster.

I do have all local posters. None are getting added to the movielib db, ONLY the one like above got added.
Reply
#27
(2013-07-06, 18:42)_Andy_ Wrote: Hello Regss

I guess i found the error. You defined the field 'file' in table 'movies' not null but in your insert statement you don't have a field 'file'. I redefined the field to null and the sync is now working.
Maybe you can verify that.
Yes, you're right. I fix it.

(2013-07-06, 18:42)_Andy_ Wrote: I would like to have 2 columns of movies. Most of the screens are big in my case all my screens are 1920x1080. Only one column is a waste of space :-)
So maybe you can add an option for 2 columns or even better make it dependable from the screen resolution. If is space for 2 columns use 2 if not use 1 column.
Maybe you can add my wish. I would like it.
I think about it.


(2013-07-06, 20:37)Aenima99x Wrote:
(2013-07-06, 17:42)Regss Wrote: For movies have a local poster.

I do have all local posters. None are getting added to the movielib db, ONLY the one like above got added.
What is stored in the movielib db for movies with local poster after update script.
Reply
#28
(2013-07-06, 22:18)Regss Wrote: What is stored in the movielib db for movies with local poster after update script.

That's the problem, nothing is getting written to the movielib db for posters or fanart. The only one that got written was the one that contained a url, not a local file path.

Also - just manually added the local poster path into the movielib db and that does get the poster to show. So it definitely is something with the poster/fanart data not being written to the movielib db. Is there anything I can check for you?
Reply
#29
(2013-07-07, 02:05)Aenima99x Wrote:
(2013-07-06, 22:18)Regss Wrote: What is stored in the movielib db for movies with local poster after update script.

That's the problem, nothing is getting written to the movielib db for posters or fanart. The only one that got written was the one that contained a url, not a local file path.

Also - just manually added the local poster path into the movielib db and that does get the poster to show. So it definitely is something with the poster/fanart data not being written to the movielib db. Is there anything I can check for you?

Now it should work fine. Download and replace function.php
Reply
#30
(2013-07-07, 11:22)Regss Wrote: Now it should work fine. Download and replace function.php

Sad Did a git pull and it's still not working.

Movielib DB
Image

XBMC - MyVideos75 DB
Image
Reply
  •  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 44
  • Next 



MovieLib - Your movie database on web4.638