•   
  • 1
  • 33
  • 34
  • 35(current)
  • 36
  • 37
  • 45
  •   
MovieLib - Your movie database on web
Try this for next line in sync.py

Code:
dataXBMC['images']['episodes']      = collections.OrderedDict( [('poster', {} )] )
to
Code:
dataXBMC['images']['episodes']      = collections.OrderedDict( [('poster', {} ), ('exthumb', {} )] )
Reply
ok , no more error , the new movies have been added as well , however the posters of the New movies are not showing in the webinterface of movielib

and no error


EDIT : now all the thumbs are gone , titles etc.. are there, but no more posters.
Reply
btw , mod_rewrite and curl show OFF in the settings.

Do they need to be ON ?


if yes, what do i need to do to enable it ?
Reply
(2015-10-10, 19:16)Regss Wrote: Several people had problems with the server on the NAS. Most often this was problem with file permissions (CHMOD) on server. Test on a local server, for example. WAMP. If the files temt_p are correct and contain image probably just the problem with the server.

Hm...I don't have the Apache-Server für MovieLib on my NAS (On the NAS runs the MySQL Database for my Kodi-Clients). The Server for MovieLib runs on my RapsberryPi and the Folders cache and cache/actors are set to CHMOD 777. But they are still empty.

The temp_p and temp_f files containing images. So I think everything is correct here.

Does the Addon need some Accesdata for the Server like Username and Password? When I connect to the Pi via FTP I need to log in.Huh
Additionaly I had to create the db.php by myself. I think the Addon isn't allowed to connect to the Pi or write Files at all. However...how can I change this?

Thank you in advance Wink
Reply
(2015-10-10, 20:29)DrPepper Wrote: btw , mod_rewrite and curl show OFF in the settings.

Do they need to be ON ?


if yes, what do i need to do to enable it ?
No, this options do not affect the coping images.

Turn on debuging in movielib addon settings. Start movielib manually from program sections this force to check all data and past kodi log using pastebin.com if images not shown.



(2015-10-11, 17:48)HeNiNnG Wrote:
(2015-10-10, 19:16)Regss Wrote: Several people had problems with the server on the NAS. Most often this was problem with file permissions (CHMOD) on server. Test on a local server, for example. WAMP. If the files temt_p are correct and contain image probably just the problem with the server.

Hm...I don't have the Apache-Server für MovieLib on my NAS (On the NAS runs the MySQL Database for my Kodi-Clients). The Server for MovieLib runs on my RapsberryPi and the Folders cache and cache/actors are set to CHMOD 777. But they are still empty.

The temp_p and temp_f files containing images. So I think everything is correct here.

Does the Addon need some Accesdata for the Server like Username and Password? When I connect to the Pi via FTP I need to log in.Huh
Additionaly I had to create the db.php by myself. I think the Addon isn't allowed to connect to the Pi or write Files at all. However...how can I change this?

Thank you in advance Wink



Addon does not need login to FTP. If movielib have problem with creating db.php during installation. This mean is the problem with the server. It would also explain that the script can not save images. Please test it on real PC. I have no experience with raspberry
Reply
@Regss After updating everything is working. The banner too...

But I have a special question. Can you pls tell me in which directory the black backgrounf of the banner is placed, because I want to mod it and want to replace with the logo of my homecinema, so that everyone cqn see fanart on the left and in the background of title etc, the logo of my cinema...
Reply
It is not a image. It is css style.
Reply
would be great if there would be a possibility...
Reply
Since the addon updated 1.4.1 and I updated the site to 2.8.0 my MovieLib DB is not updating and an error pops up saying error with script.

I believe the below is the necessary detail from the kodi.log file, how do I fix this?

17:28:21 T:1693447232 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.KeyError'>
Error Contents: ('fanart',)
Traceback (most recent call last):
File "/storage/.kodi/addons/script.movielib/default.py", line 30, in <module>
Movielib()
File "/storage/.kodi/addons/script.movielib/default.py", line 22, in __init__
sync.start(self)
File "/storage/.kodi/addons/script.movielib/lib/sync.py", line 71, in start
check(self)
File "/storage/.kodi/addons/script.movielib/lib/sync.py", line 150, in check
dataXBMC = getDataFromXBMC(self)
File "/storage/.kodi/addons/script.movielib/lib/sync.py", line 230, in getDataFromXBMC
dataXBMC['images'][table]['fanart'][data[table[0:-1]+'id']] = data['art']['fanart']
KeyError: ('fanart',)
-->End of Python script error report<--
Image
Reply
Download this file and replace sync.py in addon/script.movielib/lib/ folder.

http://www.filedropper.com/sync
Reply
Ok, it's syncing now but when I look at my site, all of the artwork for everything has vanished!
Image
Reply
i've just updated movielib,
it syncs but my cache dir was erased...empty, so i don't have poster, fanart ecc.... http://movielib.altervista.org/
how can i repopulate the cache dir?
Reply
ensignvorik, gulp try sync manually starting movielib from program section this force to check all images again. If images not shown check kodi.log for errors.
Reply
thank you, i'll try
Reply
Hello,
I want to protect my movielib with .htaccess - so I will have a two-factor-auth.

Code:
# Auth protect my_movielib
  AuthName "movielib"
  AuthType Basic
  AuthUserFile /var/www/html/movielib/.htpasswd
  Require valid-user
# ------------------------------

But when I added this code to .htaccess the movielib-addon can not connect to synch.php. The Log tell me:
Quote:20:22:58 T:4596 NOTICE: >>>> Movielib <<<< Can't connect to: http://movielib.myWebside.de/sync.php?to...cksettings
20:22:58 T:4596 NOTICE: >>>> Movielib <<<< [REQUEST ERROR]: HTTP Error 401: Authorization Required
20:22:58 T:4596 NOTICE: >>>> Movielib <<<< [REQUEST]: Wait 5 secs and retring 1
20:23:06 T:4508 NOTICE: [service.sleepy.watchdog] user activity detected, reset idle time
20:23:11 T:6692 ERROR: CPythonInvoker(7, C:\Users\nepomuk\AppData\Roaming\Kodi\addons\script.movielib\default.py): script didn't stop in 5 seconds - let's kill it
Is there a way, maybe to insert in the addon the authUser and authPassword? Or is there a other way?

@Regss
At 20:22:58 your addon want to wait 5sec and then retry. How much is the retry-counter? Attention no second retry after 5 secs.
At 20:23:11 Kodi kill the script movielib. Kodi kills it after 13secs.
Reply
  •   
  • 1
  • 33
  • 34
  • 35(current)
  • 36
  • 37
  • 45
  •   
 
Thread Rating:
  • 8 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
MovieLib - Your movie database on web4.638
This forum uses Lukasz Tkacz MyBB addons.