•   
  • 1
  • 20
  • 21
  • 22(current)
  • 23
  • 24
  • 45
  •   
MovieLib - Your movie database on web
From my website you can control XBMC. Only simple control avaliable like play, stop movie or change volume, but first you must install it and sync all data from XBMC to website.
Reply
Okay but then I need to have xbmc (so my HTPC) turned on to make it work right? And i don't want to control xbmc. I only need a viewer to navigate in the movies and TVshows who would read the databases (poster, fanart and some informations like title, cast, plot, mpaa...) and display them like your addon with some stuff like search tool.

What I want is to be able to have a pleasant web page to visit and allow my family to find out about my latest acquisitions with all the necessary information. So no modification possible.

I already have the audio and video databases on the synology (visible from phpmyadmin).
Reply
The main purpose of this project is to show your collection on a web page. Control XBMC is only a small addition of accessible only after logging in as an administrator. The script is created on a separate database. There is no interference at the base of XBMC
Reply
ok so that's what i want.

I tested the script on my synology:
- I copied the "movielib-master" folder in the "web" folder on my syno.
Now when I type "http: //url.de-mon.syno/movielib-master" I am redirected to the install.php page (same if I run admin.php). I chose the language, I agree, I give the mysql adresse and password and I got an error : "Can't create db.php file, root directory CHMOD is 555"

Must first go through a xbmc to generate the data?

Edit
i created db.php manually in "movielib-master" but now i have this error :
"File db.php exist, but can't write into it, file CHMOD is 755"
Reply
You must change chmod to 666 or create db.php file manually and put this code:

Code:
<?PHP $mysql_ml = array('host', 'port', 'login', 'password', 'database'); ?>
Reply
If you create file manually, go to admin.php, not install.php
Reply
ok I'm on the admin page. It does not seem to see my movies and series (everything is zero). I deleted install.php and change passwords as suggested in the top inset. I can enter the user interface but it's empty (no media).

I installed on my htpc the addon movielib but after entering the url (I put "http://192.168.1.XXX/medialib-master/") and the token previously generated on mediaLib, nothing happens.
Reply
Now you must run addon from program section or update some movie or restart XBMC.
Reply
Hello,

i just updated to the lates version 2.7.0. The XBMC Addon was updated to Version 1.3.0.
Now i get an error message each time i start XBMC. I turned on debugging and it looks to me like there is an error in the addon:

Code:
name":"Michael Rooker","order":7,"role":"Merle Dixon"},{"name":"Emily Kinney","order":8,"role":"Beth Greene"},{"name":"Scott Wilson","order":9,"role":"Hershel Greene"},{"name":"IronE Singleton","order":10,"role":"T-Dog"},{"name":"Lauren Cohan","order":11,"role":"Maggie Greene"},{"name":"Danai Gurira","order":12,"role":"Michonne"},{"name":"Steven Yeun","order":13,"role":"Glenn"},{"name":"Emma Bell","order":14,"role":"Amy"},{"name":"Laurie Holden","order":15,"role":"Andrea"},{"name":"Jeffrey DeMunn","order":16,"role":"Dale"},{"name":"Jon Bernthal","order":17,"role":"Shane Walsh"},{"name":"Sarah Wayne Callies","order":18,"role":"Lori Grimes"}],"genre":["Drama","Horror","Suspense"],"label":"The Walking Dead","tvshowid":39},{"cast":[{"name":"Travis Fimmel","order":0,"role":"Ragnar Lothbrok"},{"name":"Katheryn Winnick","order":1,"role":"Lagertha"},{"name":"Clive Standen","order":2,"role":"Rollo"},{"name":"Gustaf Skarsgard","order":3,"role":"Floki"},{"name":"George Blagden","order":4,"role":"Athelstan"},{"name":"Jessalyn Gilsig","order":5,"role":"Siggy"},{"name":"Gabriel Byrne","order":6,"role":"Earl Haraldson"}],"genre":["Action","Adventure","Drama","Mini-Series"],"label":"Vikings","tvshowid":41},{"cast":[],"genre":["Documentary"],"label":"Wildes Deutschland","tvshowid":42},{"cast":[{"name":"Christian Cooke ","order":0,"role":"Frederick Beauchamp "},{"name":"Julia Ormond","order":1,"role":"Joanna Beauchamp"},{"name":"Jenna Dewan-Tatum","order":2,"role":"Freya Beauchamp"},{"name":"Rachel Boston","order":3,"role":"Ingrid Beauchamp"},{"name":"Mädchen Amick","order":4,"role":"Wendy"},{"name":"Eric Winter","order":5,"role":"Dash Gardiner"},{"name":"Daniel DiTomasso","order":6,"role":"Killian Gardiner"},{"name":"Bianca Lawson","order":7,"role":"Eva"},{"name":"Enver Gjokaj ","order":8,"role":"Mike"},{"name":"Joel Gretsch","order":9,"role":"Victor"},{"name":"Shaun Smyth","order":10,"role":"Dr. Frank Foster"},{"name":"Tom Lenk","order":11,"role":"Hudson Rafferty"},{"name":"Virginia Madsen","order":12,"role":"Penelope Gardiner"}],"genre":["Drama","Fantasy","Suspense"],"label":"Witches of East End","tvshowid":57}]}}
15:57:32 T:11664   DEBUG: ------ Window Init (DialogExtendedProgressBar.xml) ------
15:57:33 T:17212   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.UnicodeDecodeError'>
                                            Error Contents: 'ascii' codec can't decode byte 0xc3 in position 8: ordinal not in range(128)
                                            Traceback (most recent call last):
                                              File "C:\Users\Stefan\AppData\Roaming\XBMC\addons\script.movielib\default.py", line 29, in <module>
                                                Movielib()
                                              File "C:\Users\Stefan\AppData\Roaming\XBMC\addons\script.movielib\default.py", line 21, in __init__
                                                sync.start(self)
                                              File "C:\Users\Stefan\AppData\Roaming\XBMC\addons\script.movielib\lib\sync.py", line 51, in start
                                                check(self)
                                              File "C:\Users\Stefan\AppData\Roaming\XBMC\addons\script.movielib\lib\sync.py", line 132, in check
                                                if syncVideo.sync(self, v) is False:
                                              File "C:\Users\Stefan\AppData\Roaming\XBMC\addons\script.movielib\lib\syncVideo.py", line 44, in sync
                                                if syncPanel.sync(self) is False:
                                              File "C:\Users\Stefan\AppData\Roaming\XBMC\addons\script.movielib\lib\syncPanel.py", line 137, in sync
                                                debug.notify(__lang__(32104).encode('utf-8') + ' ' + str(addedCount) + ' ' + self.panelsLang[panel])
                                            UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 8: ordinal not in range(128)
                                            -->End of Python script error report<--
15:57:33 T:17212    INFO: Python script stopped
15:57:33 T:17212   DEBUG: Thread LanguageInvoker 17212 terminating
15:57:33 T:11664   DEBUG: ------ Window Init (DialogKaiToast.xml) ------
15:57:33 T:11664   DEBUG: ------ Window Deinit (DialogExtendedProgressBar.xml) ------
15:57:38 T:11664   DEBUG: ------ Window Deinit (DialogKaiToast.xml) ------
15:57:38 T:11664   DEBUG: CWinEventsWin32::WndProc: window move event
15:57:44 T:11664   DEBUG: Previous line repeats 39 times.
15:57:44 T:11664   DEBUG: CWinEventsWin32::WndProcWindow is active
15:57:50 T:11664   DEBUG: ------ Window Deinit (Pointer.xml) ------
15:57:54 T:11664   DEBUG: SECTION:UnloadDelayed(DLL: spec

Any idea what the reason for this could be?

Best regards
  • ZOTAC IONITX-D-E Intel Atom N330 Dual Core 1.6 GHz NVIDIA ION
  • XBMC Live (Lucid) with Dharma Final on HDD
  • Harmony One,MS-Tech MS-1200 Case,Atric IR-Controller, WHS as Mediaserver
Reply
i get an error after reboot : "script error : movielib"

here a copy of my xbmc.log : http://pastebin.com/UCFpY81m
Reply
The same problem in both. Small bug in code. I fixed it. Update yours addon to v.1.3.1
Reply
Thank You for the quick fix, but where can i find the updated addon? The link in the first thread points to an older version.
Or do i just have to wait until the addon updates itself in XBMC?

Best regards,

Stefan
  • ZOTAC IONITX-D-E Intel Atom N330 Dual Core 1.6 GHz NVIDIA ION
  • XBMC Live (Lucid) with Dharma Final on HDD
  • Harmony One,MS-Tech MS-1200 Case,Atric IR-Controller, WHS as Mediaserver
Reply
In XBMC on my repository open context menu and choose check update.
Reply
I managed, after reboot, to bring up the list of movies and series. Unfortunately, there is no poster or fanart that appears ...

Looking into the administration page, I spotted that there was nothing in the cache and I do not have a cache folder to the root of the site.
Reply
You have problem with CHMOD for folders therefore script can't create db.php and now can't create cache folder and write to it poster and fanart files. You must read how change CHMOD for folders on your NAS.
Reply
  •   
  • 1
  • 20
  • 21
  • 22(current)
  • 23
  • 24
  • 45
  •   
 
Thread Rating:
  • 8 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
MovieLib - Your movie database on web4.638
This forum uses Lukasz Tkacz MyBB addons.