[Release] Keymap Editor (configure remote in GUI)

  Thread Rating:
  • 6 Vote(s) - 4.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
infinity85 Offline
Senior Member
Posts: 183
Joined: Jul 2015
Reputation: 10
Post: #376
(2017-09-12 00:24)gillmacca Wrote:  Need some advice.
In kodi 17.3, I patched 'menu', and swapped menu (m) with context menu ©, so the 'm' opens the context menu and 'c' opens the menu. Everything worked fine.
I have now upgraded to kodi 17.4 (also tried with a fresh install).
When I first start kodi, c will not open the menu (it is reset to opening the context menu and 'm' also opens the context menu), until I press save in the editor. It all works fine then, for a certain length of time (don't know how long), before it resets itself and I have to click save again for it to work.

Anyone come across this issue, or now how to resolve it?

Many thanks for any help
Sounds as if some other addon overwrites the custom keymap (gen.xml) every now and then. Not sure in which directory it is on your system, but you should have a look at the directory where the keymap editor "gen.xml" is saved. I assume that something renames the file. I know that e.g. "VPN manager addon for OpenVPN" and some other addons have a routine to make their own keymap.xml for making custom buttonmappings available. Some of them may overwrite it in your case.
find quote
Post Reply