•   
  • 1
  • 26
  • 27
  • 28(current)
  • 29
  • 30
  • 694
  •   
  Thread Closed
[OLD/CLOSED] PseudoTV Live - Set-Top box solution
(2013-08-13, 07:07)nerdmastax Wrote: you mentioned bct's being mixed into auto tuned channels, but what about those of us with an offline bumps and commercials folder? is there any current support or planned support, right now intergrating bumpers is a pain, i have 5 "genre" channels that best effort schedule from 10pm to 6 am so my adult swim has randomish blocks of programming, right now i have to interleave a bump channel through all 5 genre channels. then edit each best effort rule on the cartoon network channel to account for the number of bumps i interleave.
Sorry it will only be available for newly generated channels, but I forget to mention that autotuning will also check for playlists (.xsp) files before going to selected channel types... So if you're using a channel now based of a smart playlist... then it should be the same...

BCT's will include local or online sources...

(2013-08-13, 07:07)nerdmastax Wrote: also a suggestion on error handling, create a permanent off air (color bars or snow) channel, and whenever an error occurs it goes to that channel instead of stopping the script, [dunno how exactly that would work, perhaps modify all "live" playlists to have the snow channel lined up after the live channel in the playlist for that channel]

That is one of the ideas I've been toying with...
Image Lunatixz - Kodi / Beta repository
Image PseudoTV - Forum | Website | Youtube | Twitter | Help?
i dunno jack about smart playlists, in relation to ptv or in general. i have to use 5 "genre" based channels to keep my adult swim block sane, i have a genre named "10" "11" "12" "130" and "330". so my "10" genre for example has futurama, king of the hill, and bobs burgers, and my "12" genre has robot chicken, squidbillies etc. perhaps there is a better way with smart playlists, (if someone could give a good pointer or reference on it, it would be appreciated.)

as a side question, looking through and trying the settings2 provided for live streams i cant get any of it working reliably except for hsn, is there a cspan or news or weather channel? i want a legit stable weather and news channel.

i know nasa, al jezeera, and cspan have free live streaming legit? any way of getting one of those 3 workin?
(2013-08-13, 17:50)nerdmastax Wrote: i dunno jack about smart playlists, in relation to ptv or in general. i have to use 5 "genre" based channels to keep my adult swim block sane, i have a genre named "10" "11" "12" "130" and "330". so my "10" genre for example has futurama, king of the hill, and bobs burgers, and my "12" genre has robot chicken, squidbillies etc. perhaps there is a better way with smart playlists, (if someone could give a good pointer or reference on it, it would be appreciated.)

as a side question, looking through and trying the settings2 provided for live streams i cant get any of it working reliably except for hsn, is there a cspan or news or weather channel? i want a legit stable weather and news channel.

i know nasa, al jezeera, and cspan have free live streaming legit? any way of getting one of those 3 workin?

http://wiki.xbmc.org/index.php?title=Smart_playlists
(2013-08-13, 17:56)bry- Wrote: http://wiki.xbmc.org/index.php?title=Smart_playlists


this is what it says in the wiki:
Quote:Smart playlists.
There is currently no text in this page. You can search for this page title in other pages, or search the related logs, but you do not have permission to create this page.

edit: now its working.... and thank you very much, this will be helpful in creating my rerun channel.
hi guys

I have a problem with one my streams.

my rtmp link has a '?' on it, and when I pass this to settings2.xml, the pseudoTv only pass the adress until the dot.

Example:

my stream is:

rtmp://173.193.20.136/mtv/?jacob#MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0#james playpath=palomahd swfUrl=http://75.126.217.6/site/flash/player_aovivo.swf?v=1.3 pageUrl=http://75.126.217.6/videoteca/play app=mtv/?jacob#MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0#james live=true


I checked with WireShark and the tcurl from RTMP body was only "rtmp://173.193.20.136/mtv"

whats wrong?

please help me
(2013-08-13, 18:05)naldorp Wrote: hi guys

I have a problem with one my streams.

my rtmp link has a '?' on it, and when I pass this to settings2.xml, the pseudoTv only pass the adress until the dot.

Example:

my stream is:

rtmp://173.193.20.136/mtv/?jacob#MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0#james playpath=palomahd swfUrl=http://75.126.217.6/site/flash/player_aovivo.swf?v=1.3 pageUrl=http://75.126.217.6/videoteca/play app=mtv/?jacob#MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0#james live=true


I checked with WireShark and the tcurl from RTMP body was only "rtmp://173.193.20.136/mtv"

whats wrong?

please help me

I don't believe the problem is the "?" but the hash tag next to it, try replacing the # with %23, /?jacob%23M
Image Lunatixz - Kodi / Beta repository
Image PseudoTV - Forum | Website | Youtube | Twitter | Help?
(2013-08-13, 18:14)Lunatixz Wrote:
(2013-08-13, 18:05)naldorp Wrote: hi guys

I have a problem with one my streams.

my rtmp link has a '?' on it, and when I pass this to settings2.xml, the pseudoTv only pass the adress until the dot.

Example:

my stream is:

rtmp://173.193.20.136/mtv/?jacob#MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0#james playpath=palomahd swfUrl=http://75.126.217.6/site/flash/player_aovivo.swf?v=1.3 pageUrl=http://75.126.217.6/videoteca/play app=mtv/?jacob#MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0#james live=true


I checked with WireShark and the tcurl from RTMP body was only "rtmp://173.193.20.136/mtv"

whats wrong?

please help me

I don't believe the problem is the "?" but the hash tag next to it, try replacing the # with %23, /?jacob%23M


I passed:

rtmp://173.193.20.136/mtv/?jacob%23MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0%23james playpath=palomahd swfUrl=http://75.126.217.6/site/flash/player_aovivo.swf?v=1.3 pageUrl=http://75.126.217.6/videoteca/play app=mtv//?jacob%23MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0%23james live=1

the problem still the same.

The "swfUrl" and app has the same problem.

Can I just pass the strm file with all information of rtmp?
(2013-08-13, 18:38)naldorp Wrote:
(2013-08-13, 18:14)Lunatixz Wrote:
(2013-08-13, 18:05)naldorp Wrote: hi guys

I have a problem with one my streams.

my rtmp link has a '?' on it, and when I pass this to settings2.xml, the pseudoTv only pass the adress until the dot.

Example:

my stream is:

rtmp://173.193.20.136/mtv/?jacob#MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0#james playpath=palomahd swfUrl=http://75.126.217.6/site/flash/player_aovivo.swf?v=1.3 pageUrl=http://75.126.217.6/videoteca/play app=mtv/?jacob#MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0#james live=true


I checked with WireShark and the tcurl from RTMP body was only "rtmp://173.193.20.136/mtv"

whats wrong?

please help me

I don't believe the problem is the "?" but the hash tag next to it, try replacing the # with %23, /?jacob%23M


I passed:

rtmp://173.193.20.136/mtv/?jacob%23MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0%23james playpath=palomahd swfUrl=http://75.126.217.6/site/flash/player_aovivo.swf?v=1.3 pageUrl=http://75.126.217.6/videoteca/play app=mtv//?jacob%23MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0%23james live=1

the problem still the same.

The "swfUrl" and app has the same problem.

Can I just pass the strm file with all information of rtmp?

You lost me... what are you trying to do?

Where did you get this rtmp? does it work outside of xbmc? or outside of PTVL?

take a look at scilz settings2.xml to get ideas of rtmp structures... URL encoding, spaces are allowed...
Image Lunatixz - Kodi / Beta repository
Image PseudoTV - Forum | Website | Youtube | Twitter | Help?
(2013-08-13, 18:43)Lunatixz Wrote:
(2013-08-13, 18:38)naldorp Wrote:
(2013-08-13, 18:14)Lunatixz Wrote: I don't believe the problem is the "?" but the hash tag next to it, try replacing the # with %23, /?jacob%23M


I passed:

rtmp://173.193.20.136/mtv/?jacob%23MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0%23james playpath=palomahd swfUrl=http://75.126.217.6/site/flash/player_aovivo.swf?v=1.3 pageUrl=http://75.126.217.6/videoteca/play app=mtv//?jacob%23MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0%23james live=1

the problem still the same.

The "swfUrl" and app has the same problem.

Can I just pass the strm file with all information of rtmp?

You lost me... what are you trying to do?

Where did you get this rtmp? does it work outside of xbmc? or outside of PTVL?

take a look at scilz settings2.xml to get ideas of rtmp structures... URL encoding, spaces are allowed...

Ok,

I got this rtmp from a site and put it inside a strm file. I can play that strm file with xbmc. What I'm trying to do is add this rtmp to my pseudoTV Live.

I copied all rtmp link and put inside advancedsettings2.xml

Look:
Code:
<setting id="Channel_900_type" value="9" />
    <setting id="Channel_900_1" value="5400" />
    <setting id="Channel_900_2" value="rtmp://173.193.20.136/mtv/?jacob%23MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0%23james playpath=palomahd swfUrl=http://75.126.217.6/site/flash/player_aovivo.swf?v=1.3 pageUrl=http://75.126.217.6/videoteca/play app=mtv//?jacob%23MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0%23james live=1" />
    <setting id="Channel_900_3" value="SporTV HD" />
    <setting id="Channel_900_4" value="Watch SporTV" />
    <setting id="Channel_900_rulecount" value="1" />
    <setting id="Channel_900_changed" value="False" />
    <setting id="Channel_900_time" value="0" />
    <setting id="Channel_900_rule_1_id" value="1" />
    <setting id="Channel_900_rule_1_opt_1" value="SporTV" />



Here's part of xbmc log:

Code:
13:55:53 T:93644  NOTICE: Thread CDVDPlayer start, auto delete: false
13:55:53 T:93644  NOTICE: Creating InputStream
13:55:54 T:93644   ERROR: rtmp server requested close
13:55:54 T:93644   ERROR: CDVDPlayer::OpenInputStream - error opening [rtmp://173.193.20.136/mtv/?jacob%23MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0%23james playpath=palomahd swfUrl=http://75.126.217.6/site/flash/player_aovivo.swf?v=1.3 pageUrl=http:]
13:55:54 T:93644  NOTICE: CDVDPlayer::OnExit()
13:55:54 T:93644  NOTICE: CDVDPlayer::OnExit() deleting input stream
13:55:54 T:86924   ERROR: Playlist Player: skipping unplayable item: 23, path [rtmp://173.193.20.136/mtv/?jacob%23MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0%23james playpath=palomahd swfUrl=http://75.126.217.6/site/flash/player_aovivo.swf?v=1.3 pageUrl=http:]
13:55:54 T:86924  NOTICE: DVDPlayer: Opening: rtmp://173.193.20.136/mtv/?jacob%23MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0%23james playpath=palomahd swfUrl=http://75.126.217.6/site/flash/player_aovivo.swf?v=1.3 pageUrl=http:
13:55:54 T:86924 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
13:55:54 T:106644  NOTICE: Thread CDVDPlayer start, auto delete: false
13:55:54 T:106644  NOTICE: Creating InputStream
13:55:55 T:106644   ERROR: rtmp server requested close
13:55:55 T:106644   ERROR: CDVDPlayer::OpenInputStream - error opening [rtmp://173.193.20.136/mtv/?jacob%23MDdlYmYxMDEwNWU2LnBuZzwvdXJsTG9nbz48U0FMQUNPTkZJR19ET1dOTE9BRFM%2BMTwvU0%23james playpath=palomahd swfUrl=http://75.126.217.6/site/flash/player_aovivo.swf?v=1.3 pageUrl=http:]
13:55:55 T:106644  NOTICE: CDVDPlayer::OnExit()
13:55:55 T:106644  NOTICE: CDVDPlayer::OnExit() deleting input stream
Okay..


I got it.

The problem is that for some reason the plugin was limiting the size of setting "Channel_900_2".

I just apointed this setting to strm file that was working.

thanks Lunatixz

here:

Code:
<setting id="Version" value="2.1.0" />
    <setting id="Channel_900_type" value="9" />
    <setting id="Channel_900_1" value="5400" />
    <setting id="Channel_900_2" value="C:\test.strm" />
    <setting id="Channel_900_3" value="SporTV HD" />
    <setting id="Channel_900_4" value="Watch SporTV" />
    <setting id="Channel_900_rulecount" value="1" />
    <setting id="Channel_900_changed" value="False" />
    <setting id="Channel_900_time" value="851" />
    <setting id="Channel_900_rule_1_id" value="1" />
    <setting id="Channel_900_rule_1_opt_1" value="SporTV" />
    <setting id="LastResetTime" value="1376413810" />
    <setting id="LastExitTime" value="1376413850" />
(2013-08-13, 19:13)naldorp Wrote: Okay..


I got it.

The problem is that for some reason the plugin was limiting the size of setting "Channel_900_2".

I just apointed this setting to strm file that was working.

thanks Lunatixz

here:

Code:
<setting id="Version" value="2.1.0" />
    <setting id="Channel_900_type" value="9" />
    <setting id="Channel_900_1" value="5400" />
    <setting id="Channel_900_2" value="C:\test.strm" />
    <setting id="Channel_900_3" value="SporTV HD" />
    <setting id="Channel_900_4" value="Watch SporTV" />
    <setting id="Channel_900_rulecount" value="1" />
    <setting id="Channel_900_changed" value="False" />
    <setting id="Channel_900_time" value="851" />
    <setting id="Channel_900_rule_1_id" value="1" />
    <setting id="Channel_900_rule_1_opt_1" value="SporTV" />
    <setting id="LastResetTime" value="1376413810" />
    <setting id="LastExitTime" value="1376413850" />

should work both ways...

Looking for suggestions of how to use the data received from TVDB and TMDB...

Currently going to add some info to enhance LiveTV... but is there anything else??
Image Lunatixz - Kodi / Beta repository
Image PseudoTV - Forum | Website | Youtube | Twitter | Help?
i think he was trying to say there is a limit on charecters (the strm link was to long). i know everytime i have a strm that has a long code it seems to not work for me to. i figured it was a issue with the format but maybe he is right and it can't be that long for some reason.

does anyone want to help with some logo's for internet tv? they will be shared along with my new setings2 and credit will be given.
(2013-08-13, 20:22)scilz Wrote: i think he was trying to say there is a limit on charecters (the strm link was to long). i know everytime i have a strm that has a long code it seems to not work for me to. i figured it was a issue with the format but maybe he is right and it

I need to see a m3u generated with characters truncated....

Because I have it set to a 500 char limit
that has to be enough for title/description/link
Image Lunatixz - Kodi / Beta repository
Image PseudoTV - Forum | Website | Youtube | Twitter | Help?
First off, great addon

I have 3 strm channels that I'd like to assign an xmltv configuration to. I looked in the opening post but it says to manually configure a file, I'm not entirely sure what file that is. Can anyone help?

Thanks.
Is there something specific that needs to be done to get Custom Playlists setup in the Channel Config? When I go to set one up, I can't do anything but arrow down to the "Advanced Channel Rules" button. I never get prompted to select a playlist.
  •   
  • 1
  • 26
  • 27
  • 28(current)
  • 29
  • 30
  • 694
  •   
  Thread Closed
 
Thread Rating:
  • 45 Vote(s) - 4.29 Average



Logout Mark Read Team Forum Stats Members Help
[OLD/CLOSED] PseudoTV Live - Set-Top box solution4.2945
This forum uses Lukasz Tkacz MyBB addons.