•   
  • 1
  • 128
  • 129
  • 130(current)
  • 131
  • 132
  • 694
  •   
  Thread Closed
[OLD/CLOSED] PseudoTV Live - Set-Top box solution
I response to my own question, the reason it DID NOT WORK was because the XML file MUST BE named xmltv.xml.
I thought it would take any XML file in that directory, guess not. Now it's working at last. Thanks!
Lunatixz,

As somebody who comes to the XBMC forums to primarily read the PSTL thread, I wanted to let you know that despite the way certain individuals may act. I for one know how much work you must put into PSTL and it is completely appreciated. Please don't let such negative people get you down because for each and every one of those negative folks there are also folks who do appreciate what you do and understand that all the time you devote to it is purely volunteer and done so just because you wish to make a better XBMC experience. I just wanted to say thank you & tell you to keep up the amazing work because it really is appreciated.

Angel
(2013-12-29, 22:01)MrsAngelD Wrote: Lunatixz,

As somebody who comes to the XBMC forums to primarily read the PSTL thread, I wanted to let you know that despite the way certain individuals may act. I for one know how much work you must put into PSTL and it is completely appreciated. Please don't let such negative people get you down because for each and every one of those negative folks there are also folks who do appreciate what you do and understand that all the time you devote to it is purely volunteer and done so just because you wish to make a better XBMC experience. I just wanted to say thank you & tell you to keep up the amazing work because it really is appreciated.

Angel

Couldn't agree more! Keep up the great work :-)
::Update::
I ran into a problem with the EPG not playing nice with hidden BCT's, So I might have to append them to the playlist as regular media... Till I find a solution for hiding them.
[Image: y8pew5kv] Lunatixz - Kodi / Beta repository
[Image: yavkw5zj] PseudoTV - Forum | Website | Youtube | Twitter | Help?
I moved over to the latest git (as of yesterday, 0.2.4) up from 0.2.3 and have had some better luck, though TV shows still seem to give me problems..it looks like opening the samba file path is failing so it can't get the duration. I trimmed it down to only 2 channels (1 TV (channel 1) and 1 movies (channel 37)) to try and make the debug log a bit easier to sort through:

http://xbmclogs.com/show.php?id=103398
(2013-12-29, 21:39)ThorC1138 Wrote: I was trying to get you tube playlists working today but having no success, [BSOD or bad channel setups], and a search through the thread and the updates on the first few posts would suggest that any major issues there were fixed...could someone share a quick excerpt from their settings2 file of one they have working?

YT channels work fine for me, but I'm struggling with the right syntax and where exactly to replace the 1 with a 2 to indicate a playlist, and where to paste the URL, in the line <setting id="Channel_#_1" value= , or the line <setting id="Channel_#_2" value=

Thanks!!!

Here is my exact examples from my settings2.xml and these are used for my Son to create him Youtube TV Channels so he won't miss Disney Junior and Treehouse to much.

Code:
<setting id="Channel_853_type" value="10" />
    <setting id="Channel_853_1" value="PL9bsPVRSg1sl0kSa99jrim69esS0lQrkF" />
    <setting id="Channel_853_2" value="2" />
    <setting id="Channel_853_3" value="50" />
    <setting id="Channel_853_changed" value="False" />
    <setting id="Channel_853_rulecount" value="1" />
    <setting id="Channel_853_rule_1_id" value="1" />
    <setting id="Channel_853_rule_1_opt_1" value="KidsTV123 Youtube" />

1st line we specify it is Youtube with a value of "10"
2nd line we specify a playlist. You get this from the URL of the playlist you are using. The first page has perfect example of what is needed, but if it doesn't make sense, I will clarify even further, just ask.
3rd line we tell the Pluggin that we are specifying a Playlist from Youtube. Value "2" = Playlist from Youtube.

For the most part leave the rest the same, last line is the channel name you want to call it. So "KidsTV123 Youtube" you would specify a name that means something to you.

Here is my next example that I use.

Code:
<setting id="Channel_854_type" value="10" />
    <setting id="Channel_854_1" value="uxbmalaysia" />
    <setting id="Channel_854_2" value="1" />
    <setting id="Channel_854_3" value="50" />
    <setting id="Channel_854_rulecount" value="1" />
    <setting id="Channel_854_rule_1_id" value="1" />
    <setting id="Channel_854_rule_1_opt_1" value="KiddyTV Youtube" />

Again 1st line we are specifying its Youtube with the value "10"
2nd line we are specifying the Username of the Youtube Channel we are pulling from. You get this again from the URL in Youtube. This is the username of the Youtube user that has created their own Youtube channel, not a playlist as the first example uses.
3rd line we are telling PTVL that we are specifying Youtube username with the value of "1" instead of using a Playlist. Refer to page 1 again for how to get that info.
Last line again is a meaningful name for you channel.

You can copy and past these lines into your settings2.xml and the channels will load. Use it as an example and you should be able to go find your own Youtube channels and change those few lines to load what you want from Youtube.

Hope that helps you and anyone else that needs examples to get it to work. It took me a bit of playing around to get it working as expected, but the first page is a wealth of information if you can just digest everything on there. Luna has done a pretty good job of explaining but sometimes direct examples of working syntax are helpful so you can see change working syntax to what you need to see how it works. I know that helps me learn like that. Luna's default channels of settings2.xml are what I used to learn.

(2013-12-29, 03:06)photo848 Wrote:
(2013-12-29, 02:25)bry- Wrote: Curious - is anybody using the master branch with livetv via hdhomerun? I am considering setting this up to see how it works.

I am using the master branch along with livetv via hdhomerun. I tried configuring it as the example provided on page 1 for livetv
<setting id="Channel_1_type" value="8" />
<setting id="Channel_1_1" value="I60159.labs.zap2it.com" />
<setting id="Channel_1_2" value="hdhomerun://xxxxxxxD-1/tuner1?channel=qam256:399000000&program=2" />
<setting id="Channel_#_3" value="xmltv" />

however doing it this way was causing unbearable buffering so I changed it to this approach:
<setting id="Channel_20_type" value="8" />
<setting id="Channel_20_1" value="I2.1.16689.tmsdatadirect.com" />
<setting id="Channel_20_2" value="http://xxx.xxx.x.x:9981/stream/channelid/3?ticket=7962B48B91CE53B2BAEB7C25B8B56E746191B6F0" /> (xxx's being my ip addr)
<setting id="Channel_20_3" value="xmltv" />
and there is no buffering and runs great. I am using a HDHomerun Dual tuner running on an openelec machine. Unfortunately I can't explain why one approach works and the other didn't but the combination of this plugin along with live tv is amazing.

I assume this is a Samba issue more than anything. I'm using Windows and using the netbios name works perfectly for me with no buffering, but for any type of *nix, I would also move to IP vs netbios name as suggested. I'm a few versions behind as it is quite stable for my needs.

Can I ask how you got the URL with that ticket=xxxxxx? If I run into any problems, I might switch to this, but so far so good on Win7.
Hi all, I find this very confusing to set up. I am using Frodo 12.3 and Pseduo Live 0.2.4 from master. I have set up the configurations. I have my own xmltv file with UK channels and start them via another plugin (NTV). The original addon works fine, but when using via Pseduo, it starts, I hear the audio, but no picture. I also see the current EPG info, this lasts for 2 secconds, then it just stops and exits Pseduo.
HTPC Server - Windows 8.1 + XBMC Helix | Intel QuadCore, 4GB RAM, 4 TB SATA
Intel NUC D54250WYK - Windows 8.1 + XBMC Helix | Logitech Harmony 750
Samsung UE8005 | Bluetooth keyboard & mousepad
(2013-12-30, 13:08)Maniac Wrote: Hi all, I find this very confusing to set up. I am using Frodo 12.3 and Pseduo Live 0.2.4 from master. I have set up the configurations. I have my own xmltv file with UK channels and start them via another plugin (NTV). The original addon works fine, but when using via Pseduo, it starts, I hear the audio, but no picture. I also see the current EPG info, this lasts for 2 secconds, then it just stops and exits Pseduo.

Log?
[Image: y8pew5kv] Lunatixz - Kodi / Beta repository
[Image: yavkw5zj] PseudoTV - Forum | Website | Youtube | Twitter | Help?
Thanks Indy for the clarification...I was putting in the whole URL link and not just the PLxxxxx text..
Could someone build me a youtube playlist of random north america (US) commercials from that last few years? a list of 50 would be great. Please PM me the playlist link...

Need to test commercial code... rather use actual periodicals...
[Image: y8pew5kv] Lunatixz - Kodi / Beta repository
[Image: yavkw5zj] PseudoTV - Forum | Website | Youtube | Twitter | Help?
If you want I could create also a playlist for German commercials (HD). I don't know if you can choose your commercials based on country, just thought I might mention it.
PTV shows the EPG data of tomorrow, not today. I checked my xmltv file and the date is correct there.
I checked my log and this seems to be the fault.

Code:
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: setTimeLabels return
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: thetime 2013-12-30 17:30:00
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: setButtons 1388415600.0, 49, 0
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: chtype = 9
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: setbuttonnowtime 2013-12-30 16:08:18.171000
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: videotime  & reftime  + starttime + channel === 0, 1388416065.0, 1388415600.0, 49
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: setButtons return
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: setButtons 1388415600.0, 50, 1
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: chtype = 9
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: setbuttonnowtime 2013-12-30 16:08:18.172000
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: videotime  & reftime  + starttime + channel === 0, 1388416065.0, 1388415600.0, 50
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: setButtons return
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: setButtons 1388415600.0, 1, 2
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: chtype = 8
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: setbuttonnowtime 2013-12-30 16:08:18.173000
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: setbuttonnowtime2 2013-12-31 04:45:00
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: setButtons return
16:08:18 T:9432   DEBUG: script.pseudotv.live-EPGWindow: setButtons 1388415600.0, 2, 3

I don't know why it says its the 31st under "setbuttonnowtime2", not the 30th, even though "thetime" is correct.
After the two last updates,now working on 0.2.4,i have two problems
1.When i set my native language (greek) to xbmc and use interface with greek the pstv wont autotune pvr channels(black screen) when i change to english works like a charm(even though the epg is in greek characters)
2The major problem is that all my movies are with nfo(ember media manager)but the plot is changed manually with greek characters and the pstv dont display the plot only if i change it to english again.In previous versions e.g 1.9 i had no problem with the greek text!

Thanks in advance and congratulations Lunatixz for the good work
(2013-12-30, 07:14)Indy_star Wrote:
(2013-12-29, 21:39)ThorC1138 Wrote: I was trying to get you tube playlists working today but having no success, [BSOD or bad channel setups], and a search through the thread and the updates on the first few posts would suggest that any major issues there were fixed...could someone share a quick excerpt from their settings2 file of one they have working?

YT channels work fine for me, but I'm struggling with the right syntax and where exactly to replace the 1 with a 2 to indicate a playlist, and where to paste the URL, in the line <setting id="Channel_#_1" value= , or the line <setting id="Channel_#_2" value=

Thanks!!!

Here is my exact examples from my settings2.xml and these are used for my Son to create him Youtube TV Channels so he won't miss Disney Junior and Treehouse to much.

Code:
<setting id="Channel_853_type" value="10" />
    <setting id="Channel_853_1" value="PL9bsPVRSg1sl0kSa99jrim69esS0lQrkF" />
    <setting id="Channel_853_2" value="2" />
    <setting id="Channel_853_3" value="50" />
    <setting id="Channel_853_changed" value="False" />
    <setting id="Channel_853_rulecount" value="1" />
    <setting id="Channel_853_rule_1_id" value="1" />
    <setting id="Channel_853_rule_1_opt_1" value="KidsTV123 Youtube" />

1st line we specify it is Youtube with a value of "10"
2nd line we specify a playlist. You get this from the URL of the playlist you are using. The first page has perfect example of what is needed, but if it doesn't make sense, I will clarify even further, just ask.
3rd line we tell the Pluggin that we are specifying a Playlist from Youtube. Value "2" = Playlist from Youtube.

For the most part leave the rest the same, last line is the channel name you want to call it. So "KidsTV123 Youtube" you would specify a name that means something to you.

Here is my next example that I use.

Code:
<setting id="Channel_854_type" value="10" />
    <setting id="Channel_854_1" value="uxbmalaysia" />
    <setting id="Channel_854_2" value="1" />
    <setting id="Channel_854_3" value="50" />
    <setting id="Channel_854_rulecount" value="1" />
    <setting id="Channel_854_rule_1_id" value="1" />
    <setting id="Channel_854_rule_1_opt_1" value="KiddyTV Youtube" />

Again 1st line we are specifying its Youtube with the value "10"
2nd line we are specifying the Username of the Youtube Channel we are pulling from. You get this again from the URL in Youtube. This is the username of the Youtube user that has created their own Youtube channel, not a playlist as the first example uses.
3rd line we are telling PTVL that we are specifying Youtube username with the value of "1" instead of using a Playlist. Refer to page 1 again for how to get that info.
Last line again is a meaningful name for you channel.

You can copy and past these lines into your settings2.xml and the channels will load. Use it as an example and you should be able to go find your own Youtube channels and change those few lines to load what you want from Youtube.

Hope that helps you and anyone else that needs examples to get it to work. It took me a bit of playing around to get it working as expected, but the first page is a wealth of information if you can just digest everything on there. Luna has done a pretty good job of explaining but sometimes direct examples of working syntax are helpful so you can see change working syntax to what you need to see how it works. I know that helps me learn like that. Luna's default channels of settings2.xml are what I used to learn.

(2013-12-29, 03:06)photo848 Wrote:
(2013-12-29, 02:25)bry- Wrote: Curious - is anybody using the master branch with livetv via hdhomerun? I am considering setting this up to see how it works.

I am using the master branch along with livetv via hdhomerun. I tried configuring it as the example provided on page 1 for livetv
<setting id="Channel_1_type" value="8" />
<setting id="Channel_1_1" value="I60159.labs.zap2it.com" />
<setting id="Channel_1_2" value="hdhomerun://xxxxxxxD-1/tuner1?channel=qam256:399000000&program=2" />
<setting id="Channel_#_3" value="xmltv" />

however doing it this way was causing unbearable buffering so I changed it to this approach:
<setting id="Channel_20_type" value="8" />
<setting id="Channel_20_1" value="I2.1.16689.tmsdatadirect.com" />
<setting id="Channel_20_2" value="http://xxx.xxx.x.x:9981/stream/channelid/3?ticket=7962B48B91CE53B2BAEB7C25B8B56E746191B6F0" /> (xxx's being my ip addr)
<setting id="Channel_20_3" value="xmltv" />
and there is no buffering and runs great. I am using a HDHomerun Dual tuner running on an openelec machine. Unfortunately I can't explain why one approach works and the other didn't but the combination of this plugin along with live tv is amazing.

I assume this is a Samba issue more than anything. I'm using Windows and using the netbios name works perfectly for me with no buffering, but for any type of *nix, I would also move to IP vs netbios name as suggested. I'm a few versions behind as it is quite stable for my needs.

Can I ask how you got the URL with that ticket=xxxxxx? If I run into any problems, I might switch to this, but so far so good on Win7.

I don't think the ticket # matters much as I have the same value for just about all of the channels. I actually stumbled upon it while trying to play a channel within TVHeadend. When I clicked on play it downloaded an audio file while contained the "http:// . . . " value above. When I tried to run this file it loaded VLC and the tv channel played. Unfortunately this was sorta of a hit or miss and I wasn't able to reproduce it for every channel. I was able to determine the channelid for each station and on a hunch I just used the same ticket # and it works. Sorry I don't enough to know what it means or might impact but I am curious about your Samba comment. Do you know of something I could look into or test out? Thx
Here is a little tutorial to those struggling to set up xmltv through Autotune. I found this out through a lot
of trial and error, and by a lot, I mean a lot. :-D
I encourage the use of Notepad++! If you need help, you MUST have debug mode in XBMC enabled AND debug mode in PTV
enabled (under 'MISC' inside PTV)!

In order to view regular TV channels in PseudoTV Live along with the corresonding EPG data,
you need to 1. Set up a TV server 2. Activate the LiveTV plugins in XBMC 3. Use XMLTV to grab the EPG (TV schedule) 4. Integrating your XML file in PTV

1. Set up a TV server:
I use Mediaportal and followed the instructions closely. You can download it here:
http://www.team-mediaportal.com/

2. Activate the LiveTV plugins in XBMC
Enable LiveTV in XBMC and choose the appropriate LiveTV plugin to match your PVR backend.
Since I use Mediaportal, I also chose the Mediaportal plugin.

3. Use XMLTV to grab the EPG (TV schedule)
Download XMLTV here: http://sourceforge.net/projects/xmltv/files/xmltv/

XMLTV is a bit tricky for "normal" people, as it can only be used through the command line.
When you type in "xmltv.exe" you should see a list of possible parameters. The most interesting
ones start with tv_grab... Based on your country, XMLTV will grab the corresponding EPG data
for your channels. I live in Germany, so I chose the "tv_grab_eu_epgdata". Most countries
offer free EPG data, but of course not Germany, so you have to pay EPGDATA (epgdata.com)
to obtain the license key.
Before using XMLTV to grab all your stuff, you need to configure your EPG provider.
Type in "xmltv.exe tv_grab_[insert the appropriate provider] -configure"
XMLTV will now guide you through the configuration for this provider and ask for your timezone,
license key (not always) and which TV stations you actually want to have in your XMLTV file.
After you have completed the setup, you can now start grabbing the data by entering this:
"xmltv.exe tv_grab_[insert the appropriate provider] -output xmltv.xml"
Depending on the amount of channels you want in your XML file, XMLTV will crunch numbers for a while,
so grab a coffee or entertain the wife, but it shouldn't really take longer than 10 minutes.

Once finished, XMLTV will have downloaded your XML file to its XMLTV directory.
Now it's time to set up XBMC/PTV to accept your xmltv.xml file.

4. Integrating your XML file in PTV

Place the xml file you just downloaded in a separate directory. I created an XML directory
within my XBMC installation to have it close by when I set up.
We now need to make sure the channel information in your XMLTV file matches the information in your PVR backend (i. e. Mediaportal).
The beginning of your XML file will contain a list of channels and they'll look like this:

Code:
<channel id="rtl.de">
    <display-name>RTL Television|RTL Austria|RTL HH SH</display-name>
    <display-name>RTL</display-name>
    <display-name>RTL</display-name>
  </channel>

The PTV script will try to match the <display-name> with the channel name in your PVR backend to align your EPG data with your PVR channels,
or simply put: Match each TV channel with its correct EPG data. If this fails, PTV will simply make change your LiveTV channel
into an "Internet TV" channel, which does not have EPG data. Let's try to avoid this, as this would dramatically lower the WAF and
incur her terrible wrath.
Open up your PVR backend (i.e. Mediaportal) and go to your channel overview. Now you need to match the information
in your XMLTV file with your backend and align the two. Your XML file MUST have the exact same <display-name> as
your PVR backend. Look at my example and adjust your XML file accordingly to reflect this requirement.

[Image: mediaportalchannelnam1ozgs.jpg]

Your XML file should now look like this:

Code:
<channel id="rtl.de">
    <display-name>RTL Television</display-name>
    <display-name>RTL</display-name>
    <display-name>RTL</display-name>
  </channel>

Notice the change in line 2? If you have changed this for ALL channels that needed changing, PTV should be a breeze.
[Additional tip: It helps to record a macro of this procedure in Notepad++, so you can automatically repeat
this process with any other XML file you download later!]

Now go inside the configuration of PTV-Live, go to "Live Features" and point it to the directory containing your XMLTV file.
Go to "Autotune" and enable it and enable "Reset configuration". Now also enable "Find PVR backend". Back on the "General" page you enable
"Force channel reset on next start". Hit "OK" and leave the configuration.

Launch PTV. It should now aggregate all channels from your PVR backend and search your XMLTV file for corresponding
EPG data. Once this process has finished and you open up the EPG (hit 'Enter'), you should see a schedule for all
channels. If this is not the case, write down the names of the channels that snafu'd and go back into your XML
file and compare the <display-name> section with your PVR backend's channel name. Remember, the two must match!
You should also delete the /cache folder found here:
Code:
\XBMC\userdata\addon_data\script.pseudotv.live\
Rinse and repeat for as long as it takes to have every channel have an EPG. If you get frustrated, talk to your wife.

Once all your channels have EPG data, you can now go about rearranging the channels and throw out the ones
you actually don't like to watch. There is no GUI to do it yet, but no need to worry, all you need is to open
the following file:
C:\Users\<username>\AppData\Roaming\XBMC\userdata\addon_data\script.pseudotv.live\settings2.xml

This file contains the channel layout.

Code:
<setting id="Channel_1_type" value="8" />
<setting id="Channel_1_time" value="1340" />
<setting id="Channel_1_1" value="rtl.de" />
<setting id="Channel_1_2" value="pvr://channels/tv/All TV channels/0.pvr" />
<setting id="Channel_1_3" value="xmltv" />
<setting id="Channel_1_4" value="" />
<setting id="Channel_1_rulecount" value="1" />
<setting id="Channel_1_rule_1_id" value="1" />
<setting id="Channel_1_rule_1_opt_1" value="RTL Television LiveTV" />
<setting id="Channel_1_changed" value="False" />

If you want to remove the "LiveTV" part of your channel, simply change the name in line 9.
If you to have Channel 1 on channel 10, change lines 1-10 from "Channel_1_[...]" to "Channel_10_[...]"

If you have problems, message me or post here with your log. Remember to enable debug in both XBMC and PTV.

PS:
To all the other German XMLTV scrapers out there. I noticed that when you want XMLTV to include Pro7 Maxx,
it will include the EPG, but not the channel name itself, so you need to add that by hand (or macro).
I would also recommend to replace 'ß' with 'ss' inside your XML file to avoid weird characters in PTV.

Code:
<channel id="prosiebenmaxx.de">
    <display-name>ProSieben MAXX</display-name>
    <display-name>ProSieben MAXX</display-name>
    <display-name>ProSieben MAXX</display-name>
  </channel>
  •   
  • 1
  • 128
  • 129
  • 130(current)
  • 131
  • 132
  • 694
  •   
  Thread Closed
 
Thread Rating:
  • 45 Vote(s) - 4.29 Average



Logout Mark Read Team Forum Stats Members Help
[OLD/CLOSED] PseudoTV Live - Set-Top box solution4.2945
This forum uses Lukasz Tkacz MyBB addons.