Win -  Issues Connecting to XBMC Server via Remote
#1
I'd been using the official XBMC remote over WiFi without issues. However, recently the app stopped connecting and is producing the following error message:

"I/O Exception (java.net.SocketException) failed to connect to /192.168.4.104 (port 8080) after 5000ms: isConnected failed: EHOSTUNREACH (No route to host)"

I can connect to the XBMC server (XBMC version 12.2) on the machine it's running (Windows 8). However, I cannot connect either via the web browser on the phone or on another device on the same WAP.

I've changed the remote settings to the hostname of the server (which does resolve to the IP listed above) and verified the IP address.

I have set port forwards on the router (DD-WRT Build 13575M, on a Linksys WRT160Nv3) for ports 8080 (TCP/UDP) and for 9777 (UDP only) the current server settings. I've checked the windows firewall settings and XBMC is has no restrictions on public or private networks. Furthermore, I've also attempted to connect on the following ports (80,9393,1234), changing Windows firewall settings and router settings.

My home network has the router I'm connecting to set as a wireless bridge from our main access point in the living room. However, this setup has not changed and the remote was previously working with the WAN / bridge configuration.

At this point, I haven't been able to identify any other solutions from reading the forums or general web searches. Any suggestions?
Reply
#2
Welcome to the XBMC forums.

I assume you have enabled/specified all the settings on the System/Settings > Services > "Webserver" and "Remote control" pages?

You can enable debug logging in XBMC and then try to access the web interface from another computer. After it fails to connect, examine the debug log (wiki) on your XBMC system to see if there are any messages that may indicate the nature of the problem.
Reply
#3
The webserver and remote control service settings have been enabled and set consistently across devices (eg. same port login / pass). UPnP is enabled (sharing, announce & control). Zeroconf & airplay are disabled.

I turned on debugging and attempted to connect from my remote. I couldn't see any indication that of a server side event (eg. no recognition of the app attempting to connect). There was this message: "webserver: request received for /jsonrpc?Player.GetActivePlayers", but I don't believe it's related. I examined the log after attempting to connect on the same machine and didn't see any errors. My best guess is that it's a connectivity problem, but having verified that port forwarding and the local firewalls are not the issue, I'm not sure what else could be the culprit.

Sorry, forgot my manners. Thank you for the welcome to the forums.
Reply
#4
If you wish, you can upload a copy of your debug log to a public paste site such as http://www.xbmclogs.com and post the assigned URL here. You should mask any passwords or confidential info in the log before uploading it.
Reply
#5
Here's the log file

http://www.xbmclogs.com/show.php?id=50099
Reply
#6
Try setting port in network settings to "80" and the same on your phone mate.
Reply
#7
Thanks, but I've already tried ports 80, 9393 & 1234. I confirmed that the phone was set to match the tested port and tried to connect with and without a router assigned forward.
Reply
#8
As with any network debugging issue, start with ping.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#9
I have the same issue... Did you resolve this?
Reply
#10
As with any network debugging issue, start with ping.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#11
I have two computer one PC in my room the other in living room the one in my room is connected to the router via ethernet and the other in my living room with a network card through wifi ( i have set a static IP for the one in my living room) when i do all the steps to connect the xbmc remote to the one in my room everything is ok but when i created another client in my phone with the IP of the PC in th living room i get this error:
I/O Exception (java.net.SocketException)
failed to connect to /XBMC Device Address (port 8080) after 5000ms: isConnected failed: EHOSTUNREACH (No route to host)

i've tried changing ports -nothing
I'ver tried setting firewall off - nothing
i've tried enabling direct wifi - nothing
the two PCs connect with its other with no problem i even share the library (cause all the movies and tv shows are in a HDD in my Room-PC i dont seem to be able to connect the remote to the xbmc in the next room i also tried the yatse remote but still nothing. Any ideas Huh
Reply
#12
All networking trroubleshooting starts with ping. Can you ping from your phone to the machine you are tring to connect to? Try by name and by IP address.

If you can't get ping to work you have a networking issue which isn't strictly an XBMC issue, but we'll try to help Smile
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#13
I'm from Greece so my English are not in a great lvl can you explain to me what you mean by that? What i must try first and how ?? Thanks very much for the help in advance...
Reply
#14
hello guys
ive just been re-installing my pc and went to xbmc services>webserver settings and there is no option for port, only a toggle to allow control of xbmc via http, and then a web interface choice.
Very odd!
Here is the screen grab... any ideas why it is missing the port/user/password fields? This happens on aeon nox and any other skin I try.

Image
Reply
#15
Running Gotham? If so, change you user expertise level in the slide-out menu on the left to see those "expert" settings.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Issues Connecting to XBMC Server via Remote00