Akamaihd HTTPS m3u8 streams not working
#1
I am trying to playback SVT Play streams (recent ones) using my XBMC Online TV (XOT-Uzg.v3) add-on. The m3u8 chuncks are there (I can see it using Fiddler), but XBMC does not seem to be able to play it. Is it me, or is this an issue?

The add-on can be installed via http://www.rieter.net/content/xot/troubl...g/install/. Then select the SVT Play channel and try to playback any recent "Agenda" stream. Those are akamaihd.net streams using HTTPS that should work from any location (using Firefox they work from the Netherlands).
Reply
#2
our ffmpeg is not compiled with ssl support
Reply
#3
I couldn't get this addon working on a gotham nightly

can you get me a non geo-locked stream url to try this? also see: http://forum.xbmc.org/showthread.php?tid=166897
Reply
#4
Tried XOT-UZG 3.3.6 in todays nightly (XBMCSetup-20130903-4237a6e-master.exe) and it worked.

edit: just tried it again and the same episode from the Agenda SVT channel did not work anymore... this is odd.
Reply
#5
(2013-09-03, 21:16)Kibje Wrote: Tried XOT-UZG 3.3.6 in todays nightly (XBMCSetup-20130903-4237a6e-master.exe) and it worked.

edit: just tried it again and the same episode from the Agenda SVT channel did not work anymore... this is odd.

I just tried, and the 3 more recent Agenda shows don't play.
Reply
#6
I just found out that the one I tried is the only one that works, and the log shows it is not https. Sorry, https does not work yet.

Wsnipex, the addon itself works fine on gotham.
Reply
#7
(2013-09-03, 15:33)wsnipex Wrote: I couldn't get this addon working on a gotham nightly

can you get me a non geo-locked stream url to try this? also see: http://forum.xbmc.org/showthread.php?tid=166897

The URL's have ID's in them that change over time. So the add-on is really the only way. Could you tell me what is not working for you? I can run it on any XBMC (Eden to Gotham) without issues. The streams for the "SVT Play -> Agenda -> Agenda - 1/9 21.15" uses HTTPS and is not geo locked.
Reply
#8
I didn't get an listing from the addon at all, it just kept "spinning".
Reply
#9
(2013-09-04, 08:52)wsnipex Wrote: I didn't get an listing from the addon at all, it just kept "spinning".

Strange, you did not even get a channel listing? Did you try rerunning it. If you want you can post a uzgplugin.log on pastebin. That file is located in the main addons\net.rieter.xot folder.

But it should work on all platforms /versions.
Reply
#10
turns out that I don't get a listing at all if I run your addon from a non-installed dev env. If I run it from a normal installation dir, I get a channel listing, but not a single channel opens(keeps "working")

http://paste.ubuntu.com/6061857/
Reply
#11
(2013-09-04, 10:42)wsnipex Wrote: turns out that I don't get a listing at all if I run your addon from a non-installed dev env. If I run it from a normal installation dir, I get a channel listing, but not a single channel opens(keeps "working")

http://paste.ubuntu.com/6061857/

Could you also post the uzgplugin.old.log? It holds info from the previous run. The log only shows the listing of the channels.
Reply
#12
hmm, I didn't have an uzgplugin.old.log, so I deleted the uzgplugin.log and restarted xbmc.
And now its working... I verified SVP Tv https streams are working in your plugin as well with an SSL enabled ffmpeg build.

Dunno what made it work though.
Reply
#13
I tested one of the latest ffmpeg builds:
ffmpeg -i "https://svtplay3a-f.akamaihd.net/i/world/open/20130904/1355926-013A_abc/REGIONALA_NYHET-013A-abc-56a73d3f91e736a7_,900,348,564,1680,.mp4.csmil/index_0_av.m3u8?null=&id=AgBQ2BN2FwNaluOdJ1INF0y3l9i0yBiyecQju8vg3IgpjSLsEtCDDR3ELaxnM0Mokm0s4i9tscIe0Q%3d%3d"

It's a m3u8 stream over HTTPS (from Swedish SVT Play)
I worked just fine. Sadly libavcodec/libavformat 5.5 (or whatever version of libraries needed for this) aren't included in the latest Gotham release (only 5.4) of XBMC.
Reply
#14
(2013-09-05, 09:59)wsnipex Wrote: hmm, I didn't have an uzgplugin.old.log, so I deleted the uzgplugin.log and restarted xbmc.
And now its working... I verified SVP Tv https streams are working in your plugin as well with an SSL enabled ffmpeg build.

Dunno what made it work though.

don't know, but good to hear that it's working with SSL enabled ffmpeg. Are there any plans on getting this into the Trunnk?
Reply
#15
yes, I already opened a PR, but this needs some team work as it affects all platforms.
Reply



Logout Mark Read Team Forum Stats Members Help
Akamaihd HTTPS m3u8 streams not working1
This forum uses Lukasz Tkacz MyBB addons.