Failed to start common plugin cache
#1
I installed the gotham alpha 7 for android today. When i installed the youtube plugin, plugin.commom.cache was installed automatically and now it crashes on every boot saying: Failed to start commoncache. Check log."
Here is my log file: http://xbmclogs.com/show.php?id=53312
And here is a log with debugging enabled in commoncache plugin settings: http://xbmclogs.com/show.php?id=53317
I also had this problem with previous alphas. The last one i can remember that worked was alpha1.

Please help me to fix this problem!
Reply
#2
Seems to be a very common problem (at least on android) i also tested it on my Galaxy S2 and got the same result. And other people seem to have the same problem, see here.
Reply
#3
The issue for this, and other plugins that won't work, is the python interpreter

http://forum.xbmc.org/showthread.php?tid=170883
Reply
#4
Are you sure? Because it was all fine on Frodo and also on the early Gotham builds. But one day, i think it was somewhere around march of 2013, all new Gotham builds failed to start commoncache (i am currently using the 20130219 build and there are no problems with commoncache). Did they change something on the interpreter?
Reply
#5
It was the same with a catchup TV plugin I was using. Working on Gotham alpha 2. Not working now. After removing some python code that formats the date, is working again. It's python.
Reply
#6
Can you desribe what i have to do to make it work on the latest gotham builds?
Reply
#7
The fix I did worked just for that plugin, I don't know how to fix the common cache plugin.
The solution is to fix python for Android, which can only be done by the xbmc devs.
Reply
#8
Oh, i see. Have you filed an official bug roport in the bug tracker?
Reply
#9
http://trac.xbmc.org/ticket/14537
Reply
#10
any update on this?
Reply
#11
I have this bug also on my SG Tab3 10.1, All my other android tabs are find and I took it that it was the Tab3 due to the intel chip it has but that does not seem to be the case.
Reply
#12
Any news on how to fix this?
Reply
#13
I've got several plugins that fail on my tablet with locale errors since alpha1, so I suspect it is related. Hopefully this can be looked at after the feature freeze.

Martin
Reply
#14
Hi,
In digging futher, I have discovered that this might be the culprit. I was wondering if you the devs can take a look at it and hopefully push a new version out.

XBMC: Gotham 13 alpha 9

Possible problem: "import addon="xbmc.python" version="2.0"/"

Any help would be greatly appreciated.

Thanks
Reply
#15
Actually a patch for the locale issue was released just after I posted https://github.com/xbmc/xbmc/commit/cfd6...40a8336b3f python 2.0 is not supported anymore in Gotham http://forum.xbmc.org/showthread.php?tid...pid1527263

Martin
Reply



Logout Mark Read Team Forum Stats Members Help
Failed to start common plugin cache0
This forum uses Lukasz Tkacz MyBB addons.