Linux tvheadend + XBMCbuntu + Acer Aspire Idea 500 yuan MPC718 dual tv tuners
#1
I wonder if someone can please help me in relation to:
tvheadend with yuan MPC718 tv tuner (running on an Acer Aspire idea 500) and xbmcbuntu (12.2)

I am just trying to set all this up and migrate from windows 7. I have XBMCbuntu installed and can connect to tvheadend config.

In tvheadend the DVB inputs that are recognised when clicking on the configuration tab come up as:

1. Zarlink MT 352 DVB-T
2. Yuan MPC718 minipci DVB-T/Analog xc18 PCI:000:02:00.0

Only the Zarlink entry allows you to "Add DWB Network by location" and not the yuan entry (there is no button). And for the Zarlink entry, 0 services are found.

Does anyone know if that is normal for the yuan MPC718 mini PCI card and tvheadend to split this into two recognised inputs or I wonder whether my drivers may be installed incorrectly? I have tried compiling the V4l-dvb drivers and initially had errors (to do with nuances libraries and headers missing which I managed to fix and download) but there seem to be additional settings when you enter for "make menuconfig" and I left everything blank. Im not sure if that is correct but there were no errors after that.

What I want to know is:

1. Is it correct that the above 2 DVB inputs should be recognised in tvheadend in relation to the yuan MPC718 PCI card or does this signal my drivers are not properly installed?
2. If it is incorrect that 2 inputs should be recognised in this way, I wonder if someone with a similar set up or knowledge could tell me what would look correct in relation to the DVB inputs and offer advice as to how to solve this issue.
3. is there any easy way to test if my drivers are installed and working properly

I would be so grateful for any advice in how to get this working.

Mark
Reply
#2
It's ok problem solved. Embarrassingly, the only reason it wasn't finding any services was because I was looking at the wrong television network location that I had thought I was in!.

On an Acer aspire idea 500 if the drivers are set up correctly with V4l etc then it does indeed seem to show the 2 dvb inputs in tvheadend and you have to set it up using the Zarlink MT 352 one.

Finally I have live tv working!
Reply
#3
I think the reason the second adapter "doesn't work" it's because it's the analog tuner, not a digital. In the DVB world, "dual tuner" can mean different things.
Reply
#4
After more research I have solved this further.

The TV tuner is a dual analog x2, digital x2 tuner. There should actually be 2 Zarlink inputs and 2 Yuan inputs and this is what I have now. Zarlink on Adapter 0, Zarlink on Adapter 1, Yuan on Video 0 and another on Video 1.

In order for all 4 inputs to be recognised I had to increase the size of vmalloc (ubuntu 13.04) by entering the following:

Code:
gksudo gedit /etc/default/grub

then changing one of the lines to add additional word so that it reads " GRUB_CMDLINE_LINUX_DEFAULT="quiet splarsh vmalloc=192m"

then save and enter the command:

Code:
"sudo update-grub"
Reply



Logout Mark Read Team Forum Stats Members Help
tvheadend + XBMCbuntu + Acer Aspire Idea 500 yuan MPC718 dual tv tuners0
This forum uses Lukasz Tkacz MyBB addons.