•   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 17
  •   
[RELEASE] Russia Today News Addon
#16
(2013-10-12, 05:25)RedPenguin Wrote: Live still works (do you think you will ever put in a quality selection 180p, 240p, 360p, 720p, etc?).


Though I noticed you only seem to have it set to play RT Global. Will there eventually be an option for America and Doc?

The latest version (1.7.1) supports both RT Global, America, Documentary, Espanol and Arabic in 720p, 360p, 240p and 180p video resolutions through addon settings. Repo at: https://github.com/learningit/plugin.video.rt
Reply
#17
(2013-10-16, 05:59)learningit Wrote:
(2013-10-12, 05:25)RedPenguin Wrote: Live still works (do you think you will ever put in a quality selection 180p, 240p, 360p, 720p, etc?).


Though I noticed you only seem to have it set to play RT Global. Will there eventually be an option for America and Doc?

The latest version (1.7.1) supports both RT Global, America, Documentary, Espanol and Arabic in 720p, 360p, 240p and 180p video resolutions through addon settings. Repo at: https://github.com/learningit/plugin.video.rt

Thanks again. For whatever reason everybody seems to forget about the Doc channel. Even RT's own iOS app doesn't seem to include the Doc channel, LoL.
My librtmp & rtmpdump files for Android-ARM (APKs also), ATV1, iOS (Apple TV 2, iPhone, iPod Touch, & iPad), Linux (32bit & 64bit), MacOS x86 (32bit & 64bit), RasPi, & Windows
http://www.mediafire.com/?x4cvp5hl4m9xr
Reply
#18
(2013-10-16, 05:59)learningit Wrote:
(2013-10-12, 05:25)RedPenguin Wrote: Live still works (do you think you will ever put in a quality selection 180p, 240p, 360p, 720p, etc?).


Though I noticed you only seem to have it set to play RT Global. Will there eventually be an option for America and Doc?

The latest version (1.7.1) supports both RT Global, America, Documentary, Espanol and Arabic in 720p, 360p, 240p and 180p video resolutions through addon settings. Repo at: https://github.com/learningit/plugin.video.rt

I have 1.7.1 installed, but in the addon the settings page is completely blank.. is there something special I must do? I have XBMC 12.1, could that be the problem?

(2013-10-16, 01:50)RedPenguin Wrote: My list is formatted specifically for use in the "LiveStreams" add-on. So it's already capable for us in XBMC.


I don't have live streams in my list of addons at xbmc.org.. is it because I have an outdated XBMC? 12.1 ? I hesitate to change it because I configured AEON nox skin *a lot* and am worried about messing it up through upgrading
Reply
#19
(2013-10-16, 14:42)ycomp Wrote: I don't have live streams in my list of addons at xbmc.org.. is it because I have an outdated XBMC? 12.1 ? I hesitate to change it because I configured AEON nox skin *a lot* and am worried about messing it up through upgrading

The current version v1.8.0 is available in the frodo repo: http://mirrors.xbmc.org/addons/frodo/plugin.video.rt/
Reply
#20
Version 1.8.4 - Updated 11/25/13 - New addon configuration parameters to allow autoplay of news and selection of video resolution (upto 720p supported). Selection of news region also added.
Reply
#21
Thanks for the plugin. None of the Live streams appear to work anymore.
Reply
#22
(2014-02-13, 03:07)vernonjvs Wrote: Thanks for the plugin. None of the Live streams appear to work anymore.

Thanks, the streams have changed sometime from a week ago when I updated the add-on. I'll make the changes tomorrow and submit to the repo. Thanks again for spotting this.
Reply
#23
All live streams are updated and hopefully fixed.

You can load the updated version at https://github.com/learningit/plugin.video.rt/releases - I will request update to frodo repo as well.

There is a new speed - auto which I assume auto selects the speed. You will notice that the resolution displayed by XBMC doesn't always match the resolution selected, i.e. 480p shows 540 on XBMC. I use the resolutions which RT uses to describe the streams.
Reply
#24
@learningit thanks for this great add on, any chance you could possibly add the newly launched RT UK live feed please?
Reply
#25
RT UK added. When I tested, content looked the same as RT USA, but it is a different URL. You can set the speed in addon settings - I was getting buffering.

Version 1.9.4, has been submitted to the XBMC.org repo. If you can't wait grab it from my GIT:

https://github.com/learningit/plugin.video.rt
Reply
#26
Thanks for your plugin!

I have a problem: it gets buffering every 2-3 minutes, no matter which resolution I choose in settings,
I know we have not the best link to Australia from the rest of the world but I don't have any problem watching RT through the app on iPad even in highest resolutions..

Hardware I use: mac mini 2007 running OS 10.6 with Kodi beta2 (used to go with XBMC, same issue)

If you need some debug information please describe how to collect
Reply
#27
I am having the same issue with buffering, but it is every 10 seconds for just a split moment. More like a stutter. Would love to see this being fixed!
Reply
#28
(2014-12-06, 04:51)megusd Wrote: Thanks for your plugin!

I have a problem: it gets buffering every 2-3 minutes, no matter which resolution I choose in settings,
I know we have not the best link to Australia from the rest of the world but I don't have any problem watching RT through the app on iPad even in highest resolutions..

Hardware I use: mac mini 2007 running OS 10.6 with Kodi beta2 (used to go with XBMC, same issue)

If you need some debug information please describe how to collect

(2014-12-08, 16:35)Berrypicker Wrote: I am having the same issue with buffering, but it is every 10 seconds for just a split moment. More like a stutter. Would love to see this being fixed!

Once the addon starts playing the video, it's in the hands of the video player so there's not much that can be done in the addon itself. I will have a look if you post a link to a debug log Log_file (wiki) Please post the actual log to xbmclogs.com or pastebin, not here in the forum.
The m3u8 streams seem more sensitive to delays and network issues. I have found that switching from wifi to wired ethernet has sometimes fixed the buffering issues.
Reply
#29
learningit, after I updated to Kodi 14.0, the issue of buffering was fixed! I presumed it was the addon since other streams were working fine. Thanks!
Reply
#30
(2014-12-08, 17:03)learningit Wrote: Once the addon starts playing the video, it's in the hands of the video player so there's not much that can be done in the addon itself. I will have a look if you post a link to a debug log Log_file (wiki) Please post the actual log to xbmclogs.com or pastebin, not here in the forum.
The m3u8 streams seem more sensitive to delays and network issues. I have found that switching from wifi to wired ethernet has sometimes fixed the buffering issues.

Hi
I have fresh installed Kodi final release and all add ons I used to have
The problem is still present, not as regular as before but quiet often.
Sorry, the log uploader is not working at the moment so I just copy short part of the log presents a times (min 51, 53, 57) when it happens
Quote:17:50:34 T:2688038208 NOTICE: GL: NPOT texture support detected
17:50:34 T:2688038208 NOTICE: GL: Using GL_ARB_pixel_buffer_object
17:50:35 T:2956017664 NOTICE: Initialize pseudo device - requesting stream 0
17:50:35 T:2955485184 NOTICE: CAEEncoderFFmpeg::Initialize - AC3 encoder ready
17:50:55 T:2973487104 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
17:51:30 T:2971357184 NOTICE: ES: Client from 127.0.0.1 timed out
17:51:35 T:2973487104 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
17:51:55 T:2970824704 WARNING: Previous line repeats 2 times.
17:51:55 T:2970824704 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
17:52:12 T:2973487104 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
17:53:13 T:2970824704 WARNING: Previous line repeats 26 times.
17:53:13 T:2970824704 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
17:54:27 T:2971357184 NOTICE: ES: Client from 127.0.0.1 timed out
17:57:10 T:2973487104 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
17:57:11 T:2970824704 WARNING: CDVDMessageQueue(video)::Get - asked for new data packet, with nothing available
later if log uploader succeed I will upload the full log and update with a link to it

Thank you
Reply
  •   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 17
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Russia Today News Addon2
This forum uses Lukasz Tkacz MyBB addons.