•   
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 17
  •   
[RELEASE] Russia Today News Addon
#31
Are you using a proxy? I don't think it's necessary for this addon and could be adding delays to the video stream.
Reply
#32
(2014-12-31, 14:38)learningit Wrote: Are you using a proxy? I don't think it's necessary for this addon and could be adding delays to the video stream.

I am not using any proxy
Quote:Traceroute has started…

traceroute: Warning: odna.octoshape.net has multiple addresses; using 205.185.216.42
traceroute to cds.w3n8q3c5.hwcdn.net (205.185.216.42), 64 hops max, 72 byte packets
1 bigpond (192.168.1.254) 10.974 ms 5.159 ms 3.655 ms
2 bri-sot-wic-bras4-loopback20.tpgi.com.au (10.20.20.248) 18.343 ms 18.950 ms 17.285 ms
3 203-219-166-1.static.tpgi.com.au (203.219.166.1) 17.818 ms 16.862 ms 16.345 ms
4 syd-sot-ken-dom2-be-20.tpgi.com.au (203.219.35.70) 31.185 ms 30.237 ms 28.747 ms
5 * * *
6 173.245.208.14 (173.245.208.14) 31.138 ms 29.813 ms 29.933 ms
7 map2.hwcdn.net (205.185.216.42) 30.114 ms 31.445 ms 30.025 ms
Quote:Traceroute has started…

traceroute to rt.com (103.5.149.34), 64 hops max, 72 byte packets
1 bigpond (192.168.1.254) 8.884 ms 1.008 ms 2.685 ms
2 bri-sot-wic-bras4-loopback20.tpgi.com.au (10.20.20.248) 16.671 ms 15.691 ms 16.878 ms
3 203-219-166-65.static.tpgi.com.au (203.219.166.65) 16.906 ms 17.151 ms 16.839 ms
4 syd-gls-har-int2-be-20.tpgi.com.au (203.29.129.196) 29.893 ms 31.982 ms 32.432 ms
5 retn2-10g.hkix.net (202.40.161.247) 143.806 ms 143.523 ms 144.411 ms
6 et510-7.rt.mr.msk.ru.retn.net (87.245.232.34) 415.830 ms 405.288 ms 409.506 ms
7 gw-indrik.retn.net (87.245.253.126) 409.379 ms 323.010 ms 350.683 ms
8 * * *
9 * * *

It may be related to wifi but I have no problem at all streaming even higher resolution movies on Kodi from local NAS and all kinds of internet sources.
The problem seems occur only when streaming live. It may be not enough buffering to cover this short drop outs or player does not use buffering at all..


here is a full Log I finally recovered. I restarted Kodi and run RT plugin, then uploaded log just after 2 drop outs spotted (17:17, 17:28)
Reply
#33
The log just shows the link timing out. You might try setting a lower resolution (the log is showing 720p which is highest). The traceroute is showing some pretty slow times as well. When I run a traceroute here in the US, I get redirected to a different host so I can't really test the timings in the same way. You may want to try a different feed (US, UK, etc) to see if you also get stuttering.

As the feed is http:, you may also try adjusting the curl timeout, cachesize, buffermode and readbufferfactor in the advancedsettings.xml file to a higher value ( see http://kodi.wiki/view/Advancedsettings.xml ). Something like this

Code:
<advancedsettings>
<network>
  <curlclienttimeout>45</curlclienttimeout>  <!-- Timeout in seconds for libcurl (http/ftp) connections -->
  <curllowspeedtime>5</curllowspeedtime>  <!-- Time in seconds for libcurl to consider a connection lowspeed -->
  <cachemembuffersize>90000000</cachemembuffersize>  <!-- number of bytes used for buffering streams ahead in memory
   {{subst:Name}} will not buffer ahead more than this. WARNING: for the bytes set here, {{subst:Name}} will consume 3x the amount of RAM
   When set to 0 the cache will be written to disk instead of RAM, as of v12 Frodo -->
  <buffermode>1</buffermode>  <!-- Choose what to buffer:
    0) Buffer all internet filesystems (like "2" but additionally also ftp, webdav, etc.) (default)
    1) Buffer all filesystems (including local)
    2) Only buffer true internet filesystems (streams) (http, etc.)
    3) No buffer -->
  <readbufferfactor>4.0</readbufferfactor> <!-- this factor determines the max readrate in terms of readbufferfactor * avg bitrate of a video file.
This can help on bad connections to keep the cache filled. It will also greatly speed up buffering. Default value 1.0. -->
</network>
</advancedsettings>
Reply
#34
(2015-01-01, 14:54)learningit Wrote: The log just shows the link timing out. You might try setting a lower resolution (the log is showing 720p which is highest). The traceroute is showing some pretty slow times as well. When I run a traceroute here in the US, I get redirected to a different host so I can't really test the timings in the same way. You may want to try a different feed (US, UK, etc) to see if you also get stuttering.

As the feed is http:, you may also try adjusting the curl timeout, cachesize, buffermode and readbufferfactor in the advancedsettings.xml file to a higher value ( see http://kodi.wiki/view/Advancedsettings.xml ). Something like this

Hi
I've played with advancedsettings.xml a lot and none of the settings helps.
I have realised that my RAM does not decrease even when I use
Code:
<cachemembuffersize>104857600</cachemembuffersize>
which suppose to take ~300mb out 1 free GB I have, it does not fill up at all.
I have monitored codec info ("o") while streaming RT, the buffer is always zero in compare to streaming movies where buffer fills up..
Seems only when watching LIVE the buffer not in use, I've seen zero buffer when watching IPTV Live streams and the same interruptions happens when % of cache utilised drops close to zero (refer codec info"o")

I found similar problem in this thread
Reply
#35
I wasn't sure if the buffer settings would have any effect on live streams - sounds like they have no impact. I would say it's just a slow or poor link between you and the RT host unfortunately. Kodi may be a bit more sensitive or react differently to stream interruption than a browser, so you notice it.
Reply
#36
Is there an issue with RT online today because when I access the addone it is only showing me RT Live and even that does not stream? Have RT updated their website and does the add-on need updating too? Was working yesterday.

Thanks.
Reply
#37
(2015-07-16, 18:20)lookidok Wrote: Is there an issue with RT online today because when I access the addone it is only showing me RT Live and even that does not stream? Have RT updated their website and does the add-on need updating too? Was working yesterday.

Thanks.

There have been some changes to the RT website. I will release a new version tomorrow which fixes the live streams and shows.
Reply
#38
V1.10.0 in my git:
https://github.com/learningit/plugin.video.rt
Has fix for first website changes. I still need to add next page for show videos.


If you have installed my test repo:
https://github.com/learningit/repository...odi_addons

You should get an "auto-update" or "update available" message, depending on your "auto-update" setting. You may need to do a "Check for updates" to see the new version.

Please let me know if this works so that I can get the kodi.org repo updated.
Reply
#39
This may sound like a stupid question but how do I install the repo to update russia today? Thanks

Figured it out thanks!
Reply
#40
Tested latest fix from repository.t1m.kodi_addons-master and everything seems back to normal from my point of view. Now if only the maker of the android widget could be as quick about sorting it out, all would be well. Great job.
Reply
#41
Added your testing repo and the plugin updated to 1.10.0 but when accessing it I still only get RT Live menu item and none of the shows listed. I am in the UK so dunno if that bears any relevance or not.

This is what I get in the log btw:

-- CUT --

03:14:54 T:3028371968 DEBUG: Clearing cached fileitems [plugin://plugin.video.rt/]
03:14:54 T:3028371968 DEBUG: CGUIMediaWindow::GetDirectory (plugin://plugin.video.rt/)
03:14:54 T:3028371968 DEBUG: ParentPath = [addons://sources/video]
03:14:54 T:2381814592 DEBUG: StartScript - calling plugin Russia Today News('plugin://plugin.video.rt/','77','')
03:14:54 T:2381814592 DEBUG: WaitOnScriptResult - waiting on the Russia Today News (id=93) plugin...
03:14:54 T:2510289728 NOTICE: Thread LanguageInvoker start, auto delete: false
03:14:54 T:2510289728 INFO: initializing python engine.
03:14:54 T:2510289728 DEBUG: CPythonInvoker(93, /home/xbmc/.kodi/addons/plugin.video.rt/default.py): start processing
03:14:55 T:2510289728 NOTICE: -->Python Interpreter Initialized<--
03:14:55 T:2510289728 DEBUG: CPythonInvoker(93, /home/xbmc/.kodi/addons/plugin.video.rt/default.py): the source file to load is "/home/xbmc/.kodi/addons/plugin.video.rt/default.py"
03:14:55 T:2510289728 DEBUG: CPythonInvoker(93, /home/xbmc/.kodi/addons/plugin.video.rt/default.py): setting the Python path to /home/xbmc/.kodi/addons/plugin.video.rt:/usr/lib/python2.7:/usr/lib/python2.7/plat-i386-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload:/usr/local/lib/python2.7/dist-packages:/usr/lib/python2.7/dist-packages:/usr/lib/python2.7/dist-packages/PILcompat:/usr/lib/python2.7/dist-packages/gst-0.10:/usr/lib/python2.7/dist-packages/gtk-2.0
03:14:55 T:2510289728 DEBUG: CPythonInvoker(93, /home/xbmc/.kodi/addons/plugin.video.rt/default.py): entering source directory /home/xbmc/.kodi/addons/plugin.video.rt
03:14:55 T:2510289728 DEBUG: CPythonInvoker(93, /home/xbmc/.kodi/addons/plugin.video.rt/default.py): instantiating addon using automatically obtained id of "plugin.video.rt" dependent on version 2.1.0 of the xbmc.python api
03:14:55 T:3028371968 DEBUG: ------ Window Init (DialogBusy.xml) ------
03:14:55 T:2510289728 DEBUG: Russia Today News: getRequest URL:http://www.rt.com/shows/
03:14:55 T:2381814592 DEBUG: WaitOnScriptResult- plugin returned successfully
03:14:55 T:2510289728 INFO: CPythonInvoker(93, /home/xbmc/.kodi/addons/plugin.video.rt/default.py): script successfully run
03:14:55 T:3028371968 DEBUG: Saving fileitems [plugin://plugin.video.rt/]
03:14:55 T:3028371968 DEBUG: -- items: 1, sort method: 0, ascending: false
03:14:55 T:2438982464 NOTICE: Thread BackgroundLoader start, auto delete: false
03:14:55 T:2438982464 DEBUG: Thread BackgroundLoader 2438982464 terminating
03:14:55 T:2510289728 INFO: Python script stopped
-- CUT --
Reply
#42
(2015-07-18, 04:09)lookidok Wrote: Added your testing repo and the plugin updated to 1.10.0 but when accessing it I still only get RT Live menu item and none of the shows listed. I am in the UK so dunno if that bears any relevance or not.

This is what I get in the log btw:

Never post logs in the forum pages - post them to xbmclog.com or pastebin.com and always post the entire log, not a piece. The above tells me absolutely nothing.
Out of curiosity, do the live feeds play for you?
Reply
#43
I just tested with a UK proxy and the addon seems to work fine. There are minor differences between the US and European pages, but the addon didn't have any problems.
Reply
#44
Ahhhh looked at it this morning an it seems to work ok. Smile Thanks for that maybe you pushed some changes to it over night? I am hooked into your repo now so hopefully will get any iterative changes.

Thanks.
Reply
#45
Update fixed my issues thanks so much. Sad thought that I need to watch a russian news channel for real news.
Reply
  •   
  • 1
  • 2
  • 3(current)
  • 4
  • 5
  • 17
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Russia Today News Addon2
This forum uses Lukasz Tkacz MyBB addons.