"no poster found for this movie" - wha?
#1
Well, I'm not sure what's going on. I fired up Ember a couple of days ago and the VM I run it on was not connected to my network shares, which resulted in losing my database till I stopped ember, re-mapped the drives and started it up again at which time it added everything back.

Now though when I scrape a movie (and I'm guessing TV show too) I am getting an error "no posters found for this movie" and "no artwork found for this movie".

I am normally set up to scrape using the native scrapers and thinking maybe one of the sites was down I enabled scraping from tmdb.org and when I do that I get the same error but also see an "http error" pop in the lower right corner of the desktop.

What might be causing this?

Thanks.
Reply
#2
Same here.

EMM was working fine yesterday, fired it up today and I am getting the same errors.

"no posters found for this movie" and "no artwork found for this movie"
Reply
#3
Same problem for me as well! Any solution to this yet?
Reply
#4
Same problem in Germany too...
Themoviedb.org makes problems, with IMPAwards ember finds posters but no fanarts.
Reply
#5
Yes I have the same Problems... :-(
Reply
#6
according to http://www.themoviedb.org/talk/5237a29f760ee3254d143928 they shut down their old 2.1 API two days ago (finally)
Is Ember still using this?!
Would explain the no-poster-issue...
tinyMediaManager - THE media manager of your choice :)
Wanna help translate TMM ?
Image
Reply
#7
Sad
Reply
#8
I guess yesterday wasn't the best day to rescrape my entire collection then. Came halfway through before TMBD obviously shut their API down. Hope it's a quick fix.
Reply
#9
Workaround:

1. Create an TMDB account or login

2. get an API Key

3. Config Ember:

Image
Reply
#10
Hi Dan.

One note, your embedded links have ' ' around them and won't work when clicked (I had to edit the links).

I was able to create an account and I authorized it but when I try your .API key link I am getting an "unauthorized" error returned from the server.

Thanks much for providing the help.... is this problem due to the legacy API being retired?

I was able to get to the API request page by clicking on my account details (after having created the account, verifying it and logging in) and then going through the API request form.

Be aware that they want a lot of information to give you the API such as your address, phone number, the web page for your application and a summary of what you will use the API for.

It seems that this might be a very limited workaround at best especially if they are flooded with requests from people who want EMM to scrape stuff (and list that in the details).

Once details are provided the API key is generated in pretty short order. Now on to try to configure it into Ember.
Reply
#11
OK, it's working, kind of tricky though. I had to enable TMDB as a data scraper (as Dan shows above) with the API key, then I had to disable the native EMM artwork scraper options and manually enable TMDB artwork scraper and now posters and fanart are being picked up.

Other combinations of scrapers yielded some unpleasant results.

Thanks Dan for the workaround!

Also, does this mean that EMM has been cutoff from TMDB now that the 2.1 API is retired?
Reply
#12
That fix has kind of worked for me. I had to disable the default scaper which means it doesn't pull in all the plot summary, and it keeps throwing up error warnings, but it is pulling in the artwork now (although they seem to be 1920x1920 instead of 1902x1080 type sizes!)
Reply
#13
Thankyou - It fixed the problem with posters/fanarts for me too.
But: In addition to Finchy's description regarding summery & error warnings I now cant't get ember to scrape the FSK (for Germany) anymore. :-(

I tried a lot combinations in the settings without solving this.
Reply
#14
Yes I observe the same things, not pulling all the data in any longer and popping https errors.
Reply
#15
Hi, I have setup Ember with an api key and the settings that DanCooper suggested in his work around but I am unable to get posters of an acceptable size and quality. Before I could get 1000x1500 posters every scrape and now all I get is 185x278 "covers". I have changed every size drop-down box to the largest size to see if that would have any effect but it hasn't. Enabling the other "get poster from" options just results in even more small posters and non English ones. I'm sure I'm overlooking something. Does anyone know how to correct this issue?
Reply



Logout Mark Read Team Forum Stats Members Help
"no poster found for this movie" - wha?0
This forum uses Lukasz Tkacz MyBB addons.