•   
  • 1
  • 236
  • 237
  • 238(current)
  • 239
  • 240
  • 244
  •   
  Thread Closed
Linux Radeon OSS with vdpau (howto)
(2015-03-09, 15:31)fritsch Wrote: dvix/xvid accel is working by luck ;-) as during the xvid/dvix period there were a lot of different coders, formats differences and so on - I would just disable acceleration for those.

What exactly I should disable in Kodi settings?
Sorry for noob question.
Orange Pi PC Plus [OpenELEC 7.0]
Mpeg-4 and depending on your gpu (if it's a hd5000) also Mpeg-2
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Nothing for pastebin, so i do it like this:
Somewhere found to post also ls -l /dev/snd/, so here it is...

Code:
[email protected]:~$ aplay -l | pastebinit
aplay: device_list:268: no soundcards found...
You are trying to send an empty document, exiting.
[email protected]:~$ ls -l /dev/snd/
total 0
drwxr-xr-x 2 root root       80 Apr 11 12:28 by-path
crw-rw---- 1 root audio 116,  4 Apr 11 12:28 controlC0
crw-rw---- 1 root audio 116, 10 Apr 11 12:28 controlC1
crw-rw---- 1 root audio 116,  3 Apr 11 12:28 hwC0D0
crw-rw---- 1 root audio 116,  9 Apr 11 12:28 hwC1D0
crw-rw---- 1 root audio 116,  2 Apr 11 19:50 pcmC0D3p
crw-rw---- 1 root audio 116,  8 Apr 11 12:28 pcmC1D0c
crw-rw---- 1 root audio 116,  7 Apr 11 19:50 pcmC1D0p
crw-rw---- 1 root audio 116,  6 Apr 11 19:50 pcmC1D1p
crw-rw---- 1 root audio 116,  5 Apr 11 12:28 pcmC1D2c
crw-rw---- 1 root audio 116,  1 Apr 11 12:28 seq
crw-rw---- 1 root audio 116, 33 Apr 11 12:28 timer
Jo - no soundcards found ... or most likely you are not in the audio group.


From what I see you don't run the user I have told to use in that howto. So fix your permission issue:

sudo adduser pana audio
sudo adduser pana video

sudo reboot
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Did not know that it is for certain user, now for xbmc user:

http://paste.ubuntu.com/10802353/
(2015-04-11, 19:46)fritsch Wrote: Mpeg-4 and depending on your gpu (if it's a hd5000) also Mpeg-2

Thanks a lot.
I'll give it a try.
Orange Pi PC Plus [OpenELEC 7.0]
(2015-04-11, 20:07)Pana_Ruplahlava Wrote: Did not know that it is for certain user, now for xbmc user:

http://paste.ubuntu.com/10802353/

card 1: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 1/1

Can't you just provide all the logs the howto on page 1 wants to have? At least there _is_ your output device. That you need to set as your PCM device.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
[email protected]:/home/pana$ dmesg | pastebinit
http://paste.ubuntu.com/10806579/
[email protected]:/home/pana$ cat ~/.kodi/temp/kodi.log | pastebinit
http://paste.ubuntu.com/10806580/
[email protected]:/home/pana$ cat /var/log/Xorg.0.log | pastebinit
http://paste.ubuntu.com/10806581/
[email protected]:/home/pana$ DISPLAY=:0 vdpauinfo | pastebinit
http://paste.ubuntu.com/10806583/
[email protected]:/home/pana$ dpkg -l |grep mesa | pastebinit
http://paste.ubuntu.com/10806584/
[email protected]:/home/pana$

Here they are. How can i set it as my PCM device?

Thank you Smile
Quote:12:28:17 T:140256810764224 NOTICE: Device 2
12:28:17 T:140256810764224 NOTICE: m_deviceName : @:CARD=SB,DEV=0
12:28:17 T:140256810764224 NOTICE: m_displayName : HDA ATI SB
12:28:17 T:140256810764224 NOTICE: m_displayNameExtra: ALC887-VD Analog
12:28:17 T:140256810764224 NOTICE: m_deviceType : AE_DEVTYPE_PCM
12:28:17 T:140256810764224 NOTICE: m_channels : FL,FR
12:28:17 T:140256810764224 NOTICE: m_sampleRates : 48000
12:28:17 T:140256810764224 NOTICE: m_dataFormats : AE_FMT_S32NE

Huh System -> Settings -> Systems -> Audio Output:
Audio Output Device: HDA ATI SB (ALC887-VD Analog) or how it's called

Enabe Passthrough: disabled.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Im confused too, because ive been trying this setting before and it is not working. Re-tested now...
No idea what you mean with "not working" make a screenshot when you set that device. If "non working" means muted, then just unmute the device.

Edit: And post a Debug Log (e.g. turn debugging on, change device), post logfile in that order
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Not working means, no sound coming out from the port. Device is not muted, on max volume.
Debu log:
http://xbmclogs.com/pxwud8i6e
Crash log:
http://xbmclogs.com/payooxhyv
use alsamixer -c1 to unmute it
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
The crashlog was 13.2 :-) hahahaha
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Angel Did not read the log, just copypaste...

BUT! It was muted! Working like a charm now! Thank you a lot! Smile
  •   
  • 1
  • 236
  • 237
  • 238(current)
  • 239
  • 240
  • 244
  •   
  Thread Closed
 
Thread Rating:
  • 26 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
Radeon OSS with vdpau (howto)4.5826