•   
  • 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 244
  •   
  Thread Closed
Linux Radeon OSS with vdpau (howto)
#91
Maybe it will help someone: my computer immediately freezes when I connect device (over HDMI) with no audio capabilities (projector for example) with "radeon.audio=1" option enabled. It's not big problem for me, because I have S/PDIF connection to the AV receiver.
I think it is OSS radeon driver bug.
#92
Yes it is, cause of this the radeon.audio=1 is not default.

Edit: I mentioned this in the howto, thx for reporting.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
#93
Unfortunately, still no sound after running xrandr. Is there any way of seeing if this had any effect?
I see dmesg reporting the following right after hitting the command:
Code:
[  266.369249] HDMI: ELD buf size is 0, force 128
[  266.369271] HDMI: invalid ELD data byte 0

Also disabling dpm didn't do anything, same for EXAPixmaps and even XAA acceleration.
Obviously, putting "NoAccel" fixed things ;-)

Complete dmesg after removing dpm=1:
http://paste.ubuntu.com/6197292/

Xorg.conf:
http://paste.ubuntu.com/6197269/
#94
you can see /var/log/Xorg.0.log

Download: https://dl.dropboxusercontent.com/u/5572...arantz.bin and save it to /lib/firmware/edid
you have to create the /lib/firmware/edid directory. Make 100% sure, the file has exact 256 Byte, if not redownload it.

afterwards write to /etc/default/grub:
Code:
GRUB_CMDLINE_LINUX_DEFAULT="drm_kms_helper.edid_firmware=HDMI-A-1:edid/marantz.bin radeon.audio=1 radeon.dpm=1 quiet splash"

This will overwrite EDID and ELD info.

Good luck. If you don't get it to work - file a bug on freedesktop, one for the audio and one for the video and locotomif can add his logfiles there, too.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
#95
(2013-10-05, 15:43)fritsch Wrote: You have qualified for the next round :-)

Image

I think it's not bad for someone who doesn't see the 24p Bug Image
#96
(2013-10-05, 19:20)fritsch Wrote: Good luck. If you don't get it to work - file a bug on freedesktop, one for the audio and one for the video and locotomif can add his logfiles there, too.

Unfortunately nothing changed Sad I will file the two bugs separately. Thanks!
#97
I'll give it a try on Monday, and report back.

glad to see that I'm not alone! let's make this driver work for everyone!!! Smile
Linux Mint 18 LTS 64-bit - Kodi 17 Beta6
Odroid-C2 - Libreelec v7.90.009
#98
Unexpected bonus of OSS: VNC actually works with XBMC running... fglrx always showed a black screen in XBMC but worked in openbox, etc.

Not actually sure what piece of the puzzle caused this to work, but I'm glad nonetheless.
#99
(2013-10-03, 10:52)fritsch Wrote: advancedsettings.xml in /home/xbmc/.xbmc/userdata/advancedsettings.xml should contain (don't create that file / directory as root - use the xbmc user):
Code:
<advancedsettings>
   <loglevel hide="false">0</loglevel>
  <cputempcommand>sensors|sed -ne "s/temp1: \+[-+]\([0-9]\+\).*/\1 C/p"</cputempcommand>
  <gui>    
    <algorithmdirtyregions>3</algorithmdirtyregions>
    <nofliptimeout>0</nofliptimeout>
  </gui>    
<video>
  <latency>
    <delay>0</delay>
    <refresh>
      <min>23</min>
      <max>24</max>
      <delay>175</delay> <!-- set to zero or adjust if audio seems out of sync with 24p movies -->
     </refresh>
  </latency>
</video>
</advancedsettings>

fritsch, first off - thank you very much for this tutorial. this is absolutely one of the best that i have ever seen - you are thorough beyond dreams.

can you help with how to accomplish the above? i'm not quite sure to do it (aside from attempting from root which you explicitly say not to do). please advise.
thank you!
okay, so i had some extra time,

so here's something of interest...
with this setup, i'm not getting an xorg.conf

so i copied yours, @noopiex, and yes, setting "NoAccel" does work... but not a good option, as both CPU's are maxed out, and the menu is SUPER SLOW.

thanks!

@noopiex, can you give me some assistance in posting a log on freedesktop. way beyond my scope.

------------------------------------------

additional note: i'm running ATI Richland [Radeon HD 8470D]
i don't see anywhere on the x.org site that says it's supporting Richland, at the moment... could this be an issue? http://www.x.org/wiki/radeon/
Linux Mint 18 LTS 64-bit - Kodi 17 Beta6
Odroid-C2 - Libreelec v7.90.009
@noopiex:
Concerning the Audio, please also try:

Code:
sudo service xbmc stop
X &
xrandr --output HDMI-0 --set audio auto
speaker-test -c 2 -D plughw:0,3

@jal301:
It is not reeally difficult, just start xbmc once. Then do:
nano ~/.xbmc/userdata/advancedsettings.xml
Paste in the content and save the file ctl-o followed by ctl-x
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
@locomot1f
Same here, I didn't have an xorg.conf to begin with either. I used fritsch's from page 266 in the XVBA thread as an example. As you saw, it does work, "NoAccel" does what it says ;-)
I didn't file a bug for the flickering yet, because it seems others already filed it. Example: https://bugs.freedesktop.org/show_bug.cgi?id=60389

Steps to post a bug report:
1. Go to https://bugs.freedesktop.org/ and login or create a new account.
2. Now you can file a bug, this is the path I would select, but I could be wrong: Select "xorg", component "Drivers/Gallium/Radeonsi", version "git".
3. Describe the bug and include log files.

I wonder, since we have the same flickering issue, does audio work for you? If so, what did you do to get it working?
You could be right about HD 8xxx not being supported yet. It's not listed here either: http://xorg.freedesktop.org/wiki/RadeonFeature/

@fritsch: I will try that.
@fritsch:
Speaker-test does work!
So what could be wrong with xbmc? Why would aplay not work either?
Pretty easy, you have wrong sound settings in xbmc :-)

make sure your ~/.xbmc/userdata/guisettings.xml contains:

Code:
<audiooutput>
        <ac3passthrough>true</ac3passthrough>
        <audiodevice>ALSA:hdmi:CARD=Generic,DEV=0</audiodevice>
        <channels>8</channels>
        <dtshdpassthrough>true</dtshdpassthrough>
        <dtspassthrough>true</dtspassthrough>
        <eac3passthrough>true</eac3passthrough>
        <guisoundmode>1</guisoundmode>
        <mode>2</mode>
        <multichannellpcm>true</multichannellpcm>
        <normalizelevels>true</normalizelevels>
        <passthroughaac>false</passthroughaac>
        <passthroughdevice>ALSA:hdmi:CARD=Generic,DEV=0</passthroughdevice>
        <processquality>50</processquality>
        <stereoupmix>false</stereoupmix>
        <streamsilence>true</streamsilence>
        <truehdpassthrough>true</truehdpassthrough>
</audiooutput>

Especially passthroughdevice and audiodevice are relevant.

And about the xrandr command for audio, you have to run it everytime _after_ your xserver is up.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
I inserted your "audiooutput" into the xml file, but I already had the correct audiodevice and passthroughdevice selected.
Xrandr indeed needs to be hit every time. However, still no luck. Speaker-test works. XBMC doesn't.
  •   
  • 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 244
  •   
  Thread Closed
 
Thread Rating:
  • 26 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
Radeon OSS with vdpau (howto)4.5826