TVDB are updating their site. Their site currently has a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are working to rectify the problems.

  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 244
  •   
  Thread Closed
Linux Radeon OSS with vdpau (howto)
#61
All the logfiles are looking great.

Make sure you are member of the video group.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
#62
yup -- Sad

it's really beyond tearing... cause it's not just horizontal.
it's like all this "noise" in the display.

here's a pic: https://www.dropbox.com/sc/vf83py3qr9tzvro/0OISd3nk5N

should be pretty visible...
although a pic does not truley represent what is happening... because it's constantly flickering like this all over the screen.
like i said -- "noise"
Linux Mint 18 LTS 64-bit - Kodi 17 Beta6
Odroid-C2 - Libreelec v7.90.009
#63
No further ideas - i pinged @laric which has similar hardware to yours. Perhaps he knows what is going on.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
#64
i've had that once on my e350, just assumed it was all the messing about i did with compiling from source so reinstalled raring.
Asus E2KM1I-DELUXE (E2-2000 with HD7340) 60GB SSD + 2TB WD Caviar Green : Xubuntu 18.04 LTS : (mythtv 0.29.1+fixes + TBS 6205 QUAD FREEVIEW DVB-T2)
Odroid C2 Coreelec.
#65
@ deadite, i see your tag... is your system running any GUI? (Xcfe, Unity, etc.)?
Linux Mint 18 LTS 64-bit - Kodi 17 Beta6
Odroid-C2 - Libreelec v7.90.009
#66
blackbox on my Panasonic tv, xfce on a vnc.
Asus E2KM1I-DELUXE (E2-2000 with HD7340) 60GB SSD + 2TB WD Caviar Green : Xubuntu 18.04 LTS : (mythtv 0.29.1+fixes + TBS 6205 QUAD FREEVIEW DVB-T2)
Odroid C2 Coreelec.
#67
I just wanted to share my experience:
I installed Xubuntu 13.04 instead of the minimal version.
My hardware is as follows:
Mainboard: ASUS M4A78-E
CPU: AMD Athlon X2 4850e
GPU: HIS HD 4670

I had vertical tearing despite precisely following the tutorial (I skipped the xbmc.conf part in /etc/init) and xbmc crashed _every time_ I wanted to exit it.

After playing around a little I have no tearing and no more crashes with the following options different from the tutorial:

System->Settings->System->Video Settings:
Vertical Sync: Disabled

System ->Video->Playback:

Adjust Refreshrate to match video: Off
Sync Playback to Display: off

The other settings (including the advanced config) are the same and now my video playback is as smooth as I could wish for.

Also, xbmc only crashed once on exiting (of maybe 30 tries) and that was after I stuck a pendrive into the computer and the system pushed xbmc to the background to show me a message.

Sound over SP/DIF also works great, I just activated the SP/DIF device and passthrough in System > System > Audio Settings Wink
#68
The crash on exit is a hang I assume, which results from the System -> Addons -> Services -> Xbmc version check addon, you can disable it there (it will also hang after first exit after that, but not afterwards).

radeon does vsync by default, you can see this in the Xorg.0.log
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
#69
i just don't think it has anything to do with VSYNC...
i don't have any crashes. it's just as if for whatever reason, my setup is unable to render the XBMC GUI properly.

on a side note. i loaded the Lubuntu, and was able to use the Experimental Drivers
Code:
To force the use of gallium i915 driver:
$ LIBGL_DRIVERS_PATH=/usr/lib/dri-alternates glxgears -info

definate improvement in image...

unfortunately, my XBMC still jitters all over the place.
Linux Mint 18 LTS 64-bit - Kodi 17 Beta6
Odroid-C2 - Libreelec v7.90.009
#70
(2013-10-04, 19:31)fritsch Wrote: The crash on exit is a hang I assume, which results from the System -> Addons -> Services -> Xbmc version check addon, you can disable it there (it will also hang after first exit after that, but not afterwards).

Thanks, xbmc also "crashed" a few times when it encountered an error, but after disabling the version check addon it didn't hang again.

(2013-10-04, 19:31)fritsch Wrote: radeon does vsync by default, you can see this in the Xorg.0.log

Good to know!


Full HD playback and audio work really well, but I'd like to install the tvheaded pvr plugin (I got tvheaded itself from http://apt.tvheadend.org/stable), which isn't in the fernetmenta-master repository.
So I grabbed xbmc-pvr-tvheadend-hts-1.6.19-0raring from https://launchpad.net/~wsnipex/+archive/xbmc-prestable/ and installed it via dpkg -i.
That was obviously not enough, because after enabling the addon in xbmc it seemed ok, but as soon as I activated the PVR manager, I got an error message saying I should check the logs. And that's what I did, here's the interesting part:
http://pastebin.com/bCjnPzPd

Could you recommend me a source to get pvr addons that are compatible with this build?

Kind regards,

lindworm

edit: added tvheaded source
#71
I will ask wsnipex to also build the xbmc-pvr-addons for easy installation.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
#72
(2013-10-04, 21:48)fritsch Wrote: I will ask wsnipex to also build the xbmc-pvr-addons for easy installation.

great, thanks!
#73
Hi guys, any way to make this happen on debian wheezy?
#74
@wbsoul: I think you have to compile everything mentioned on the first page from source. That is doable but gets you work for a complete week.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
#75
I succesfully built it on Archlinux.
I added the needed patches to the PKGBUILD of the 3.11-2 Kernel and the mesa-full packages.

Here is the edited PKGBUILD and the Patches for mesa.
https://aur.archlinux.org/packages/mesa-full-amd-vdpau/

Because of some restrictions i am unable to upload the edited kernel PKGBUILD to the aur.

Here are my results

Code:
qvdpautest 0.5.2
AMD E-450 APU with Radeon(tm) HD Graphics
Unknown GPU

VDPAU API version : 1
VDPAU implementation : G3DVL VDPAU Driver Shared Library version 1.0

FATAL: get_bits failed : No backend implementation could be loaded.!!

MPEG DECODING (1920x1080): 59 frames/s
MPEG DECODING (1280x720): 91 frames/s
H264 DECODING (1920x1080): 37 frames/s
H264 DECODING (1280x720): 68 frames/s
VC1 DECODING (1440x1080): 84 frames/s
MPEG4 DECODING (1920x1080): 51 frames/s

MIXER WEAVE (1920x1080): 301 frames/s
MIXER BOB (1920x1080): 436 fields/s
MIXER TEMPORAL (1920x1080): 501 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 501 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 499 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 500 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 500 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 500 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 620 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 56 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 495 fields/s
Thank you for your help.
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 244
  •   
  Thread Closed
 
Thread Rating:
  • 26 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
Radeon OSS with vdpau (howto)4.5826