•   
  • 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 244
  •   
  Thread Closed
Linux Radeon OSS with vdpau (howto)
@golddk. To fix the limited rgb display. Assuming u have a Sony. Open the picture they gave you. Full screen.
press options -> picture adjustments take a picture or note of current settings, to save your pro settings, in case you mess it up Then scroll down to brightness. Then scroll right to brighten it just until you can barely, just barely see the left upper box and so that the borders do not look too grey, they stay black. I will dig up easy self calibration links I use. Mp4 vids that you open in xbmc to calibrate. Most sets allow calibration for each input separately. One for HDMI 1 the htpc, one for coax, one for hdmi2 blu ray.... Each input requires the right settings for my eyes to be happiest. This oss required a new recal from the gt610. I reset my set for each new input. For me it's like changing the channel.. 8). Brightness adjusts the black levels and picture adjusts the white levels/contrast. As I see it.
edit add-

basics on how to calibrate http://lifehacker.com/5858625/how-to-cal...es-or-less

videos http://www.avsforum.com/t/948496/avs-hd-...alibration
mp4s to play in xbmc http://www.wuala.com/alluringreality/Public/MP4-2c.7z
-------use basic settings black clipping for brightness. white clipping for picture.. both get you 98% there. fine tune while viewing the movies.
u oh just did the updates to xbmc and oss looks like it borked xbmc vdapu. plays white screen. if i disable acceleration it plays normal.
cant see errors..

logging

http://pastebin.com/5J6G0Yt2

new faster test same hardware. says vc1 not suported--
qvdpautest 0.5.2
AMD A4-3400 APU with Radeon™ HD Graphics
Unknown GPU

VDPAU API version : 1
VDPAU implementation : G3DVL VDPAU Driver Shared Library version 1.0


MPEG DECODING (1920x1080): 83 frames/s
MPEG DECODING (1280x720): 127 frames/s
H264 DECODING (1920x1080): 53 frames/s
H264 DECODING (1280x720): 96 frames/s
MPEG4 DECODING (1920x1080): 74 frames/s

MIXER WEAVE (1920x1080): 447 frames/s
MIXER BOB (1920x1080): 678 fields/s
MIXER TEMPORAL (1920x1080): 742 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 742 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 742 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 742 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 742 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 742 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 815 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 79 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 776 fields/s
i played it safe and held many packages so they don't get upgraded, mostly mesa ones,

Quote:you can hold a package using

sudo apt-mark hold package_name

and remove the hold with

sudo apt-mark unhold package_name

The following packages have been kept back:
libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libegl1-mesa libegl1-mesa-drivers libg3dvl-mesa
libgbm1 libgl1-mesa-dri libgl1-mesa-glx libglamor0 libglapi-mesa libgles2-mesa libopenvg1-mesa
libxatracker1 xserver-xorg-video-ati xserver-xorg-video-intel xserver-xorg-video-radeon
Asus E2KM1I-DELUXE (E2-2000 with HD7340) 60GB SSD + 2TB WD Caviar Green : Xubuntu 18.04 LTS : (mythtv 0.29.1+fixes + TBS 6205 QUAD FREEVIEW DVB-T2)
Odroid C2 Coreelec.
(2013-10-10, 07:22)gfisher Wrote: u oh just did the updates to xbmc and oss looks like it borked xbmc vdapu. plays white screen. if i disable acceleration it plays normal.
cant see errors..

logging

http://pastebin.com/5J6G0Yt2

new faster test same hardware. says vc1 not suported--
qvdpautest 0.5.2
AMD A4-3400 APU with Radeon™ HD Graphics
Unknown GPU

VDPAU API version : 1
VDPAU implementation : G3DVL VDPAU Driver Shared Library version 1.0


MPEG DECODING (1920x1080): 83 frames/s
MPEG DECODING (1280x720): 127 frames/s
H264 DECODING (1920x1080): 53 frames/s
H264 DECODING (1280x720): 96 frames/s
MPEG4 DECODING (1920x1080): 74 frames/s

MIXER WEAVE (1920x1080): 447 frames/s
MIXER BOB (1920x1080): 678 fields/s
MIXER TEMPORAL (1920x1080): 742 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 742 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 742 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 742 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 742 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 742 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 815 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 79 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 776 fields/s

Yep, same here. vdpau works with mplayer or qvdpautest, xbmc gives white screen. Or green screen, if i untick the "prefer vdpau mixer".

I previously updated mesa from git (i even removed the whole mesa dir, cloned again, applied ckoenig patches+compile fix again).
The vdpau interop extensions seem to be present:

Code:
$ glxinfo | grep vdpau
    GL_NV_packed_depth_stencil, GL_NV_texture_barrier, GL_NV_vdpau_interop,
    GL_NV_texture_env_combine4, GL_NV_texture_rectangle, GL_NV_vdpau_interop,

I have these errors in the terminal (maybe it helps):

Code:
Mesa: User error: GL_INVALID_OPERATION in VDPAUMapSurfacesNV
There were a lot of changes in mesa lately concerning vdpau, the missing VC1 in qvdpautest is not a problem, this results from a change that "main and simple vc1 profile" don't work. xbmc correctly reads out the VC1 Advanced capabilities.

For the rest I don't know. If someone has time, ask zgreg on #radeon - but be polite :-)

Btw. does downgrading mesa + latest xbmc still work? If that is also not the case, the problem is in xbmc changes.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2013-10-10, 09:09)fritsch Wrote: There were a lot of changes in mesa lately concerning vdpau, the missing VC1 in qvdpautest is not a problem, this results from a change that "main and simple vc1 profile" don't work. xbmc correctly reads out the VC1 Advanced capabilities.

For the rest I don't know. If someone has time, ask zgreg on #radeon - but be polite :-)

Btw. does downgrading mesa + latest xbmc still work? If that is also not the case, the problem is in xbmc changes.

It is most likely not in xbmc since it was working fine until i upgraded mesa using the same xbmc build.
(2013-10-03, 10:52)fritsch Wrote: If you get reproducable freezes, when you plugin a monitor after adding the above options, remove radeon.audio=1 again.

I get reproducable kernel panics at boot with radeon.audio=1. However, if i remove radeon.audio=1, I have no audio in xbmc.
Any ideas?

Image

I tried without success:
- Marantz Edid
- xrandr --output HDMI-0 --set audio auto

Thanks for your help!
For the sake of completeness:

http://paste.ubuntu.com/6217401/
http://paste.ubuntu.com/6217402/
http://paste.ubuntu.com/6217403/
http://paste.ubuntu.com/6217405/
http://paste.ubuntu.com/6217406/
Quote:Yep, same here. vdpau works with mplayer or qvdpautest, xbmc gives white screen. Or green screen, if i untick the "prefer vdpau mixer".

I would be surprised id they had implemented interop for video surfaces. Last info I got is that only interop for output surfaces works. In other words the mixer is required for OSS:
Pressing "o" during playback shows everything as it should be normally, the driver changes to the "uvd" profile, so only the display is messed up for some reason.

Compiling mesa without the ckoenig patches and enabling vdpau in xbmc causes crash, last line in log is:

Code:
ERROR: VDPAU::COutput driver does not support GL_NV_vdpau_interop

PS. Tere was talk about implementing new subsampling options (4:2:2 and 4:4:4):

http://cgit.freedesktop.org/mesa/mesa/co...0906b4c8ad
maybe it has to do with this?
Check your glxinfo.

Edit: Oh I checked above, it seems to be there.
Edit2: Yes - GLInterOp is needed to run xbmc ... on oss vdpau since the old way was removed: https://github.com/xbmc/xbmc/commit/2eb7...f93a8bb301

There is a reason, why this howto states that patch _as needed_
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
I know that that patch is needed. I just wanted to say that without them xbmc+vdpau doesnt work at all without it, to answer (maybe i misunderstood what he wanted to say)
FernetMenta Wrote:I would be surprised id they had implemented interop for video surfaces.

The patch(+the compile fix patch) still works, with it glxinfo shows the interop extensions as before, without it doesnt. Just the image is all rendered white. Granted i havent tried to disable the vdpau mixer when vdpau was working, so it just might have had the same green screen as it shows now.

Anyway, a fix would be nice Smile
I just want to thank everyone involved in this effort. So far I've only had a few .WMV files not play (I'll try to identify some and post debug logs etc in here when I get a chance), and this release is MUCH more stable than the wsnipex XBVA version I was using before on my E350. It also seems to have much better performance - I used to have freezes/crashes when I tried to skip around videos and that's gone. I am getting better FPS and even the UI seems more responsive.

Cheers! Can't wait until this stuff gets into mainline. Smile
My system shows a white display with vdpau/vdpau mixer both ticked (definitely both required when working for good PQ). Green if only vdpau is ticked. Plays fine off CPU if both unticked. I will look at it more tonight after work. I will try any patches that may come up.
That stuff already is in mainline ...

The only problem is, that Mesa does not have glinterop by default.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2013-10-10, 15:24)gfisher Wrote: My system shows a white display with vdpau/vdpau mixer both ticked (definitely both required when working for good PQ). Green if only vdpau is ticked. Plays fine off CPU if both unticked. I will look at it more tonight after work. I will try any patches that may come up.

I confirm.
My iMac does the same after yesterday's updates.
  •   
  • 1
  • 11
  • 12
  • 13(current)
  • 14
  • 15
  • 244
  •   
  Thread Closed
 
Thread Rating:
  • 26 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
Radeon OSS with vdpau (howto)4.5826