20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

  •   
  • 1
  • 59
  • 60
  • 61(current)
  • 62
  • 63
  • 244
  •   
  Thread Closed
Linux Radeon OSS with vdpau (howto)
@fritsch

I testing again with different types of movies (mkv/H264). I got no crashes up to now, but with 24fps-movies I see frame drops /surges, not with 50fps-movies.
Is this a typcal behavior, or is my configuration/installation wrong?
I don't have these frame-drops with my reference installation (Ubuntu12.10, Xbmc-xvba-frodo) sames movies and same hardware.


for your information :
[email protected]:~$ dmesg | pastebinit
http://paste.ubuntu.com/6407542/
[email protected]:~$ cat ~/.xbmc/temp/xbmc.log | pastebinit
http://paste.ubuntu.com/6407543/
[email protected]:~$ cat /var/log/Xorg.0.log | pastebinit
http://paste.ubuntu.com/6407544/
[email protected]:~$ DISPLAY=:0 vdpauinfo | pastebinit
http://paste.ubuntu.com/6407545/
[email protected]:~$ dpkg -l |grep mesa | pastebinit
http://paste.ubuntu.com/6407552/




The hardware should be performant enough, here's the output from qvdpautest :
-------------------------------------------------------------------------------------------------
qvdpautest 0.5.2
Unknown GPU

VDPAU API version : 1
VDPAU implementation : G3DVL VDPAU Driver Shared Library version 1.0

FATAL: get_bits failed : No backend implementation could be loaded.!!

MPEG DECODING (1920x1080): 83 frames/s
MPEG DECODING (1280x720): 124 frames/s
H264 DECODING (1920x1080): 54 frames/s
H264 DECODING (1280x720): 95 frames/s
Profile unsupported.
MPEG4 DECODING (1920x1080): 78 frames/s

MIXER WEAVE (1920x1080): 1156 frames/s
MIXER BOB (1920x1080): 1614 fields/s
MIXER TEMPORAL (1920x1080): 496 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 484 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 486 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 488 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 487 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 487 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 1074 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 82 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 493 fields/s
Quote:21:55:05 T:140737353840512 DEBUG: Window Manager Name: Compiz
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
@ixbeemce:
Yeah, you are using Compiz, which heavily interferes with everything that tries to Sync to Display. But let's try something: Set your Vertical Blank Sync to "Let driver decide" and Turn Off Sync Playback to Display and retry.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Just a little question: Is it possible to control this xbmc with vnc or something similar?
@fritch

Thanks for the quick answers

I had set the Vertical Blank Sync to "Let driver decide" and Turn Off Sync Playback to Display, but this didn't solve the problem. The frame drops are still in.

This evening I will "switch off" Compitz, as in my refence installation and test again.
Then keep 60hz - that's the price to play for compiz.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
@ fritsch,

thanks for adding the bug in display on some cards in the known issues section.

couple of things:
the link has the ")" attached to it, so it is not linked properly.
second, can you add that it's also some HD 8xxxD APU's, everything that I've seen are the APU's having this problem.

Would like to know if it's also showing up in GPU's.

thanks in advance.
Linux Mint 18 LTS 64-bit - Kodi 17 Beta6
Odroid-C2 - Libreelec v7.90.009
Hi,
it's some time since the file "walker_interlaced.ts" hangs my computer when played with xbmc.
The file plays quite well with vlc though.
I've downloaded the file from laric's repository here
https://www.dropbox.com/sh/rncnghoe7rqwg...zLj_jg?lst
@Claudio.Sjo: http://forum.xbmc.org/showthread.php?tid...pid1548693

Depending on your hardware, the second one is relevant.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2013-11-14, 10:04)fritsch Wrote: @Claudio.Sjo: http://forum.xbmc.org/showthread.php?tid...pid1548693

Depending on your hardware, the second one is relevant.

Mine is Radeon HD 6750M, I'll wait mesa to include it.
If you wish, I can run forther tests.
(2013-11-14, 11:05)Claudio.Sjo Wrote:
(2013-11-14, 10:04)fritsch Wrote: @Claudio.Sjo: http://forum.xbmc.org/showthread.php?tid...pid1548693

Depending on your hardware, the second one is relevant.

Mine is Radeon HD 6750M, I'll wait mesa to include it.
If you wish, I can run forther tests.

http://forum.xbmc.org/showthread.php?tid...pid1549107
(2013-11-12, 20:05)wsnipex Wrote:
(2013-11-12, 09:05)fritsch Wrote: @Claudio.sjo: Yes

@the guy with the broken mpeg-2 decoding, here is your fix: http://cgit.freedesktop.org/mesa/mesa/co...b3b0124687

That will come, when we rebuild mesa.

someone willing to test that?
https://launchpad.net/~wsnipex/+archive/test/

completely new mesa, including DRI3 support for intel

Thanks wsnipex Smile

Will give this a try later today as I'm seeing frequent GPU lockups (almost every time) starting playback here (both switching channel and recordings) - although not on h264 sources - and it isn't dpm related...

Most of the time it resets and recovers, resuming playback, but will hard lock the machine eventually.

Radeon HD6950.
(2013-11-12, 19:09)fritsch Wrote: @TheCritter: Do one, i will link it - I like to support thinking people - but I don't support lazy ones.

*ggg*
Oh nice, but I dont have a public server Wink
(2013-11-14, 13:02)TheCritter Wrote:
(2013-11-12, 19:09)fritsch Wrote: @TheCritter: Do one, i will link it - I like to support thinking people - but I don't support lazy ones.

*ggg*
Oh nice, but I dont have a public server Wink

Use launchpad Smile
If my post helped you then there is a nice "Thank user" button on the bottom of the post.
Ok, still seeing crashes with the mesa test ppa.

Any MPEG-2 based (so it seems) recording has about a 90% chance of causing a GPU lockup. Doesn't seem to happen starting any h264 recordings. After a number of successful resets it will hard lock the machine Sad

Only happens at the start of playback (setting dpm/audo = 0 has no effect).

Logs:
dmesg http://pastebin.com/4fDwRh0V
xorg http://pastebin.com/WRXgTUCx
vdpau http://pastebin.com/jw7NpvQQ
dpkg http://pastebin.com/FQkZYvjk
xbmc http://pastebin.com/Mt1nM6nN
  •   
  • 1
  • 59
  • 60
  • 61(current)
  • 62
  • 63
  • 244
  •   
  Thread Closed
 
Thread Rating:
  • 26 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
Radeon OSS with vdpau (howto)4.5826