•   
  • 1
  • 174
  • 175
  • 176(current)
  • 177
  • 178
  • 244
  •   
  Thread Closed
Linux Radeon OSS with vdpau (howto)
@fritsch
I didn't touch the advancedsettings file. Was working before I did the apt-get upgrade which installed the recently updated XBMC version.
Anyway, sensor is not too important.. Never mind I can live without it.
Provide the output of:
- sensors
and
- sensors|sed -ne "s/Core 0: \+[-+]\([0-9]\+\).*/\1 C/p"

Mentioning bugs and not trying to fix them is a no go :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
@fritsch

I have a Problem with Audio Passthrough all Audio Codecs are played as PCM 2.0. , I did all the steps discribed in the first post. I did a clean install of Ubunut 14.04 Desktop and cleaned my home folder. When I install the official Xbmc from the reposetory Passthrough works fine but the Video lags. With your version 1a video is fine but Audio sucks. Your Xbmc mentioned another HDMI audio device than the official Xbmc Version. The same with version from 1b, but with Gotham I have another problem everytime I want to exit or shutdown Xbmc my Computer freeze.

Thanks for your help

My System is Zotac Mini-ITX E350
Haha..okay..ueberzeugt..

Code:
k10temp-pci-00c3
Adapter: PCI adapter
temp1:        +61.0°C  (high = +70.0°C)
                       (crit = +100.0°C, hyst = +97.0°C)

radeon-pci-0008
Adapter: PCI adapter
temp1:        +61.0°C  (crit = +120.0°C, hyst = +90.0°C)

No output at all for sensors|sed -ne "s/Core 0: \+[-+]\([0-9]\+\).*/\1 C/p"

Relevant part of the advancedsettings
Code:
<cputempcommand>sensors|sed -ne '1h;1!H;${g;s/radeon.*k10temp.*temp1: \+[-+]\([0-9]\+\).*/\1 C/p}'</cputempcommand>

  <gputempcommand>sensors|sed -ne '1h;1!H;${g;s/radeon.*temp1: \+[-+]\([0-9]\+\).*/\1 C/p}'</gputempcommand>
(2014-04-27, 10:02)AlexKid Wrote: @fritsch

I have a Problem with Audio Passthrough all Audio Codecs are played as PCM 2.0. , I did all the steps discribed in the first post. I did a clean install of Ubunut 14.04 Desktop and cleaned my home folder. When I install the official Xbmc from the reposetory Passthrough works fine but the Video lags. With your version 1a video is fine but Audio sucks. Your Xbmc mentioned another HDMI audio device than the official Xbmc Version. The same with version from 1b, but with Gotham I have another problem everytime I want to exit or shutdown Xbmc my Computer freeze.

Thanks for your help

My System is Zotac Mini-ITX E350

Provide the logfiles, the howto wants. Btw. Ubuntu 14.04 uses Pulseaudio by default and this howto explicitely suggests to install a _minimal_ iso. Read here: http://wiki.xbmc.org/index.php?title=PulseAudio
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2014-04-27, 10:04)Endeavour79 Wrote: Haha..okay..ueberzeugt..

Code:
k10temp-pci-00c3
Adapter: PCI adapter
temp1:        +61.0°C  (high = +70.0°C)
                       (crit = +100.0°C, hyst = +97.0°C)

radeon-pci-0008
Adapter: PCI adapter
temp1:        +61.0°C  (crit = +120.0°C, hyst = +90.0°C)

No output at all for sensors|sed -ne "s/Core 0: \+[-+]\([0-9]\+\).*/\1 C/p"

Relevant part of the advancedsettings
Code:
<cputempcommand>sensors|sed -ne '1h;1!H;${g;s/radeon.*k10temp.*temp1: \+[-+]\([0-9]\+\).*/\1 C/p}'</cputempcommand>

  <gputempcommand>sensors|sed -ne '1h;1!H;${g;s/radeon.*temp1: \+[-+]\([0-9]\+\).*/\1 C/p}'</gputempcommand>

Your advancedsettings.xml does not match the one in the howto. Use the howto one and replace Core 0 with temp1 or something.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
@AlexKid
Did you read the info about PulseAudio in the Wiki. Might be the source of your problem.
Sad 
Please help Sad

dmesg
cat ~/.xbmc/temp/xbmc.log
cat /var/log/Xorg.0.log
DISPLAY=:0 vdpauinfo
Quote:Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1
dpkg -l |grep mesa
You are running fglrx. Please follow the howto.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Image

Image

We (especially christian) are currently tuning the 24p modes again - stay tuned.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Here are the kernels and the patch:

Code:
wget https://dl.dropboxusercontent.com/u/55728161/linux-image-3.14.2-amdfixes5%2B_1.0_amd64.deb https://dl.dropboxusercontent.com/u/55728161/linux-headers-3.14.2-amdfixes5%2B_1.0_amd64.deb
sudo dpkg -i *amdfixes5*deb

The patch is here: http://sprunge.us/XcQW
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Big Grin 
(2014-04-27, 12:54)fritsch Wrote: You are running fglrx. Please follow the howto.

Right! Remove fglrx and use xorg open-source driver. All works perfectly! Thanks! Big Grin
As you are now on the radeon boat, test the above kernels if you have time :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2014-04-27, 17:55)fritsch Wrote: Here are the kernels and the patch:

Code:
wget https://dl.dropboxusercontent.com/u/55728161/linux-image-3.14.2-amdfixes5%2B_1.0_amd64.deb https://dl.dropboxusercontent.com/u/55728161/linux-headers-3.14.2-amdfixes5%2B_1.0_amd64.deb
sudo dpkg -i *amdfixes5*deb

The patch is here: http://sprunge.us/XcQW

This kernel works great on a4 3400, xubuntu64 full desktop 14.04 release + Fernetmenta ppa. No additional skips 1080px23.976 and 1080ix29.97 (temporal deint) = amazing PQ improvement (goodbye Judders and skips). Thanks so much. Some version of this must go mainline. OE 4.0 with this patch actually made my Zotac AQ01 perfect, 1080ix29.97+ temporal, a OK.
gfisher, does suspend/resume work on your AQ01?
  •   
  • 1
  • 174
  • 175
  • 176(current)
  • 177
  • 178
  • 244
  •   
  Thread Closed
 
Thread Rating:
  • 26 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
Radeon OSS with vdpau (howto)4.5826