•   
  • 1
  • 179
  • 180
  • 181(current)
  • 182
  • 183
  • 244
  •   
  Thread Closed
Linux Radeon OSS with vdpau (howto)
(2014-05-06, 21:17)fritsch Wrote: Yes. AMD OSS drivers only can do Full Range for now, which is a big problem when the output devices wants to be smart and converts everything between 0..255 by itself. When you now send "pseudo limited range" (that setting in xbmc) it gets even worse ... head over to bugs.freedesktop.org and file a nice bug report.

This is one of the things we clearly miss in the OSS drivers for now.

4K decoding
Limited Range setting

So can you recommend me what i can make to watch movies in correct display . Previously i use xbmc 11 with xvba , should i rollback to that setup ?
Is that problem occurs with that TV which i got or what ?
I have nothing to recommend. OSS drivers have that limitation. You can easily use "old" OpenELEC 3.2 until that feature is implemented in the drivers. I would look at the TV before again, perhaps you find something concerning HDMI Black level. Which exact brand is it?

Don't forget the asked for xrandr output.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
That is sony lcd tv .
What kind output from xrandr.
Dont use openlec , i use ubuntu .
DISPLAY=:0 xrandr --verbose | pastebinit

there is no fglrx / xvba solution anymore. We burned the code and we killed that driver ...
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Thx for help
http://paste.ubuntu.com/7406443/
Yeah, not implemented, yet - so the above possiblities.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Fritsch.

On the first page it should be: sudo apt-add-repository ppa:team-xbmc/ppa, as stated on page 176.

This is working nearly perfect on AM1H-ITX with the Athlon 5150.

Keep up the good work.
Thx - will fix.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Hi all,

I'm running a E350 and currently updated from 13.10 to 14.04. After purging the necessary ppa and readding the wsnipex/mesa ppa for trusty xbmc works again.
But I'm still experiencing some problems:
- qvdpautest states that VC1 is not supported
- in XBMC when playing a video file there is screen tearing consistent with no vsync even though vsync is enabled in XBMC as well as the sync video to screen option.
disabling these options doesn't make any difference...

I tested with both kernel 3.13.6 and kernel 3.14.2-amdfixes

logs:
dmesg | pastebinit
http://paste.ubuntu.com/7409153/
cat ~/.xbmc/temp/xbmc.log | pastebinit
http://paste.ubuntu.com/7409154/
cat /var/log/Xorg.0.log | pastebinit
http://paste.ubuntu.com/7409155/
DISPLAY=:0 vdpauinfo | pastebinit
http://paste.ubuntu.com/7409157/
dpkg -l |grep mesa | pastebinit
http://paste.ubuntu.com/7409159/
Replace /etc/init/xbmc.conf with the new file from the howto. This will disable backing store.

VDPAU on AMD can only do VC1 advanced,
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2014-05-07, 11:08)fritsch Wrote: Replace /etc/init/xbmc.conf with the new file from the howto. This will disable backing store.

VDPAU on AMD can only do VC1 advanced,

Right the VC1 part I understand since I found that as well, still that doesn't explain why this is possible in the how-to:
Quote:qvdpautest 0.5.2
AMD E-350 Processor
Unknown GPU

VDPAU API version : 1
VDPAU implementation : G3DVL VDPAU Driver Shared Library version 1.0

FATAL: get_bits failed : No backend implementation could be loaded.!!
MPEG DECODING (1920x1080): 59 frames/s
MPEG DECODING (1280x720): 92 frames/s
H264 DECODING (1920x1080): 38 frames/s
H264 DECODING (1280x720): 70 frames/s
VC1 DECODING (1440x1080): 85 frames/s
MPEG4 DECODING (1920x1080): 54 frames/s
MIXER WEAVE (1920x1080): 275 frames/s
MIXER BOB (1920x1080): 439 fields/s

While I use the same processor I can't seem to get the VC1 benchmark working...

(and apparently I can't type either today...)
Ah yes - that's confusing, correct :-)

It only supports VC1 Advanced.

qvdpautest tests VC1 Main. This worked in a very old mesa prior to 10.0 but was patched out by AMD cause most chips don't really do it.

Edit: Remove those two lines: https://github.com/robertmassaioli/qvdpa...er.cpp#L59 and retry.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2014-05-07, 11:08)fritsch Wrote: Replace /etc/init/xbmc.conf with the new file from the howto. This will disable backing store.

VDPAU on AMD can only do VC1 advanced,

So I found out there was no /etc/init/xbmc.conf nor an /etc/init.d/xbmc.conf... After creating /etc/init/xbmc.conf according to the how-to nothing changed.
This is probably do to the fact that I started out with a full ubuntu 12.10 back in the xvba days (I know I shouldn't use that cursed word here anymore) and upgraded my way up to 13.10 + OSS and now 14.04.

Long story short, since I have full DE the installation of XBMC added a XBMC DE for me in the list of DE's I can choose from in the login screen. Currently I'm automatically logged in to the last used DE on boot, which would explain the lack of /etc/init/xbmc.conf. Still since this is the case I figure there should be a xbmc.conf somewhere which I probably should edit accordingly, though I'm not sure where I could find it...

Anyone has any bright ideas?

P.S. I'm sorry, but I have absolutely no clue what "backing store" is... Confused

P.P.S. I know it would have been probably best to start with a fresh Trusty mini install, but since I use this server for a lot more then just XBMC, I was hoping to get it working this way. If everything else fails I will start over from scratch, but was hoping to avoid that...

Thanks for all the help wsnipex and fritsch for helping us all out so much!
Then you are not running that howto at all, but something else with probably lightdm and other things - not handled by this howto.

Never the less, you need to disable backing store (I showed how this works within that howto) - that won't work for you, though ... remove the xbmc.conf(!) it will cause harm in that combination.

Post your /etc/lightdm/lightdm.conf ...

Edit:
Cause today is not such a bad day as yesterday, adjust your lightdm.conf to the following:

edit /etc/lightdm/lightdm.conf

Code:
[SeatDefaults]
xserver-command=/usr/bin/X -bs -nolisten tcp
autologin-user=xbmc
autologin-user-timeout=0
user-session=XBMC
greeter-session=lightdm-gtk-greeter

This is not(!) needed for this howto - just for your not following it
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2014-05-07, 12:38)fritsch Wrote: Then you are not running that howto at all, but something else with probably lightdm and other things - not handled by this howto.

Never the less, you need to disable backing store (I showed how this works within that howto) - that won't work for you, though ... remove the xbmc.conf(!) it will cause harm in that combination.

Post your /etc/lightdm/lightdm.conf ...

Edit:
Cause today is not such a bad day as yesterday, adjust your lightdm.conf to the following:

edit /etc/lightdm/lightdm.conf

Code:
[SeatDefaults]
xserver-command=/usr/bin/X -bs -nolisten tcp
autologin-user=xbmc
autologin-user-timeout=0
user-session=XBMC
greeter-session=lightdm-gtk-greeter

This is not(!) needed for this howto - just for your not following it

It's true I never completely followed the xvba or this How-to, still a lot of the things add up anyway and I could never have done all this without these great how-to's. And since I didn't follow it to the letter I try to fix as many of my problems on my own, still this was something I just couldn't wrap my head around...
After your last post it all made sense and a quick search indeed viewed the awnsers to the problem as you stated above. I just didn't know where to look for before that. (my mistake I know)

Thanks allot for taking the time to help me, I really appreciate it!
  •   
  • 1
  • 179
  • 180
  • 181(current)
  • 182
  • 183
  • 244
  •   
  Thread Closed
 
Thread Rating:
  • 26 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
Radeon OSS with vdpau (howto)4.5826