RetroPlayer and Rom Collection Browser
#16
(2013-12-30, 09:07)tommymsw Wrote: I have everything working well except that I can't get RCB working at all. It does not ask me if I want to use retroplayer and the options in RCB don't look anything like the screen shot I see here (I have no "Use RetroPlayer" option in RCB). I have 2.0.11 installed. Also when I add the path in file manager OR as a file path under Games/files, if I restart XBMC, I have to add the path again. It does not remain. Sad

I am having the same issue, except to say that RCB works as originally intended, but there is no RetroPlayer option included.
Reply
#17
Thx Rome.

For those like me waiting for retroplayer I wrote a script that :
installs retroarch/libretro and configures rcb with a selection (you will be prompted) of consoles.
Currently supported : NES, SNES, SMS, Genesis, PS1

https://www.dropbox.com/s/qdsba7223sm8aa...ohelper.sh

How to use :
1. connect a keyboard to your xbmc (if not already)
2. press alt+ctrl+F1
(Or connect over ssh)
3. Login
4. Execute next lines :
Code:
wget https://www.dropbox.com/s/qdsba7223sm8aam/retrohelper.sh
chmod +x retrohelper.sh
./retrohelper
Follow the onscreen instructions.
When done Press ctrl+alt+F7 to return to xbmc.
Reply
#18
(2014-01-07, 02:50)Komerad Wrote: Thx Rome.

For those like me waiting for retroplayer I wrote a script that :
installs retroarch/libretro and configures rcb with a selection (you will be prompted) of consoles.
Currently supported : NES, SNES, SMS, Genesis, PS1

https://www.dropbox.com/s/qdsba7223sm8aa...ohelper.sh

How to use :
1. connect a keyboard to your xbmc (if not already)
2. press alt+ctrl+F1
(Or connect over ssh)
3. Login
4. Execute next lines :
Code:
wget https://www.dropbox.com/s/qdsba7223sm8aam/retrohelper.sh
chmod +x retrohelper.sh
./retrohelper
Follow the onscreen instructions.
When done Press ctrl+alt+F7 to return to xbmc.

Anyway to do this on a windows system?
Reply
#19
The script is for xbmcbuntu (probably works on ubuntu just aswel).
So it won't work on windows.
You can make a script that does the same for windows tho but I wont as :
1. I currently have no interest in running htpc's on windows.
2. I'm not done with the script. It needs some refinement, I need to add configuration of controllers. And there are other scripts in the pipeline.
3. I barely have time for point 2 Smile

PS : if ur on windows try "hyperspin" you could save yourself some work.
http://www.youtube.com/watch?v=9IbPFALGDp0
Reply
#20
(2014-01-08, 18:36)Komerad Wrote: The script is for xbmcbuntu (probably works on ubuntu just aswel).
So it won't work on windows.
You can make a script that does the same for windows tho but I wont as :
1. I currently have no interest in running htpc's on windows.
2. I'm not done with the script. It needs some refinement, I need to add configuration of controllers. And there are other scripts in the pipeline.
3. I barely have time for point 2 Smile

PS : if ur on windows try "hyperspin" you could save yourself some work.
http://www.youtube.com/watch?v=9IbPFALGDp0

Eh... Thanks man, but executor addon is long gone (since like 2010) I think, and advanced launcher is also marked as broken. Doesn't seem to be any launcher addons that work with xbmc anymore. I wish I had checked that before setting up hyperspin though. lol It's no big deal... I am not a "gamer" anyway. I just like to mess with XBMC when I am bored.
Reply
#21
(2014-01-09, 05:16)tommymsw Wrote:
(2014-01-08, 18:36)Komerad Wrote: The script is for xbmcbuntu (probably works on ubuntu just aswel).
So it won't work on windows.
You can make a script that does the same for windows tho but I wont as :
1. I currently have no interest in running htpc's on windows.
2. I'm not done with the script. It needs some refinement, I need to add configuration of controllers. And there are other scripts in the pipeline.
3. I barely have time for point 2 Smile

PS : if ur on windows try "hyperspin" you could save yourself some work.
http://www.youtube.com/watch?v=9IbPFALGDp0

Eh... Thanks man, but executor addon is long gone (since like 2010) I think, and advanced launcher is also marked as broken. Doesn't seem to be any launcher addons that work with xbmc anymore. I wish I had checked that before setting up hyperspin though. lol It's no big deal... I am not a "gamer" anyway. I just like to mess with XBMC when I am bored.

I'm using advanced launcher, so it's working.
Reply
#22
(2014-01-09, 05:16)tommymsw Wrote: Eh... Thanks man, but executor addon is long gone (since like 2010) I think, and advanced launcher is also marked as broken. Doesn't seem to be any launcher addons that work with xbmc anymore. I wish I had checked that before setting up hyperspin though. lol It's no big deal... I am not a "gamer" anyway. I just like to mess with XBMC when I am bored.
Advanced Launcher is marked as broken on XBMC repository, it doesn't mean that this addon is not working on XBMC... It's just mean that it is marked as broken and so you cannot install it. If you want the last working version of Advanced Launcher, install and use the Angelscry's repository : http://forum.xbmc.org/showthread.php?tid=85724
Here is the installation guide : http://www.gwenael.org/forum/viewtopic.php?pid=3#p3
Reply
#23
(2014-01-14, 15:21)Angelscry Wrote:
(2014-01-09, 05:16)tommymsw Wrote: Eh... Thanks man, but executor addon is long gone (since like 2010) I think, and advanced launcher is also marked as broken. Doesn't seem to be any launcher addons that work with xbmc anymore. I wish I had checked that before setting up hyperspin though. lol It's no big deal... I am not a "gamer" anyway. I just like to mess with XBMC when I am bored.
Advanced Launcher is marked as broken on XBMC repository, it doesn't mean that this addon is not working on XBMC... It's just mean that it is marked as broken and so you cannot install it. If you want the last working version of Advanced Launcher, install and use the Angelscry's repository : http://forum.xbmc.org/showthread.php?tid=85724
Here is the installation guide : http://www.gwenael.org/forum/viewtopic.php?pid=3#p3

Thank you for the info. It sucks that they mark it as broken, you think you could trust that. But I'm on Gotham now so I will have to wait a bit it seems. (I know, I upgraded early but I NEEDED Gotham, my TV is 3D and it allowed me to free up a TON of HD space). I will patiently wait for a Gotham version and thank you again for the info. I assume when a Gotham version comes out, I will be able to install it though the Angelscry's repository. Smile
Reply
#24
To bypass install incompatibility problem with Gotham version, you can perform a full manual installation of Advanced Launcher :
  • Close XBMC
  • Download the last version of Advanced Launcher from here : http://www.gwenael.org/Repository%20Archives/
  • Decompress the .zip file.
  • Copy/paste the plugin.program.advanced.launcher into the xbmc/addons directory.
  • Restart XBMC
Once Gotham will not become the official stable version, you will have to perform like this. Once Gotham will be released, Angelscry's Repository and Advanced Launcher will be updated to work with this last version.
Reply
#25
Oh cool, so it works with Gotham then? thank you. Smile
Reply
#26
The add-on do not install automatically with Gotham due to Python version dependencies, but, once you have installed manually by yourself, yes it works with Gotham.
Reply
#27
Thank you Angelscry, it works perfectly! Smile
Reply
#28
(2013-10-04, 18:11)malte Wrote: If RCB detects that your XBMC build is RetroPlayer-ready it will ask you if you want to use RetroPlayer to launch games.

I'm running a test build from here. OpenELEC 3.2.0 General x86_64 (upgraded to 3.10), and XBMC 13.0-alpha7, and Aeon MQ5. When I click to lauch games it's linked to RCB and suggests to create a config file, should it not at this point detect RP and automate the emulator script configuration?
HTPC RPI3 Kodi 17 (Krypton) v8.0.1 MR
Storage BPI 1x 500GB SSD UPnP server
Display Sony Bravia 32"
Reply
#29
(2014-01-27, 03:11)n1md4 Wrote:
(2013-10-04, 18:11)malte Wrote: If RCB detects that your XBMC build is RetroPlayer-ready it will ask you if you want to use RetroPlayer to launch games.

I'm running a test build from here. OpenELEC 3.2.0 General x86_64 (upgraded to 3.10), and XBMC 13.0-alpha7, and Aeon MQ5. When I click to lauch games it's linked to RCB and suggests to create a config file, should it not at this point detect RP and automate the emulator script configuration?
Are you on one of the latest RCB releases? Can you upload a log after you tried this? Maybe I can see why it is not working.
Reply
#30
I'm running RCB 2.0.10.
HTPC RPI3 Kodi 17 (Krypton) v8.0.1 MR
Storage BPI 1x 500GB SSD UPnP server
Display Sony Bravia 32"
Reply
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
RetroPlayer and Rom Collection Browser52