Thread Rating:
  • 2 Vote(s) - 4.5 Average
OSX Mavericks and MKV files
#1
Hi, i updated my mac mini to OSX Mavericks and some mov files doesn't deinterlace correctly
Reply
#2
Is deinterlacing turned on? http://wiki.xbmc.org/index.php?title=Vid...o_settings
Reply
#3
Yes, with macos 10.8 and any version of XBMC from 12 to 13 in Auto Mode works OK, baut with Mavericks i've to turn on and select the mode to view it, and with some files in mkv the colors doen't correct
Reply
#4
i too have this issue, here's what it's looking like w/o the deinterlacing:
Image

here's with it turned on (auto seems to be the best result but far from correct)

Image
Reply
#5
How does it look if you turn off hardware decoding in system->video->playback
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#6
(2013-10-25, 11:01)Memphiz Wrote: How does it look if you turn off hardware decoding in system->video->playback
I have the same issue with some files, and indeed turning off hardware decoding "fixes" the problem. Both shader options and automatic mode result in the corruption pictured above.
Reply
#7
thx for the feedback
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#8
Could you post an example file to dropbox or so? (like 50MB max). Ensure that the sample shows the problem.

Also we need to know which hardware you are using (which mac which graphics card).
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#9
I've uploaded a sample to dropbox: https://www.dropbox.com/s/23q42bctgvtnha...Sample.mkv
It's especialy visible with reds on my system, a 2012 Mac Mini with an Intel HD4000
Reply
#10
(2013-10-25, 12:28)Banjer Wrote:
(2013-10-25, 11:01)Memphiz Wrote: How does it look if you turn off hardware decoding in system->video->playback
I have the same issue with some files, and indeed turning off hardware decoding "fixes" the problem. Both shader options and automatic mode result in the corruption pictured above.

I'm having the same issue, with the added problem that i don't have the option to turn off hardware decoding on my MacBook Pro.
System -> Video -> Playback doesn't get me there. Any suggestions?

Thanks in advance.
Reply
#11
Quote:I'm having the same issue, with the added problem that i don't have the option to turn off hardware decoding on my MacBook Pro.
System -> Video -> Playback doesn't get me there. Any suggestions?


Using the confluence skin, go into settings. Toggle left and you can access the tiers from the side menu bar. You'll need to enable the advanced mode.
Nvidia Shield
Apple TV 4
Reply
#12
(2013-10-30, 21:58)beemarp Wrote: Using the confluence skin, go into settings. Toggle left and you can access the tiers from the side menu bar. You'll need to enable the advanced mode.

Thanks a lot, found it.

And indeed, turning hardware decoding off fixes the problem here, too.
Reply
#13
Agreed 100 percent BTW. Thanks for mentioning this as the fix. As long as I keep hardware decording off under my Mac Mini using Mavericks, my files are playing judder-free.

Doesn't seem to be affecting performance in any way to have have decoding off for now, so I'm pleased to leave it this way until the devs have time to catch up.

If any devs think they have it fixed, and want me to install a nightly and try turning it back on, I'm happy to do so. For now, just happy to be up and running!
Reply
#14
Same problem here. Must be "Software" decoder to work.
Reply
#15
I've found this happens with some MKV files and not others. Some run smooth with hardware turned on. Others skip a TON of frames unless I turn it off.

I'll put together some logs and post in the hopes I can help out the devs to track down the bug. Likely there is one aspect of some MKV files that is throwing it off. Could be related to a frame rate, sound codec, etc.

The key will be figuring out what the difference is between the MKVs that work and the ones that don't work.
Reply
 
Thread Rating:
  • 2 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
OSX Mavericks and MKV files4.52