[IPTV] No Video, just Sound

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
crossx1 Offline
Junior Member
Posts: 2
Joined: Sep 2013
Reputation: 0
Post: #1

I've got my Raspberry Pi for a week now and set it up with Raspbmc.

Now I'm trying to get IPTV working (with TVHeadend, IPTV provider is a german one: T-Home Entertain), and so far I got Raspbmc to play the sound, after disabling Raspbmc's firewall, but no video. It seems like I'm just playing a Radio station, because I don't even get a black screen or something similar. It keeps showing me the channel list and I can switch between them.

I've bought and activated the MPG2 Codec, but it didn't help. I attached the codec information I got with VLC.

What makes me wonder, is that when I record a show, it works really good. After that I can watch the record without any problems on my Raspberry Pi.

PS: Here's my xbmc.log, I hope it helps: http://xbmclogs.com/show.php?id=66735

And here's the recordings codec information:

[Image: eedvmcwtynlo.jpg]

EDIT: I now tried it a different way and set up a recording timer for a tv show, which was playing live on tv.
While it was recording, I already played the ongoing recording back and it worked. This way I could watch live tv with a litte bit of delay because of setting up the timer (similar to timeshift). So why can't I get it playing without recording? Hope anybody can help Smile
(This post was last modified: 2013-10-07 15:04 by crossx1.)
find quote
crossx1 Offline
Junior Member
Posts: 2
Joined: Sep 2013
Reputation: 0
Post: #2
Just a quick update:

(((I now have managed to get it working. I guess there was a problem with Raspbmc, I tried OpenElec and it works just fine.
HD- and SD-Channels both without any lags. Smile

Does anyone know why Raspbmc didn't want to play my streams?)))

(((Edit: I have to revise my comment above. It wasn't Raspbmc which didn't let me watch TV, it was the skin. Previously I used Xperience1080, now I'm using Confluence and it works fine.)))

Edit 2: I got it working now with xperience1080 as well. 'Minimized playback' was activated on channel select, but because xperience1080 doesn't have a minimized playback window, I could only hear the sound. Now it works like a charm!
(This post was last modified: 2013-10-09 23:26 by crossx1.)
find quote